Affichage des résultats 1 à 7 sur 7

Discussion: Probleme mail postfix

  1. #1
    Membre
    Date d'inscription
    October 2012
    Localisation
    Bordeaux
    Messages
    37

    Probleme mail postfix

    Bonjour,
    j'ai installé mon premier site sur mon serveur, je test la messagerie pas de problème
    Je reçois les mails avec windows live mail que j'envois a partir du serveur
    le probleme arrive après l'installation du deuxieme nom de domaine
    La les mails tourne en boucle sur le serveur
    Parte et arrive dans la Boîtes aux lettres des usagers

    main.cf
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = no

    # TLS parameters
    smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
    smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
    smtpd_use_tls=yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = ks206043.kimsufi.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = ks206043.kimsufi.com, localhost.kimsufi.com, , localhost
    relayhost =
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0/104 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    virtual_alias_maps = hash:/etc/postfix/virtual
    sender_bcc_maps = hash:/etc/postfix/bcc
    mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
    home_mailbox = Maildir/
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
    allow_percent_hack = no
    sender_dependent_default_transport_maps = hash:/etc/postfix/dependent
    master.cf

    #
    # Postfix master process configuration file. For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ================================================== ========================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ================================================== ========================
    smtp inet n - - - - smtpd -o smtpd_sasl_auth_enable=yes
    #submission inet n - - - - smtpd
    # -o smtpd_tls_security_level=encrypt
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #smtps inet n - - - - smtpd
    # -o smtpd_tls_wrappermode=yes
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #628 inet n - - - - qmqpd
    pickup fifo n - - 60 1 pickup
    cleanup unix n - - - 0 cleanup
    qmgr fifo n - n 300 1 qmgr
    #qmgr fifo n - - 300 1 oqmgr
    tlsmgr unix - - - 1000? 1 tlsmgr
    rewrite unix - - - - - trivial-rewrite
    bounce unix - - - - 0 bounce
    defer unix - - - - 0 bounce
    trace unix - - - - 0 bounce
    verify unix - - - - 1 verify
    flush unix n - - 1000? 0 flush
    proxymap unix - - n - - proxymap
    proxywrite unix - - n - 1 proxymap
    smtp unix - - - - - smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay unix - - - - - smtp
    -o smtp_fallback_relay=
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - - - - showq
    error unix - - - - - error
    retry unix - - - - - error
    discard unix - - - - - discard
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - - - - lmtp
    anvil unix - - - - 1 anvil
    scache unix - - - - 1 scache
    #
    # ================================================== ==================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent. See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ================================================== ==================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop unix - n n - - pipe
    flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # ================================================== ==================
    #
    # Recent Cyrus versions can use the existing "lmtp" master.cf entry.
    #
    # Specify in cyrus.conf:
    # lmtp cmd="lmtpd -a" listen="localhost:lmtp" proto=tcp4
    #
    # Specify in main.cf one or more of the following:
    # mailbox_transport = lmtp:inet:localhost
    # virtual_transport = lmtp:inet:localhost
    #
    # ================================================== ==================
    #
    # Cyrus 2.1.5 (Amos Gouaux)
    # Also specify in main.cf: cyrus_destination_recipient_limit=1
    #
    #cyrus unix - n n - - pipe
    # user=cyrus argv=/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
    #
    # ================================================== ==================
    # Old example of delivery via Cyrus.
    #
    #old-cyrus unix - n n - - pipe
    # flags=R user=cyrus argv=/cyrus/bin/deliver -e -m ${extension} ${user}
    #
    # ================================================== ==================
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp unix - n n - - pipe
    flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix - n n - 2 pipe
    flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman unix - n n - - pipe
    flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
    ${nexthop} ${user}

    submission inet n - - - - smtpd -o smtpd_sasl_auth_enable=yes
    Dernière modification par Falcon 10/12/2012 à 12h22

  2. #2
    Membre
    Date d'inscription
    October 2012
    Localisation
    Bordeaux
    Messages
    37

    Re : Probleme mail postfix

    bon, personne

  3. #3
    Membre
    Date d'inscription
    October 2010
    Localisation
    Sud-Ouest
    Messages
    3 264

    Re : Probleme mail postfix


    Si, bien sur.

    Mais on attend encore.
    Il manque deux trois truc comme:
    Quel OS ?
    T'as un click-face, ou non (et si c'est qui => ton seule espoir: va voir chez eux - ou regarde dans leur doc)

    Sinon, oui, j'ai deux, trois idées.
    Certainement pas 'la' solution car avec postfix (et ces dizaines des fichiers de config - t'en donnée que 2) sans logs ni accès a rien c'est de l'impossible au mieux.

  4. #4
    Membre
    Date d'inscription
    November 2012
    Localisation
    france
    Messages
    138

    Re : Probleme mail postfix

    je vois qu'une erreur le serveur écoute pas l'exterrieur sur
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0/104 [::1]/128
    ajoute l'ip de ton serveur sur cette ligne
    sinon mois j'avais eu un problème avec les noms de domaine j'avais remplacer le nom de domaine par la reverse dns mydestination sa avais résolu le problème peut être bon pour toi à tester après suis pas un pro de postfix mais si c'est sa tant mieux

    si tu connais pas la reverse dns c'est pas compliquer pour l ip 82.242.115.123 la reverse c'est 123.115.242.82.in-addr.arpa pour faire cour le dns donne l'ip la reverse dns donne le dns pour le mail c'est indispensable en ip V6 je sais pas du tout comment sa se passe mais en V4 c'est comme sa .

    NOWHAT : c'est linux debian c'est le fichier autogenere à l'installation par l'apt-get .... parcontre c'est vrais sa manque surtout d'un bout de /var/log/syslog et d'un bout de /var/log/mail.log
    Dernière modification par overdrive 10/12/2012 à 16h59

  5. #5
    Membre
    Date d'inscription
    October 2010
    Localisation
    Sud-Ouest
    Messages
    3 264

    Re : Probleme mail postfix

    Citation Envoyé par overdrive Voir le message
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0/104 [::1]/128
    J'ai ça moi, et exactement ça.
    Et pas plus.

    Car, le webmail sur le serveur dépose les mails sur 'localhost' = 127.0.0.1
    Et mes clients mail contacte mon serveur sur mes divers IP-extérieur:587 - comme Falcon.

    Mais, Falcon, tu possède plusieurs domaines sur un même serveur, donc je te conseille de lire ceci: http://www.howtoforge.com/virtual-us...l-debian-lenny
    C'est un tuto pour Lenny, mais valable pour Squeeze aussi.

  6. #6
    Membre
    Date d'inscription
    October 2012
    Localisation
    Bordeaux
    Messages
    37

    Re : Probleme mail postfix

    Probleme resolu
    j'ai 3 domaines du même nom an .fr .net et .com
    postfix n'aime pas

  7. #7
    Membre
    Date d'inscription
    October 2010
    Localisation
    Sud-Ouest
    Messages
    3 264

    Re : Probleme mail postfix

    Citation Envoyé par Falcon Voir le message
    ...
    j'ai 3 domaines du même nom an .fr .net et .com
    postfix n'aime pas
    De plus, ces trois domaines ont le même IP !
    postfix aime pas ça non plus ?

    postfix s'en fout totalement de ton domaine, il gère très bien un domaine, voir plus. Sans restrictions sur leur noms (quoi que - évite les accents stp)

    T'as un doc de postfix qui détaille pourquoi il n'aime pas ça ?

Règles de messages

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •