OVH Community, your new community space.

Install archlinux inside archlinux (as rescuepro=debian didn't work)


anyone
07/02/2014, 13h47
I was able to install archlinux.
1. install archlinux over webinterface (don't forget to partition the hdd for a second archlinux installation)
2. install arch-install-scripts (maybe some more are needed but this is the most important)
3. install from the OVH-archlinux your own archlinux (don't forget to set IP, GRUB/syslinux [syslinux is easier] and permanent network adapter name)
4. try to start your new archlinux


The current problem (I haven't got any help from https://bbs.archlinux.org/ ) is that it isn't starting...
I think there is a kernel panic but I was not able to debug it so far since I am not a linux genius.

That's why I am going to give it up, I already spent a month for this,
I want to use the server and not sitting in front of my PC and reading sites for hours.

Peter Littmann
07/02/2014, 09h55
I am working on this, also. So far I am able to run pacman. in the chroot.

anyone
06/02/2014, 22h59
I still wasn't successful so it is interesting.
The installer over the webinterface is not an option for me.
I cannot be sure that every feature is under my control, I need to install and configure archlinux myself.

Since I tried it for over a month I will probably give it up and install Debian instead.

Peter Littmann
06/02/2014, 15h45
Is this question still interesting for you? In the new webinterface there is a menuentry Arch Linux(autoinstaller, latest version) (BETA)

anyone
15/01/2014, 21h47
After the pretty annoying registration (in french _ -- drop that, saw the language settings at the bottom left just now)
I hope to find here some help.
For about one week I am trying to install archlinux without ovh's 'special' abilities.

tl;dr: Was anyone able to install archlinux with a kimsufi server without their special abilities?

1. I tried it with the rescuepro, since it is debian, I had problems to install, "pacstrap -i /mnt base" gave me an error:
Code:
[root@rescue /]# pacstrap -i /mnt base
==> Creating install root at /mnt
mount: mount point /mnt/dev/pts does not exist
==> ERROR: failed to setup API filesystems in new root
/dev/pts was created and mounted properly, it didn't help.
(Same problem here -> https://bbs.archlinux.org/viewtopic.php?pid=1231074 )

2. Well, not really the second try (tried it several times with the rescuepro).
I installed Arch-Linux over the webinterface (I hate their partition manager), the partitions had been made that way I could install a second system to install my "real" system... it is much work but it's only one time or as long as the hdd doesn't crash.
Arch-Linux with ovh abilities was working, the old grub-common was installed, it looked good to get archlinux installed from there.
So, I partitioned the drive, updated and installed arch-install-scripts.
Mount the partitions correctly (with arch-chroot it was much easier) und well, pacstrap worked!

I could chroot into the system, get openssh and install the bootloader, grub (because I know how to use it).
I followed the following tutorial several times -> https://wiki.archlinux.org/index.php/Beginners%27_Guide
But the server got never past grub. (I would've understand if I got wrong IP settings.)
How do I know this? The /var/log/ don't have any logs except a few logs from installing packages, no dmesg or anything like that.

'mkinitcpio -p linux' is going well, 'grub-install --recheck /dev/sda' works and 'grub-mkconfig -o /boot/grub/grub.cfg' is correct. fstab is of course correct.

Did someone else got archlinux installed this way?
I am clueless what I may have done wrong.