OVH Community, your new community space.

SSH : Connexion refusée


BBR
26/01/2014, 14h33
sécuriser et ne pas s'arrêter là, ensuite il faut mettre à jour régulièrement, surtout si tu utilises des CMS, forums, etc. entrer par WP est courant s'il n'est pas à jour

Jeremie13
26/01/2014, 13h22
Bonjour,

Merci pour les informations. Tous mes applications autres que SSH ont démarrées. Mais toujours impossible de s'y connecter. Je vais mettre mon serveur en mode rescue et recuperer ce que je peux. Si jamais je n'arrive pas à refaire fonctionner le SSH, je formaterais.

Cordialement,

Jérémie

EDIT :

Bon après avoir relancer le serveur en mode Rescue,

j'ai vu des données bizarre sur le wordpress de ma copine et sur le serveur de type :

(2,'Arnold','$P$BLejX3/Qf2OV00La3kad.dD0Whgl3G0','arnold','edek.kredee@o2 .pl','','2014-01-13 05:17:04','',0,'Arnold');


Je pense qu'un petit malin à trouvé un moyen d'entrer sur mon serveur ce qui me pousse à le formater.
Ca m'apprendra je pense à ne pas avoir assez sécuriser mon serveur.

Kitty
25/01/2014, 21h29
Citation Envoyé par nowwhat
Faire un fsck et déjà lancer le service FTP, à mon vis, ça c'est nouveau.
Je n'ai pas vu ce (FTP).

Mais, peut-être FTP démarre comme un service, en tout cas, même si une vérification est nécessaire?

--
I didn't see this (FTP).

But, maybe FTP starts as a service in any case, even when a check is needed?

nowwhat
25/01/2014, 20h34
Juste une chose.
Un serveur qui redémarre peut faire un fsck, ça arrive.
Mais dans ce cas précis:
Point notable, mon serveur répond en FTP et aux pings.
Faire un fsck et déjà lancer le service FTP, à mon vis, ça c'est nouveau.
Il convient de parler d'un serveur qui n'a plus de service SSH tout simplement (crashé, stoppé, etc).

Je conseille plutôt un hard reboot car il n'y pas d'autre moyen de relancer le SSH, et pendant le temps de démarrage, un peu de lecture: http://guides.ovh.com/ModeRescue

Je présume que le serveur de Jeremie13 ne possède pas un interface "clique" (CPanel, ISPConfig, VirtualMin etc) ou le serveice peut être stoppé et activé à la demande.

Kitty
25/01/2014, 20h26
Si je vois une question que je peux répondre, je vais

--

If I see a question I can answer, I do

BBR
25/01/2014, 20h22
si tu es anglophone autant utiliser cette partie : http://forum.kimsufi.com/forumdispla...s-(KS)-English

Kitty
25/01/2014, 20h15
J'utilise la traduction automatique, qui n'est pas toujours bon, si j'inclus l'original. Quelqu'un qui parle anglais pourrait préférer le poste anglais.

Aussi, afin que ceux qui cherchent en anglais pourraient trouver une réponse à leur question.

--

I use machine translation, which is not always good, so I include the original. Someone who speaks English might prefer the English post.

Also, so that others who search in English might find an answer to their question

BBR
25/01/2014, 20h10
C'est la partie francophone du forum, pourquoi mettre systématiquement en anglais ?

Kitty
25/01/2014, 20h04
En heures? Non, désolé. Il dépend de la taille du disque. Les grands disques peuvent prendre un certain temps.

Vous pouvez désactiver la vérification dans le fichier /etc/fstab.

Par exemple, pour désactiver la vérification sur /dev/md2:
Code:
VIEUX 
#                
/dev/md1         /             ext3   errors=remount-ro  1      1 
/dev/md2         /home         ext3   defaults           1      2 

NOUVEAU 
#                
/dev/md1         /             ext3   errors=remount-ro  1      1 
/dev/md2         /home         ext3   defaults           0      2
--

In hours? No, sorry. It depends on the size of the drive. Large drives can take a long time.

You can disable the check in /etc/fstab.

For instance, to disable the check on /dev/md2:
Code:
OLD
#                
/dev/md1         /             ext3   errors=remount-ro  1      1 
/dev/md2         /home         ext3   defaults           1      2 

NEW 
#                
/dev/md1         /             ext3   errors=remount-ro  1      1 
/dev/md2         /home         ext3   defaults           0      2

Jeremie13
25/01/2014, 19h18
Citation Envoyé par Kitty
Après un redémarrage, le noyau peut effectuer une vérification de disque (fsck). Si c'est le cas, il refusera les connexions jusqu'à ce qu'il ait fini.
--
After a reboot, the kernel may run a disk check (fsck). If it does, it will refuse connections until it has finished.



Je parle l'anglais
Bonjour,

Je vous remercie de l'information.
Avez vous une idée du temps nécessaire à celà ?

Cordialement,

Jérémie

Kitty
25/01/2014, 18h33
Après un redémarrage, le noyau peut effectuer une vérification de disque (fsck). Si c'est le cas, il refusera les connexions jusqu'à ce qu'il ait fini.
--
After a reboot, the kernel may run a disk check (fsck). If it does, it will refuse connections until it has finished.

Jeremie13
25/01/2014, 18h15
Bonjour,

Depuis aujourd'hui, mon serveur est totalement réfractaire à toute connexion SSH. J'ai bien essayé un reboot via l'admin ovh mais ça n'a rien changé.
Lors que j'essaye de me connecter, j'ai l'erreur "connection refused", que je tente une connexion avec identifiant ou sans identifiant.
Pensant à un blacklistage de mon IP, j'ai tenté de me connecter via un deuxième serveur ( IP différente donc ) et là c’était la même chose.

Je n'ai rien changé sur ce serveur depuis quelques temps ( il me sert de CDN ).
La seule action que j'ai réalisé hier est que j'ai re-souscrit pour trois mois. Je ne sais pas si ça a un lien mais je ne pense pas que j'avais souscrit à l'option payante de la protection OVH anti-DDos.

Point notable, mon serveur répond en FTP et aux pings.

Je préfèrerais avoir à éviter une réinstalle donc si vous avez une idée, je suis preneur.

Jérémie.