OVH Community, your new community space.

Proxmox avec une IP


Ikuto
04/02/2014, 00h02
je pense aussi

en tout cas je te remercie beaucoup pour toute ton aide je pense que je vais foncer vers esx alors

tu pourrais m'envoyer une adresse mail en mp si jamais j'ai encore quelques questions ?

DmilZ
03/02/2014, 22h22
Mea culpa, pfSense est basé sur freebsd... Il faut utiliser netstat avec les bon arguments, et j'en ai pas sous la main. Si tu as l'occasion d'installer ESXi et que tu es plus habitué fonce !

Mon lab est monopolisé pour arriver à tirer quelque chose de Windows et l'installer depuis le mode rescue, j'ai une VM configuré en IPv6 pour la communication extérieur et aucun souci. Je n'ai pas documenté mais aucun souci particulier (penser à fixer l'adresse MAC).

Si tu choisis d'inverser l'IPv4 et l'IPv6 quelque chose me dit que tu trouveras des infos sur ce forum même...

Ikuto
03/02/2014, 21h29
toute les commandes avec route me marque argument invalide, je suis plus habitué à ESXi qu'à proxmox

DmilZ
03/02/2014, 21h17
Depuis une connexion SSH à pfSense (ou via la console) :
ifconfig -a
route -n
route -6

Bizarre tout ça... Étant donné je n'ai pas souvent utilisé Proxmox, je dirais juste qu'ESXi c'est différent A l'inverse de Proxmox tu peux dédier l'IPv6 au Management Network et garder l'IPv4 pour Proxmox (mais tu peux bien sûr garder l'IPv4 sur l'hyperviseur et l'IPv6 dans la VM).

J'avais essayé de passer l'IPv6 pour la gestion de Proxmox pour garder l'IPv4 dans une VM, mais le produit se sert de netcat pour communiquer avec la console VNC. La version de netcat installée n'est pas compatible avec IPv6 et "netcat6" n'a pas les même arguments. Rien d'insurmontable, il faut juste un peu de temps et d'idées.

Ikuto
03/02/2014, 21h03
Ca je l'ai fais des le départ dans proxmox je lui ai demander de creer l'interface virtuel avec la mac de l'eth0 et tout est bien bridge c'est bien ce qui me parait bizarre, mais bon je pense que je vais aller sur de l'esx j'ai l'impression que c'est un poil plus simple

DmilZ
03/02/2014, 20h17
Et soudain.. un souvenir : dans pfSense modifie l'adresse MAC de l'interface WAN pour correspondre avec celle du serveur physique.

Après si ça ne fonctionne toujours pas, je commence à être à court d'idée. Vérifie que que l'interface WAN est bien celle bridgée sur eth0 (ou quelque soit le nom que l'interface physique porte).

Ikuto
03/02/2014, 02h53
j'ai bien configuré l'ip en /56 mais je ne peux toujours pas ping la gateway :/

je commence à désespéré.....

DmilZ
02/02/2014, 23h40
La gateway par défaut est bien 2001:41d0:1:84ff:ff:ff:ff:ff.

Logiquement elle devrait au moins répondre au ping si tu as bien configuré l'IP en 2001:41d0:1:8468::1/56.

Ikuto
02/02/2014, 14h49
Citation Envoyé par DmilZ
Dans la ligne IPv6 address tu entres :"2001:41d0:1:8468::1" / "56"

Pas besoin de renseigner de masque sur la gateway normalement puisqu'elle sera dans le même range.
maintenant que j'ai fais ça à partir du psfense lorsque je fais un ping6 sur les dns ipv6 de google il me dis "UDP connect: no route to host" maintenant il me manque la route par défaut à ajouter mais alors la je ne sais pas quoi mettre non plus quoi

DmilZ
01/02/2014, 23h55
Dans la ligne IPv6 address tu entres :"2001:41d0:1:8468::1" / "56"

Pas besoin de renseigner de masque sur la gateway normalement puisqu'elle sera dans le même range.

Ikuto
01/02/2014, 23h48


c'est vraiment juste la passerelle qui m'énerve....

DmilZ
01/02/2014, 23h37
Je ne comprends pas "la gateway prends le masque de l'adresse ip", je n'ai plus l'interface sous les yeux tu pourrais faire un screenshot ?

Ikuto
01/02/2014, 23h11
Citation Envoyé par DmilZ
Je n'ai jamais utilisé IPv6 directement sur pfSense, mais sur ESXi, Windows ou Linux aucun problème avec le /56, donc oui.
merci pour tes infos alors j'ai tester de mettre l'ipv6 du pfsense en /56 des fois que la gateway passe aussi et malheureusement ca ne fonctionne pas et si je remets comme avant le /64 cela ne marche pas non plus... la gateway prends le masque de l'adresse ip et il n'y a aucun moyens de le configurer autrement je vais faire encore quelque rechercher on sais jamais.

je te remercie quand même de m'avoir aider

DmilZ
31/01/2014, 20h13
Je n'ai jamais utilisé IPv6 directement sur pfSense, mais sur ESXi, Windows ou Linux aucun problème avec le /56, donc oui.

Ikuto
30/01/2014, 23h08
Citation Envoyé par DmilZ
Oui je n'ai jamais compris la logique d'OVH lorsqu'ils configurent IPv6. Si tu regardes bien l'IPv6 est dans un /64 alors qu'officiellement les Kimsufi ont un IP unique donc normalement /128... Dans tous les cas le serveur serait incapable de trouver le gateway qui est bien 2001:41D0:1:84ff:ff:ff:ff:ff. OVH ruse en indiquant l'interface de sortie (ici vmbr0).

Sous pfSense tu dois utiliser la gateway 2001:41D0:1:84ff:ff:ff:ff:ff et le masque 56.
Donc lorsqu'il me demande de mettre le masque ipv6 dans pfsense je dois mettre le /56 si j'ai bien compris ?

je te remercie encore de m'aider pour ça c'est la seul chose qui me manque pour pouvoir tout faire comme je veux pour mon projet ^^

DmilZ
30/01/2014, 19h56
Oui je n'ai jamais compris la logique d'OVH lorsqu'ils configurent IPv6. Si tu regardes bien l'IPv6 est dans un /64 alors qu'officiellement les Kimsufi ont un IP unique donc normalement /128... Dans tous les cas le serveur serait incapable de trouver le gateway qui est bien 2001:41D0:1:84ff:ff:ff:ff:ff. OVH ruse en indiquant l'interface de sortie (ici vmbr0).

Sous pfSense tu dois utiliser la gateway 2001:41D0:1:84ff:ff:ff:ff:ff et le masque 56.

Ikuto
30/01/2014, 04h55
Citation Envoyé par DmilZ
Bonsoir,

Je n'ai pas passer beaucoup de temps sous Proxmox, mais de façon générale j'imagine que la démarche doit être la suivante :
- brigdger une interface sur l'interface physique du serveur (ce qui doit déjà être le cas pour vmbr0)
- ne pas assigner d'adresse IPv6 sur cette interface depuis Proxmo
- monter une VM pfSense qui utilisera vmbr0 pour la patte WAN et lui assigner l'IPv6 (attention il faut que l'adresse MAC de la VM soit la même que la carte réseau physique)

Au passage j'avais remarqué que toute modification réseaux en utilisant le panel avaient tendance à casser la configuration IPv6 de l'hôte.
J'ai commenté la parti ipv6 dans la conf link précédemment

#iface vmbr0 inet6 static
# address 2001:41D0:1:8468::1
# netmask 64
# post-up /sbin/ip -f inet6 route add 2001:41D0:1:84ff:ff:ff:ff:ff dev vmbr0
# post-up /sbin/ip -f inet6 route add default via 2001:41D0:1:84ff:ff:ff:ff:ff
# pre-down /sbin/ip -f inet6 route del default via 2001:41D0:1:84ff:ff:ff:ff:ff
# pre-down /sbin/ip -f inet6 route del 2001:41D0:1:84ff:ff:ff:ff:ff dev vmbr0

dans mon pfsense j'ai bien mis l'adresse mac sur la patte Wan j'ai donc mis aussi l'adresse qu'il y avait dans "address" mais je pense que la gateway ipv6 que j'ai mis dans le la conf de pfsense n'est pas bonne à savoir 2001:41D0:1:8468:ff:ff:ff:ff car quand je met 2001:41D0:1:84ff:ff:ff:ff:ff il me met que les adresses ne sont pas dans le même sous réseau.

je pense qu'il ne me reste plus que ça et ça devrais rouler.

DmilZ
29/01/2014, 00h03
Bonsoir,

Je n'ai pas passer beaucoup de temps sous Proxmox, mais de façon générale j'imagine que la démarche doit être la suivante :
- brigdger une interface sur l'interface physique du serveur (ce qui doit déjà être le cas pour vmbr0)
- ne pas assigner d'adresse IPv6 sur cette interface depuis Proxmo
- monter une VM pfSense qui utilisera vmbr0 pour la patte WAN et lui assigner l'IPv6 (attention il faut que l'adresse MAC de la VM soit la même que la carte réseau physique)

Au passage j'avais remarqué que toute modification réseaux en utilisant le panel avaient tendance à casser la configuration IPv6 de l'hôte.

Ikuto
28/01/2014, 23h46
Bonjour alors voila j'ai mon serveur kimsufi sur lequel proxmox est installer, je voudrais pouvoir accéder à mon proxmox depuis l'ipv4 et que les machine sur le proxmox soit accessible depuis l'ipv6.

En gros ça donnerais : NET ---> ipv4 ---> proxmox
NET---> ipv6 ---> pfsense ---> toute les VMs

actuellement le brigde se fait depuis le vmbr1 qui va par la suite sur le vmbr0 pour sortir

# The loopback network interface
auto lo
iface lo inet loopback

# for Routing
#auto vmbr1
#iface vmbr1 inet manual
# post-up /etc/pve/kvm-networking.sh
# bridge_ports dummy0
# bridge_stp off
# bridge_fd 0


# vmbr0: Bridging. Make sure to use only MAC adresses that were assigned to you.
auto vmbr0
iface vmbr0 inet static
address 91.1XX.79.1XX
netmask 255.255.255.0
network 91.1XX.79.0
broadcast 91.1XX.79.255
gateway 91.1XX.79.254
bridge_ports eth0
bridge_stp off
bridge_fd 0

iface vmbr0 inet6 static
address 2001:XXXX:1:8XXX::1
netmask 64
post-up /sbin/ip -f inet6 route add 2001:41D0:1:84ff:ff:ff:ff:ff dev vmbr0
post-up /sbin/ip -f inet6 route add default via 2001:41D0:1:84ff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del default via 2001:41D0:1:84ff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del 2001:41D0:1:84ff:ff:ff:ff:ff dev vmbr0


auto vmbr1
iface vmbr1 inet static
address 192.168.1.254
netmask 255.255.255.0
bridge_port none
bridge_stp off
bridge_fd 0
post-up echo 1 > /proc/sys/net/ipv4/ip_forward
post-up iptables -t nat -A POSTROUTING -s '192.168.1.0/24' -o vmbr0 -j MASQUERADE
post-down iptables -t nat -A POSTROUTING -s '192.168.1.0/24' -o vmbr0 -j MASQUERADE

j'ai pas mal chercher de solution pour pouvoir faire ce que je veux avec pfsense mais maintenant que l'ipfailover n'est pas dispo pour les kimsufi 2013 je ne vois pas comment me dépatouiller.


merci pour votre aide