OVH Community, your new community space.

Rtorrent


Kitty
29/01/2014, 21h58
Avez-vous plus d'un .rtorrent.rc et/ou config.php?

Où est rtorrent installé? (habituellement /usr/bin/rtorrent)

Où est rutorrent installé? (habituellement /var/www/html)

Quel est le nom de l'utilisateur de rtorrent?

Comment commencez-vous rtorrent, et l'utilisateur qui commencez il?

Avez-vous mis en place une autorisation de HTTP/mot de passe pour l'utilisateur?

En supposant que le nom d'utilisateur est 'username', vous aurez besoin de ces fichiers:

Si vous avez un système mono-utilisateur: /var/www/html/conf/config.php
Si vous avez un système multi-utilisateur: /var/www/html/conf/users/username/config.php

/home/username/rtorrent/.rtorrent.rc

Assurez-vous que les valeurs scgi_* sont les mêmes dans chaque.

Puis, en tant que root, faire
Code:
killall rtorrent
su -s /bin/bash --session-command="/usr/bin/screen -d -m /usr/bin/rtorrent -n -o /home/username/rtorrent/.rtorrent.rc" username
Vérifiez qu'il est en cours d'exécution
Code:
ps -Af | grep username
Chargez RuTorrent dans votre navigateur et connectez-vous en tant que utilisateur.

sbx59
29/01/2014, 21h13
Non toujours pas ...

Pas contre, si je mais le port 5000, il y a que en SSH ( rtorrent ) qui ne fonctionne pas.

Je vois bien les download sur rutorrent avec le port 5000.

Es ce que je remais le port 5000, ou y a t'il une réel solution ?

Kitty
29/01/2014, 21h06
rtorrent peut être en cours d'exécution, mais il n'est pas à l'écoute sur le port 5001 localohost.

Vous devrez peut-être redémarrer (et comme le bon utilisateur).

Try
Code:
sudo killall rtorrent
su -s /bin/bash --session-command="/usr/bin/screen -d -m /usr/bin/rtorrent -n -o /chemin/vers/.rtorrent.rc" 
And clear iptables
Code:
iptables -F

sbx59
29/01/2014, 20h59
La commande netstat -nepl | grep rtorrent | grep "5001 "
ne donne rien.


root@ns3280277:/home/sbx59# telnet 127.0.0.1 5001
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused

J'ai bien iptables

Kitty
29/01/2014, 20h52
Avez-vous un pare-feu (iptables)?

Est en marche rtorrent et écoute sur 5001?
Code:
netstat -nepl | grep rtorrent | grep "5001 "
Qu'est-ce qui se passe avec ce?
Code:
telnet 127.0.0.1 5001
Il faut dire
Code:
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

sbx59
29/01/2014, 20h34
Dans mon config.php

$scgi_port = 5001;
$scgi_host = "127.0.0.1";

mon .rtorrent.rc

tracker_numwant = 80
http_capath = /etc/ssl/certs
encoding_list = utf8

directory = /home/sbx59/rtorrent/download
session = /home/sbx59/rtorrent/.session
scgi_port = 127.0.0.1:5001
port_range = 6890-6999

Et cela ne fonctionne toujours pas

Kitty
29/01/2014, 20h31
Citation Envoyé par sbx59
Alors sur Rutorrent j'ai ce message :

[29.01.2014 19:07:14] Lien incorrect avec rTorrent. Vérifier qu'il est bien en cours d'exécution. Vérifier la configuration de $scgi_port et de $scgi_host dans config.php et scgi_port dans le fichier de configuration de rTorrent.
$scgi_port et de $scgi_host dans /var/www/html/conf/config.php (ou là où vous l'avez installé) doit correspondre à la scgi_port ligne in .rtorrent.rc

Modifier /var/www/html/conf/config.php et recharger RuTorrent dans votre navigateur.

Quelque chose comme:
Code:
$scgi_host = "127.0.0.1";
$scgi_port = 5000;
Dans rtorrent (ssh)

(19:07:16) Using 'epoll' based polling.
(19:07:16) Using 'epoll' based polling.
(19:07:16) Using 'epoll' based polling.
(19:07:16) The SCGI socket is bound to a specific network device yet may still pose a security risk, consider using 'scgi_local'.
C'est OK.

sbx59
29/01/2014, 20h09
Alors sur Rutorrent j'ai ce message :

[29.01.2014 19:07:14] Lien incorrect avec rTorrent. Vérifier qu'il est bien en cours d'exécution. Vérifier la configuration de $scgi_port et de $scgi_host dans config.php et scgi_port dans le fichier de configuration de rTorrent.


Dans rtorrent (ssh)

(19:07:16) Using 'epoll' based polling.
(19:07:16) Using 'epoll' based polling.
(19:07:16) Using 'epoll' based polling.
(19:07:16) The SCGI socket is bound to a specific network device yet may still pose a security risk, consider using 'scgi_local'.
(19:07:16) Closed XMLRPC log.

Kitty
29/01/2014, 19h40
rtorrent est en marche.
rtorrent is running.

Est-ce que cela fonctionne?
Is it working?

Si c'est non, le résilier:
If it is not, terminate it:
Code:
su kill 11985

sbx59
29/01/2014, 19h28
sbx59@ns3280277:~$ ps -Af | grep rtorrent
sbx59 11984 1 0 18:21 ? 00:00:00 SCREEN -fa -d -m rtorrent
sbx59 11985 11984 4 18:21 pts/2 00:00:16 rtorrent

Kitty
29/01/2014, 19h22
Citation Envoyé par sbx59
Edit, je l'ai lancé en Root

root@ns3280277:/home/users# netstat -nlep | grep "5000 "
tcp 0 0 127.0.0.1:5000 0.0.0.0:* LISTEN 1000 25428 9109/rtorrent
Ce sera le résilier:
Code:
su kill 9109
Si cela échoue, utilisez:
Code:
su kill -9 9109

Kitty
29/01/2014, 19h11
netstat: no support for `AF INET (tcp)' on this system.
Cela pourrait aider:
This might help:

CEntOS:
Code:
yum install lksctp*
Debian/Ubuntu:
Code:
apt-get install lksctp*

e2a:
Could not lock session directory: "/home/users/rtorrent/.session/", held by "ns3280277.ip-94-23-52.eu:+9109
Est rtorrent en cours d'exécution déjà?
Code:
ps -Af  | grep rtorrent

sbx59
29/01/2014, 19h10
Voici le nouveau message :


Could not lock session directory: "/home/users/rtorrent/.session/", held by "ns3280277.ip-94-23-52.eu:+9109".

sbx59
29/01/2014, 19h00
Ta commande netstat -nlep | grep "5000 "

Ne donne rien ...

Edit, je l'ai lancé en Root

root@ns3280277:/home/users# netstat -nlep | grep "5000 "
tcp 0 0 127.0.0.1:5000 0.0.0.0:* LISTEN 1000 25428 9109/rtorrent


Et celle ci :

netstat -laputen
Connexions Internet actives (serveurs et établies)
Proto Recv-Q Send-Q Adresse locale Adresse distante Etat User Inode PID/Program name
netstat: no support for `AF INET (tcp)' on this system.

Kitty
29/01/2014, 18h57
Je pense que ce pourrait être le problème:
Code:
scgi_port = 127.0.0.1:5000
Essayez ceci pour découvrir si quelque chose utilise le port:
Code:
netstat -nlep | grep "5000 "
Changer '5000' pour trouver un port inutilisé, puis modifier .rtorrent.rc.

sbx59
29/01/2014, 18h48
J'ai fait une edit plus haut ^^

Je doit juste ajouté les port donc ?

Kitty
29/01/2014, 18h47
Dans .rtorrent.rc

sbx59
29/01/2014, 18h40
Citation Envoyé par Kitty
Essayez de changer les à l'adresse de votre serveur:
Try changing these to the address of your server:

Code:
# The ip address reported to the tracker.
ip = 12.34.56.78

# The ip address the listening socket and outgoing connections is
# bound to.
bind = 12.34.56.78
Et ce si le port est déjà en cours d'utilisation:
And this if the port is already in use:

Code:
# Port range to use for listening.
port_range = 6890-6999

Je change sa dans le rtorrent ?

Voici mon .rtorrent.rc

utilisateur@ns3280277:~$ nano /home/users/.rtorrent.rc
GNU nano 2.2.6 Fichier*: /home/users/.rtorrent.rc

tracker_numwant = 80
http_capath = /etc/ssl/certs
encoding_list = utf8

directory = /home/users/rtorrent/download
session = /home/users/rtorrent/.session
scgi_port = 127.0.0.1:5000

Kitty
29/01/2014, 17h50
Essayez de changer les à l'adresse de votre serveur:
Try changing these to the address of your server:

Code:
# The ip address reported to the tracker.
ip = 12.34.56.78

# The ip address the listening socket and outgoing connections is
# bound to.
bind = 12.34.56.78
Et ce si le port est déjà en cours d'utilisation:
And this if the port is already in use:

Code:
# Port range to use for listening.
port_range = 6890-6999

sbx59
29/01/2014, 17h11
Bonjour,

sur l'un de mes serveur j'ai ce message d'erreur quand je tape "torrent"

Error in option file: ~/.rtorrent.rc:7: Could not prepare socket for listening: Adresse déjà utilisée

merci de votre aide