OVH Community, your new community space.

Probleme de Mot de passe Root


nowwhat
31/01/2014, 01h19
Disons que, si coté Putty etc tout est bon (adresse IP ou l'URL correct - porte 22 ) on y va tout droit vers un:
=> "service sshd" qui ne tourne pas - car désactivé dans l'interface de gestion (Plesk, ISPConig, autre) tout simplement,
=> Un parafeu 'mal paramétré' ....,
=> On n'a pas vérifié (on a du demander le fichier /etc/ssh/sshd_config entier) si l'authentification n'est pas verrouille sur clé publique/privé (mais j'en doute ...),
=> etc.

On aurais inspecter les logs de démarrage en mode 'normal' pour voir comment sshd démarre - je présume que le soucis est la ....

@Jarod6827: t'as accès à tes données par le mode rescue .... de ce coté la t'as passé ton diplômé.
Sauvegarde avec l'accès que Buddy t'as montré plus TOUTES ces répertoires:
Surtout le
/etc
/home
/var
/root
/usr

Le /bin, /sbin, /opt
si t'as envie.

Sauvegarde pas les
/dev
/run
/tmp
c'est inutile.

Puis ré-installe.

buddy
31/01/2014, 00h30
et en ssh ??
tu essayes de te connecter comment ?
et quel est le problème exactement ? quel message d'erreur ( on veut un copier coller exact )

jarod6827
30/01/2014, 21h38
Mon serveur n'est plus en mode rescue etant donnée que je vois mes sites.
en ftp je n'arrive a me connecter il marque erreur de mot de passe

nowwhat
30/01/2014, 20h35
Avant de ré-intaller:

Quand tu teste ton login, quand tu te connecte sur ton serveur avec ton IP sur la porte "22", t'as ceci à l'écran:
Login:
puis tu tape
root
Il y aura une réponse:
Password:
puis tu saisi le mot de passe que t'as mis tout à l'heure.

Tu nous dit (mais nous montre pas) que ça marche pas.
Il dit:
réfusé
ou quelque chose du genre (exact) ?

A ce moment la - précisément, dans le mail d'OVH, que t'as reçu quand t'as basculé en mode rescue, t'as ceci:
.....
l'arborescence de votre système de fichiers:
http://91.121.98.165:81
- nom d'utilisateur : root
- mot de passe : L5fjPklS
.....
T'as un lien pareil:
http://a.b.c.d:81
a.b.c.d est l'IP de ton serveur.

Clqiue sur ce lien - Ce lien fonctionne ? Il donne une page - ou un "erreur" ?

Pourquoi je demande tout ça ?
Pour voir si ton serveur est réellement quitté le mode rescue (des fois ça bloque de ce coté la).
Si une page s'affiche qui te demande de te loger, ton serveur est resté en mode rescue !!
C'est donc normal que ton nouveau mot de passe ne fonctionne pas - t'es toujours en rescue ..... (il te faut le mot de passe qui est dans le mail du rescue).

BBR
30/01/2014, 20h26
Filezilla se met tout seul en sftp si on met le 22 (de moire en tous cas)

nowwhat
30/01/2014, 20h18
Citation Envoyé par BBR
.......puis sans fermer la fenêtre ssh, allez sur votre client ftp favori (Filezilla par exemple) hote : ip du serveur, utilisateur : root, mot de passe rescue root, mettez en port 22, ....
et surtout : dans FileZilla, quand tu te connecte à ton serveur, bascule le protocole en SFTP - le FTP 'normal' n'est pas bon sur la porte "22" (= SSH).

admin_julie_srv
30/01/2014, 20h17
Citation Envoyé par jarod6827
je pense que je vais réinstaller le serveur mille merci
Ok bon courage pour ta réinstallation.

admin_julie_srv
30/01/2014, 20h14
Donc celà à bien été prit en compte et pas de souci au quelle je pensais. et inutile de rechanger le mot de passe, sauf si t'est un poisson rouge. Où là je te souhaite bien du courage.^^

Mise à par çà quand tu te connect en SSH çà te dit quoi exactement?

jarod6827
30/01/2014, 20h10
je pense que je vais réinstaller le serveur mille merci

jarod6827
30/01/2014, 20h09
ca me donne deux fois les meme mot de passe

jarod6827
30/01/2014, 20h04
Merci sincèrement pour la recup des fichiers ca me rassure

admin_julie_srv
30/01/2014, 20h03
Bon ce qui compte c'est qu'au final si tu arrive toujours pas à te connecter tu retourne en rescue et que tu compare les 3 ligne avec les grace à la commande

cat /root/mot_pass,

Les 2 dernière doivent être identique, si c'est pas le cas, ta un sérieux souci.

Pour cà une fois que tu retourne en rescue t'auras juste a taper cette commande "echo $(cat /etc/shadow | grep root) >> /root/mot_pass"

et tu tape la commande cat /root/mot_pass qui te permet de vérifé si le mot de passe à changer.

En conclusion la 1ère ligne te donne l'ancien mot de passe , la seconde le nouveau, et la dernière (en théorie)
te done la même que la deuxième.

Et encore une fois désolé,.enfin quoique vu que ta linker, y'a possibilié de récupéré ma bétise^^

BBR
30/01/2014, 19h55
et pour répondre à la question sur la récupération des données en rescue :
montez les partitions, chroot /mnt/
puis sans fermer la fenêtre ssh, allez sur votre client ftp favori (Filezilla par exemple) hote : ip du serveur, utilisateur : root, mot de passe rescue root, mettez en port 22, ensuite vous aurez toute l'arborescence de votre serveur et vous pourrez donc récupérer vos fichiers

jarod6827
30/01/2014, 19h51
Code:
root@rescue [~]# cat /root/mot_pass
root:$6$MBcGFRLu$UDfAZbPgcq/e5JBw3y8WyPnhi675Eb1GcgoyCmUZy9OqTugMDsI6nAERXWbNioUFgePvubcYyntL6mdZsm/Tu/:16100:0:99999:7:::
root@rescue [~]# echo $(cat /etc/shadow | grep root) > /root/mot_pass
root@rescue [~]# cat /root/mot_pass
root:$6$MBcGFRLu$UDfAZbPgcq/e5JBw3y8WyPnhi675Eb1GcgoyCmUZy9OqTugMDsI6nAERXWbNioUFgePvubcYyntL6mdZsm/Tu/:16100:0:99999:7:::
root@rescue [~]# passwd root echo $(cat /etc/shadow | grep root) > /root/mot_pass
passwd: Only one user name may be specified.
root@rescue [~]# cat /root/mot_pass
root@rescue [~]#

admin_julie_srv
30/01/2014, 19h46
Ensuite tu copie colle cette commande aussi "$(cat /etc/shadow | grep root) > /root/mot_pass"

à remplacer par "echo $(cat /etc/shadow | grep root) > /root/mot_pass"

Et "$(cat /etc/shadow | grep root) >> /root/mot_pass"

par "echo $(cat /etc/shadow | grep root) >> /root/mot_pass"

Donc meme chose que précédament en rajoutant echo pour t'aider je vais édité mon précédent post

admin_julie_srv
30/01/2014, 19h43
Citation Envoyé par jarod6827
Voila le resultat :


Code:
 root@rescue:~# $(cat /etc/shadow | grep root) > /root/mot_pass
-bash: root:MTbcyOjJvQTyw:16100:0:99999:7:::: command not found
root@rescue:~#  chroot /mnt/
root@rescue [/]#  cd /root/
root@rescue [~]# $(cat /etc/shadow | grep root) > /root/mot_pass
bash: root:$6$MBcGFRLu$UDfAZbPgcq/e5JBw3y8WyPnhi675Eb1GcgoyCmUZy9OqTugMDsI6nAERXWbNioUFgePvubcYyntL6mdZsm/Tu/:16100:0:99999:7:::: No such file or directory
root@rescue [~]# cat /root/mot_pass
root@rescue [~]# passwd root $(cat /etc/shadow | grep root) >> /root/mot_pass
passwd: Only one user name may be specified.
root@rescue [~]#

ET m......., désolé pour le vocabulaire j'ai oulié de te faire mettre un echo devant,
Erreur de débutant vraiment désolé.

jarod6827
30/01/2014, 19h39
Voila le resultat :


Code:
 root@rescue:~# $(cat /etc/shadow | grep root) > /root/mot_pass
-bash: root:MTbcyOjJvQTyw:16100:0:99999:7:::: command not found
root@rescue:~#  chroot /mnt/
root@rescue [/]#  cd /root/
root@rescue [~]# $(cat /etc/shadow | grep root) > /root/mot_pass
bash: root:$6$MBcGFRLu$UDfAZbPgcq/e5JBw3y8WyPnhi675Eb1GcgoyCmUZy9OqTugMDsI6nAERXWbNioUFgePvubcYyntL6mdZsm/Tu/:16100:0:99999:7:::: No such file or directory
root@rescue [~]# cat /root/mot_pass
root@rescue [~]# passwd root $(cat /etc/shadow | grep root) >> /root/mot_pass
passwd: Only one user name may be specified.
root@rescue [~]#

jarod6827
30/01/2014, 19h34
root@rescue:~# $(cat /etc/shadow | grep root) >> /root/mot_pass
-bash: root:MTbcyOjJvQTyw:16100:0:99999:7:::: command not found
root@rescue:~#

admin_julie_srv
30/01/2014, 19h32
Citation Envoyé par jarod6827
root@rescue:~# chroot /mnt/
root@rescue [/]# cat /etc/ssh/sshd_config | grep PermitRootLogin
#PermitRootLogin yes
# the setting of "PermitRootLogin without-password".
root@rescue [/]#
çà c'est bon cela veut dire que tu peut te connecter en root.

admin_julie_srv
30/01/2014, 19h31
Pour la 2ème étape: Toujour chrooté

Avant modifcation du mot de passe root.

on ce deplace dans le dossier /root/ -> cd /root/,
Ensuite tu copie colle cette commande aussi " echo $(cat /etc/shadow | grep root) > /root/mot_pass"
éventuellement tu peut vérifié en faisant la commande " cat /root/mot_pass"

Ce qui te devrait te donné, aussi a titre d'exmple
Code:
 root:$fhdfhkjdsghfjegzfgzzgdu:::
ensuite tu tape de nouveau "passwd root, puis la commande "echo $(cat /etc/shadow | grep root) >> /root/mot_pass"

Tu compare çà avec " cat /root/mot_pass" ce qui devrais te donné

Normalement tu a deux ligne bien différente ce qui veut dire que ton mon pass à changé.

jarod6827
30/01/2014, 19h28
alors quand je suis pas en chroot /mnt/ le PermitRootLogin y a pas le # et de l'autre cote y a un #

jarod6827
30/01/2014, 19h27
root@rescue:~# chroot /mnt/
root@rescue [/]# cat /etc/ssh/sshd_config | grep PermitRootLogin
#PermitRootLogin yes
# the setting of "PermitRootLogin without-password".
root@rescue [/]#

jarod6827
30/01/2014, 19h25
root@rescue:~# cat /etc/ssh/sshd_config | grep PermitRootLogin
PermitRootLogin yes
# the setting of "PermitRootLogin without-password".
root@rescue:~#

jarod6827
30/01/2014, 19h20
ok je relance rescue merci

jarod6827
30/01/2014, 19h19
petit question en rescue on peut récupérer le backup de la sauvegarde ? merci a tous pour l aide mais ca veux pas fonctionner ou alors je peut donnee l ip a quelqu'un pour voir si il arrive a faire quelque chose

admin_julie_srv
30/01/2014, 19h16
Re Toujour pas ???

Bon, je te propose le pire (mode parano^^).

tu reboot pour énième fois en rescue, bref tu suis comme ce qui ta été dit précédemment, MAIS au instruction que je vais te dire une fois avoir faire
"chroot /mnt/"

On va d'abord vérifié la config de sshd ensuite,
on va vérifié chaque modification du root dans /etc/shadow (3fois avant, après, et en cas d'une nouvelle échec en rescue)

Très bien étape 1 (vérification de /etc/ssh/sshd_config:
Tu fait un copier coller de cette commande: "cat /etc/ssh/sshd_config | grep PermitRootLogin"

A titre d'exemple çà te donne
Code:
PermitRootLogin no
# the setting of "PermitRootLogin without-password"
.
Une fois que c'est fait tu nous dit ce qui est indiqué

Pendent ce temps j'écris les autres étape, oui je suis longue (aussi je vérifie les commande^^)

jarod6827
30/01/2014, 19h10
Ben j'ai mis passwd root mais cela ne fonctionne pas

BBR
30/01/2014, 18h48
pourtant tu as écrit :
je met pas passwd root
alors qu'il faut mettre
passwd root
explication : tu veux changer le mot de pass de l'utilisateur root, si tu voulais changer celui de l'utilisateur toto tu taperais passwd toto
sur ce je passe le relais.

jarod6827
30/01/2014, 18h32
oui je suis le tuto et tout ce que vous m'avez dit mais cela ne fonctionne tjr pas

BBR
30/01/2014, 18h28
Citation Envoyé par jarod6827
je met pas passwd root
tu devrais car c'est celui de l'utilisateur root que tu veux changer
et il me semblait avoir dit qu'il fallait mettre exactement ce qui était dans le tuto !

jarod6827
30/01/2014, 18h25
je met pas passwd root

nowwhat
30/01/2014, 18h22
Donc, dès que le
chroot /mnt/
est exécuté - t'es bon.

Exécute
passwd
puis il te demande deux fois de saisir un mot de passe 'root'.

Et maintenant ..... attention.

Laisse la fenêtre SSH ouvert.

Va, avec ton navigateur internet, vers ton Manager de ton KS.
Repositionne le mode boot sur "boot sur disque dur" - fait en sorte que le boot ne se fait PLUS en mode "rescue".
Dès que c'est fait, saisi dans ton fenêtre SSH le commande
exit
puis
reboot.

Ton serveur redémarre - et cette fois si en mode 'normal - à partir de ton disque dur' (et plus en mode 'rescue').

Ton login SSH avec le nouveau mot de passe devrait fonctionner.

jarod6827
30/01/2014, 18h22
donc une fois ca fait je fait chroot /mnt/
et ensuite je modifie mon mot de passe mais cela ne fonctionne pas

nowwhat
30/01/2014, 18h16
Citation Envoyé par jarod6827
root@rescue:~# chroot /mnt/
root@rescue [/]# ls -alh /mnt/
total 8.0K
drwxr-xr-x 2 root root 4.0K Sep 23 2011 ./
dr-xr-xr-x 25 root root 4.0K Jan 30 15:26 ../
C'est normal - c'est ok.
T'as fait le "chroot" donc tu liste ce qui est dans [va voir le ligne rouge en bas]
Comme chez moi, ton /mnt/ est vide ....

Citation Envoyé par jarod6827
et si je fait pas chroot /mnt/ j'ai ca
root@rescue:~# ls -alh /mnt
total 136K
dr-xr-xr-x 25 root root 4.0K Jan 30 15:26 .
drwxrwxrwt 17 root root 420 Jan 30 16:43 ..
-rw-r--r-- 1 root root 0 Jan 30 15:26 .autofsck
-rw-r--r-- 1 root root 0 Jun 15 2013 .autorelabel
drwxr-xr-x 3 root root 4.0K Dec 19 04:00 .rvglobalsoft
drwx--x--x 3 root root 4.0K Jan 30 02:00 backup
dr-xr-xr-x 2 root root 4.0K Jan 6 10:41 bin
dr-xr-xr-x 4 root root 4.0K Jun 15 2013 boot
.....
drwxr-xr-x 2 root root 4.0K Sep 23 2011 mnt
drwxr-xr-x 10 root root 4.0K Jan 9 11:16 opt
.....
drwxr-xr-x 2 root root 4.0K Sep 23 2011 selinux
.....
drwxr-xr-x 23 root root 4.0K Jan 7 03:37 var
C'est parfait : les partions sont donc bien monté !!!!!!!!

jarod6827
30/01/2014, 17h55
et si je fait pas chroot /mnt/ j'ai ca
root@rescue:~# ls -alh /mnt
total 136K
dr-xr-xr-x 25 root root 4.0K Jan 30 15:26 .
drwxrwxrwt 17 root root 420 Jan 30 16:43 ..
-rw-r--r-- 1 root root 0 Jan 30 15:26 .autofsck
-rw-r--r-- 1 root root 0 Jun 15 2013 .autorelabel
drwxr-xr-x 3 root root 4.0K Dec 19 04:00 .rvglobalsoft
drwx--x--x 3 root root 4.0K Jan 30 02:00 backup
dr-xr-xr-x 2 root root 4.0K Jan 6 10:41 bin
dr-xr-xr-x 4 root root 4.0K Jun 15 2013 boot
drwxr-xr-x 2 root root 4.0K Jun 25 2013 cgroup
drwxr-xr-x 2 root root 4.0K Jul 8 2011 dev
drwxr-xr-x 76 root root 12K Jan 30 16:40 etc
drwx--x--x 20 root root 4.0K Jan 30 07:52 home
dr-xr-xr-x 12 root root 4.0K Jan 6 10:41 lib
dr-xr-xr-x 9 root root 12K Jan 6 10:41 lib64
drwx------ 2 root root 16K Apr 22 2013 lost+found
drwxr-xr-x 2 root root 4.0K Sep 23 2011 media
drwxr-xr-x 2 root root 4.0K Sep 23 2011 mnt
drwxr-xr-x 10 root root 4.0K Jan 9 11:16 opt
drwxr-xr-x 2 root root 4.0K Jun 15 2013 proc
-rw-r--r-- 1 root root 109 Nov 8 03:50 razor-agent.log
dr-xr-x--- 19 root root 4.0K Jan 30 15:26 root
dr-xr-xr-x 2 root root 12K Jan 6 10:41 sbin
lrwxrwxrwx 1 root root 25 Apr 22 2013 scripts -> /usr/local/cpanel/scripts
drwxr-xr-x 2 root root 4.0K Sep 23 2011 selinux
drwxr-xr-x 2 root root 4.0K Sep 23 2011 srv
drwxr-xr-x 2 root root 4.0K Jul 8 2011 sys
drwxrwxrwt 2 root root 4.0K Jan 30 15:26 tmp
drwxr-xr-x 14 root root 4.0K Jan 30 15:26 usr
drwxr-xr-x 23 root root 4.0K Jan 7 03:37 var

jarod6827
30/01/2014, 17h52
root@rescue:~# chroot /mnt/
root@rescue [/]# ls -alh /mnt/
total 8.0K
drwxr-xr-x 2 root root 4.0K Sep 23 2011 ./
dr-xr-xr-x 25 root root 4.0K Jan 30 15:26 ../

nowwhat
30/01/2014, 17h48
T'inquiète, mon but n'est pas d'être désagréable.

J’espère simplement que tu garde une petite feuille de route, pour y noter tes boulots pour demain et après demain, car, à cet instant, ton serveur risque gros.
La question n'est pas SI ton disque va lâcher, mais QUAND.
Et ça c'est le jour que t'as tout perdu.
(donc: pourquoi faire des efforts pour aujourd'hui si 'demain' tout sera perdu ?? )

Il me semble que je t'ai demandé de me donner le résultat de ceci:
Citation Envoyé par Copie-colle-moi
ls -alh /mnt
AVANT que tu chroot /mnt/ - et
APRES que t'as mount tes deux partitions.

Plus haut je te donné ce que j'ai eu moi, quand je fait tout ça.
SI rien figure dans le répertoire /mnt/, tes partions ne sont pas mounté, et il faut qu'on détaille ça.

édit: mdr: buddy m'a grillé ......... je bavarde trop

buddy
30/01/2014, 17h43
Quand tu as tape
chroot /mnt/
Fais
ls -alh /mnt/
et poste le resultat ici.

jarod6827
30/01/2014, 17h36
j'ai suivi ce que vous m'avez indiqué précédemment concernant le changement du mot de passe, je n'ai rien rentre a ma sauce comme vous savez si bien dire.
et je vous ai indiqué les résultats que j'ai obtenu.

nowwhat
30/01/2014, 17h31
Encore un sujet dans un sujet:
Citation Envoyé par jarod6827
Bonjour,

Notre système de monitoring vient de détecter un défaut sur votre
serveur ks3289448.kimsufi.com. (ks3289448.kimsufi.com).
Le défaut a été constaté à la date 2014-01-24 13:18:01

Notre équipe de techniciens sur site (opérationnelle 24h/24, 7j/7),
a été informée de ce défaut et va intervenir sur votre machine.

Sachez que d'autres interventions peuvent être en cours actuellement
et qu'il faut compter en moyenne 30 minutes par intervention et par
machine.
Par conséquent, nous ne pouvons pas vous donner plus de précisions
quant à l'heure de début de l'intervention.

Vous pouvez avoir un aperçu global des machines actuellement en défaut
et en intervention sur tout le réseau à cette adresse:

http://travaux.ovh.net/vms/

Votre serveur se trouve dans la baie 45C12

Vous recevrez un email dés qu'un technicien prendra en charge votre
serveur. En attendant, vous avez la possibilité de le rebooter à partir
de votre manager.

Logs:
----------------------
PING ks3289448.kimsufi.com (5.135.183.52) from 213.186.33.13 : 56(84) bytes of data.
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable

--- 5.135.183.52 ping statistics ---
10 packets transmitted, 0 packets received, +6 errors, 100% packet loss
---------------------
Dès que tu passe ton serveur en mode rescue, ton serveur redémarre.
Ca prend quelques minutes probablement, des fois, plus.
Or, la chance est grand que l'auto ping de OVH - le service Monitoring - te balance un "ping".

Panique à bord: le serveur est en train de démarrer, et il ne sais pas encore qu'il posssède un carte réséau (un NIC) et/ou cette carte n'est pas encore initialisé.
Ton serveur - la carte réseau - ne repondera pas à ce moment bien précis.

Le service monitoring d'OVH détecte ceci, et va t'envoyer un mail.
C'est le mail que tu cite.

Ce qui ce passe réellement: le type salarié d'OVH' dans la salle retrouve ton serveur listé sur une sorte d'écran comme chez McDo, dans leur cuisines. Je te montre l'écran: http://travaux.ovh.net/vms/index_rbx3.html
Dès qu'il passe devant ton serveur, il regarde (et rien de plus).
Ton serveur, entretemps, a déjà redémarré et est en mode 'normal', soit en mode 'rescue', mais est en train de répondre aux ping comme avant. Le salarié détecte un gros RAS.

Ceci est donc un exemple typique d'un FAUX alarme.
Ce mail indique seulement que le serveur a disparu des écran radar d'OVH pour un petit instant.

De plus, dès que le serveur recommence à répondre à nouveau au petit ping que lui sont envoyés, le service monitoring détecte que t'as du recevoir un mail, donc il t’envoie un autre mail, qui mentionne:

Citation Envoyé par "[suivi
(Fin de defaut sur ton-domaine.tld) Service Monitoring d'OVH]
Bla bla bla ...

A la date 2014-03-01 08:38:30, nous avons constaté un défaut
sur votre serveur et nous avons programmé une intervention afin de
palier à ce défaut.

Toutefois, à la date 2014-03-08:43:11 notre système de monitoring n'a plus
relevé de défaut sur votre serveur dédié domaine.tld (ksxxxxx.kimblufi.com)

Nous ne sommes pas intervenus sur votre machine. Nous ne connaissons
pas l'origine du défaut.

L'intervention programmée a été supprimée de notre liste
De toute façon.
OVH qui intervient sur un serveur KS sans autorisation de ta part .......... je ne dirais plus que ça n'existe pas*** mais disons: ça n'existe pas.

Et c'est logique: il ne sont pas payées pour, suivant tes ordres très stricte .......

** (pour ceux qui sont là chaque jour)

BBR
30/01/2014, 17h31
Citation Envoyé par jarod6827
Moi je ne fait jamais de copier coller car souvent cela met des espaces, ou sont les administrateur des serveurs kimsufi on paye à qui et comment on règle ce genre de problème
bah tu devrais ou alors écrire comme c'est indiqué
le support kimsufi n'intervient pas pour les problèmes logiciels et c'en est un même pas en service payant, donc soit tu fais comme on t'a expliqué soit...

BBR
30/01/2014, 17h29
jarod, nowwhat a son franc parler (de plus le français n'est pas sa langue natale si je me souviens bien) mais il n'a pas tort, on en est à 8 pages pour constater que tu as entré les commandes à ta sauce alors que si tu avais respecté la syntaxe donnée ça fait longtemps que ton problème serait résolu
J'ai une bonne dose de patience mais là je suis proche d'abandonner.

jarod6827
30/01/2014, 17h26
Moi je ne fait jamais de copier coller car souvent cela met des espaces, ou sont les administrateur des serveurs kimsufi on paye à qui et comment on règle ce genre de problème

BBR
30/01/2014, 17h24
Citation Envoyé par jarod6827
et concernant l'espace entre le chroot /mnt/ je n'en ai pas mis lors de ma config
c'est quand même pas compliqué de faire des copiés/collés ??? ou de réécrire exactement les commandes !!!

BBR
30/01/2014, 17h23
et ce mail a été suivi presque aussitôt d'un autre disant que tout était ok ?
si oui ils n'ont rien fait, le serveur a de nouveau pinger donc incident clos
tout ça est automatique

jarod6827
30/01/2014, 17h17
et concernant l'espace entre le chroot /mnt/ je n'en ai pas mis lors de ma config

jarod6827
30/01/2014, 17h15
nowwhat je vous trouve très désagréable je ne vous ai rien fait, je pense être un peu dans la merde donc pas besoin de vous acharnez contre moi

nowwhat
30/01/2014, 17h12
Citation Envoyé par jarod6827
en 3ème chroot /mnt /
Et baf .....
jarod invente un espace entre /mnt et le / - regardé bien.

Je zoom:
chroot /mnt /
et la, on le vois.

Or, le commande est (suivant tuto)
chroot /mnt/

@BBR: le tuto: avant "3ème chroot /mnt/" que la victime fasse un ls -alh /mnt
Code:
# ls -alh /mnt
total 556K
drwxr-xr-x  22 root root 4,0K janv. 29 09:52 .
drwxr-xr-x  22 root root 4,0K janv. 29 09:52 ..
drwxr-xr-x   2 root root 4,0K oct.  13 17:05 bin
drwxr-xr-x   3 root root 4,0K janv. 12 01:26 boot
drwxr-xr-x  12 root root  14K janv. 10 09:06 dev
drwxr-xr-x 113 root root  12K janv. 24 22:17 etc
drwxr-xr-x   3 root root 4,0K nov.  13 23:51 home
drwxr-xr-x  16 root root  12K déc.  23 13:27 lib
drwxr-x---   2 root root 4,0K mars   8  2013 .LOCK
drwx------   2 root root  16K déc.   4  2010 lost+found
drwxr-xr-x   3 root root 4,0K févr.  9  2009 media
drwxr-xr-x   4 root root 4,0K juil. 11  2012 mnt
drwxr-xr-x   7 root root 4,0K déc.  13 19:03 opt
dr-xr-xr-x 177 root root    0 janv. 10 09:06 proc
drwxr-xr-x  26 root root 432K janv. 28 20:33 root
drwxr-xr-x  24 root root  720 janv. 30 03:16 run
drwxr-xr-x   2 root root 4,0K janv. 10 13:50 sbin
drwxr-xr-x   2 root root 4,0K sept. 16  2008 selinux
dr-xr-xr-x  11 root root    0 janv. 10 09:06 sys
drwxrwxrwt   3 root root  28K janv. 30 16:10 tmp
drwxr-xr-x  10 root root 4,0K mai   28  2013 usr
drwxr-xr-x  13 root root 4,0K janv. 29 09:51 var
Il FAUT qu'il y à toutes ces répertoires (ici: un Debian) dans le répertoire /mnt et qu'il ne continue pas avec un chroot dans le vide.

En gros, je pense qu'il y a un marché pour un vidéo sur YouTube.

jarod6827
30/01/2014, 17h09
Bonjour,

Notre système de monitoring vient de détecter un défaut sur votre
serveur ks3289448.kimsufi.com. (ks3289448.kimsufi.com).
Le défaut a été constaté à la date 2014-01-24 13:18:01

Notre équipe de techniciens sur site (opérationnelle 24h/24, 7j/7),
a été informée de ce défaut et va intervenir sur votre machine.

Sachez que d'autres interventions peuvent être en cours actuellement
et qu'il faut compter en moyenne 30 minutes par intervention et par
machine.
Par conséquent, nous ne pouvons pas vous donner plus de précisions
quant à l'heure de début de l'intervention.

Vous pouvez avoir un aperçu global des machines actuellement en défaut
et en intervention sur tout le réseau à cette adresse:

http://travaux.ovh.net/vms/

Votre serveur se trouve dans la baie 45C12

Vous recevrez un email dés qu'un technicien prendra en charge votre
serveur. En attendant, vous avez la possibilité de le rebooter à partir
de votre manager.

Logs:
----------------------
PING ks3289448.kimsufi.com (5.135.183.52) from 213.186.33.13 : 56(84) bytes of data.
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable
From 213.186.33.13: Destination Host Unreachable

--- 5.135.183.52 ping statistics ---
10 packets transmitted, 0 packets received, +6 errors, 100% packet loss
---------------------

jarod6827
30/01/2014, 17h09
Je comprend pas personne à un acces direct a ces serveurs chez kimsufi

jarod6827
30/01/2014, 17h07
Y avais un problème de monitoring

BBR
30/01/2014, 17h03
ovh ne fait rien sans t'en avertir, ils auraient fait quoi ?

jarod6827
30/01/2014, 16h55
ben le probleme sans ssh je suis coince je n'ai rien modifier depuis plus de 6 mois jusqu'a present je sais que kimsufi a travailler sur mon serveur y a quelque jour.

jarod6827
30/01/2014, 16h50
c'est centos 6

BBR
30/01/2014, 16h48
ta distribution c'est quoi ? Cpanel c'est juste une surcouche
edit : réponse postée en même temps, donc pas un desktop
et sur le forum cpanel t'as rien trouvé pour le mot de pass WHM, Google m'a donné plein de lien en cherchant changer pass whm

jarod6827
30/01/2014, 16h48
je suis sous la distibution Système d'exploitation Cpanel 11 (CentOS 6)

jarod6827
30/01/2014, 16h47
ca me dit la connexion n'est pas valide

BBR
30/01/2014, 16h45
oui c'est différent et puis si jamais il est en Ubuntu Desktop, le root machine ce n'est pas root mais Desktop, bref...

admin_julie_srv
30/01/2014, 16h44
En faite je viens de m'apercevoir que je n'arrive plus du tout à aucun des mes comptes cpanel
?? ca te dit quoi?

jarod6827
30/01/2014, 16h44
Ben le probleme c'est que je ne peu pas me connecter sur ssh donc je suis dans une galère lol

admin_julie_srv
30/01/2014, 16h43
Sinon je connait pas Cpanel de Whm, mais d'après http://guides.ovh.com/cpanel
Faut créer un compte utilisateur qui sera admin, je me trompe peut être, mais n'est ce pas différent du compte root?

juste pas curiosité, a tu changer la configuration de sshd, ce qui est le cas pour moi qui fait en sorte que je refuse toute connexion via root?
éventuellement tu peut jeté un oeil dedans c'est "/etc/ssh/sshd_config" sur la partie "PermitRootLogin no"

jarod6827
30/01/2014, 16h41
En faite je viens de m'apercevoir que je n'arrive plus du tout à aucun des mes comptes cpanel

BBR
30/01/2014, 16h33
t'as quoi comme distribution ?

jarod6827
30/01/2014, 16h30
Ssh

BBR
30/01/2014, 16h30
qu'est ce qui ne fonctionne pas ? l'accès ssh ou l'accès à WHM ?

jarod6827
30/01/2014, 16h28
Donc le résultat c'est que cela ne fonctionne pas

jarod6827
30/01/2014, 16h26
Ok je viens de recommencez la procédure Netboot j’attends que le serveur redémarre.

BBR
30/01/2014, 16h21
à l'installation oui, mais si tu changes celui du root est-ce toujours le cas ?
par exemple sur les releases, webmin a le meme pass que le root mais on peut changer et en avoir un différent

jarod6827
30/01/2014, 16h20
Oui le mot de passe est identique a celui du root d'après les dires de OVH

WHM = CPANEL

BBR
30/01/2014, 16h19
je ne connais pas WHM, idée peut être saugrenue, mais est-ce que le mot de passe de ce truc est forcément identique à celui du mot de pass root du serveur ?
essaie déjà de te connecter uniquement en ssh avec root et ton nouveau mot de passe
edit : si ça marche il ne te restera qu'à aller changer le mot de pass de WHM

jarod6827
30/01/2014, 16h14
Suis désoler de ce que j'ai dit au sujet de la sauvegarde, j'ai suivi scrupuleusement tout ce qui à été dit sur le forum.

mount /dev/sda1 /mnt/
mount /dev/sda2 /mnt/home

en 3ème chroot /mnt /

en 4 more /root/.p

en 5 passwd root

en 6 mot de passe * 2

BBR
30/01/2014, 16h11
et la dernière fois tu as bien fait le tuto en suivant scrupuleusement toutes les commandes sans oublier un / ou autre truc qui t'aurait semblé inutile mais qui ne l'est pas ?

nowwhat
30/01/2014, 16h10
Accessoirement:
Ceci:
Citation Envoyé par jarod6827
je n'ai aucune sauvegarde de mes sites ni les base de donnée
Il ne faut JAMAIS dire ça sur un forum.
Car ça te ferme toutes les possibilités pour trouver de l'aide sur un forum.
Dire "je n’ai ni sauvegarde de mes sites ni les base de donnée" est exactement la même chose que dire "mes données et paramétrage, ça m'intéresse pas, ils ne sont pas indispensables".
Ok : pourquoi pas. C’est un choix. Et le jour que t'as un souci: réinstalle le serveur - soucis réglé dans 15 minutes sans que t'as besoin d'aide.
Sinon, un serveur sans sauvegarde est comme une voiture sans assurance …..


édit: t'as mal choisi ton pseudo. Très mal.

jarod6827
30/01/2014, 16h09
Oui c'est ca une fois les modifs fait avec le mot de passe je remet sur le manager le netboot sur hd et je redemarre le serveur

relancer un test je me connecte avec ssh avec mon nouveau mot de passe et j'esseille de me connecter au WHM

BBR
30/01/2014, 16h09
et qu'est-ce que t'appelles "relancer un test"

BBR
30/01/2014, 16h08
donc qu'on soit bien d'accord : tu mets le Netboot sur HD
PUIS
tu cliques sur Redémarrer ?

jarod6827
30/01/2014, 16h06
Super maintenant le serveur ne demarre plus

jarod6827
30/01/2014, 16h02
je reboot en HD et la ca ne marche tjr pas malgres d'avoir relancer un test

admin_julie_srv
30/01/2014, 16h01
juste comme çà après une opération en mode rescue,
ne faut pas oublier de retourner sur le manager puis d'aller sur netboot et de choisir Hardisk ou hd
et enfin de reboot a partir du manager.

admin_julie_srv
30/01/2014, 15h59
Tu reboot comment?

jarod6827
30/01/2014, 15h58
non lol ca marche pas

nowwhat
30/01/2014, 15h56
!!! Bravo !!!!

T'as appliqué la procédure sans bruler des étapes.
Et dans ce cas: ça marche.

T'as même retyrouvé ton ANCIEN mot de passe "mAU7mgv4" !!.
édit: je me trompe.
Tu te goure ......
Ceci est faux: root@rescue:~# chroot /mnt
Et la rpeuve est que: ton prompt ne change pas - il reste "root@rescue"
Le doc te dicte
chroot /mnt/

Sache que dès cet instant (quand t'es pas en mode rescue),
more /root/.p
te donnear toujours
mAU7mgv4
qui n'est plus valable.

PS: note cette procédure quelque part .... repète-le dans quelques semaines.
Un jour, ça va te sauver ton serveur == tes heures/jours/mois/années de travail.

édit: ???
Ca fonctionne pas ?
Ah, je vois ....

BBR
30/01/2014, 15h47
alors refais le tuto en faisant des copiés/collés des commandes et ça va marcher, tout est utile dans ce qui est indiqué, tu remplaces juste le m de md par un s donc sd !

jarod6827
30/01/2014, 15h44
pffffffff ca ne fonctionne pas

jarod6827
30/01/2014, 15h41
ok je fait le test

BBR
30/01/2014, 15h41
le / c'est la racine
regarde si ton mot de passe fonctionne

BBR
30/01/2014, 15h40
euh edite ton post et retire le pass

jarod6827
30/01/2014, 15h39
Ca change quelque chose le / a la fin de mount /dev/sda1 /mnt/ car le mot de passe a été changer

jarod6827
30/01/2014, 15h37
root@rescue:~# mount /dev/sda1 /mnt
root@rescue:~# mount /dev/sda2 /mnt/home
root@rescue:~# chroot /mnt
root@rescue [/]# more /root/.p
++++++++
root@rescue [/]# passwd root
Changing password for user root.
New password:
Retype new password:
passwd: all authentication tokens updated successfully.

BBR
30/01/2014, 15h37
mount /dev/sda1 /mnt/
ne pas oublier le / à la fin pour la partition système
idem :
chroot /mnt/

admin_julie_srv
30/01/2014, 15h36
en 2ème étape

mount /dev/sda1 /mnt
mount /dev/sda2 /mnt/home

en 3ème chroot /mnt

jarod6827
30/01/2014, 15h35
qu'est que je doit faire ensuite vu que j'ai que du sd au lieu du md

jarod6827
30/01/2014, 15h31
1er Etape Fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0005cfe3

Device Boot Start End Blocks Id System
/dev/sda1 * 4096 41947135 20971520 83 Linux
/dev/sda2 41947136 975716351 466884608 83 Linux
/dev/sda3 975716352 976766975 525312 82 Linux swap / Solaris

jarod6827
30/01/2014, 15h30
J'ai 1 disque dur j'ai juste un peu peur de perdre la totalité de mes sites

jarod6827
30/01/2014, 15h27
je vais refaire le test

BBR
30/01/2014, 15h26
le staff ne s'occupe que des problèmes matériels

BBR
30/01/2014, 15h26
pas de panique c'est juste que tu ne dois pas faire tout comme il faut, suis toutes les étapes http://forum.kimsufi.com/showthread....TO-Mode-rescue et postes ici chaque résultat (tu as un seul disque ou 2 ?
si un seul tu remplaces mda par sda dans les commandes

jarod6827
30/01/2014, 15h24
Le staff de kimsufi ne peu t'il pas modifier le pass et me le communiquer tout simplement moi j'ai essaye et cela ne fonctionne pas, j'ai accès à tout mes sites depuis cpanel mais je ne peu plus allez sur le WHM et SSH

jarod6827
30/01/2014, 15h20
je n'ai aucune sauvegarde de mes sites ni les base de donnée

jarod6827
30/01/2014, 15h19
Bin jusqu'a présent tout fonctionnais mes sites fonctionnes avec cpanel simplement je n'arrive plus a me connecter a WHM il me dit le passe est faux meme depuis ssh

admin_julie_srv
30/01/2014, 15h17
T'est disque ne sont pas monté apparament,

et mount çà donne quoi

ainsi comme la suggéré nowwhat le résultat de la commande fdisk -l

jarod6827
30/01/2014, 15h12
Impossible de me connecter au panel de cpanel ni sur ssh

jarod6827
30/01/2014, 15h10
serveur en route sur HD et mot de passe ne fonctionne pas

jarod6827
30/01/2014, 15h07
Une fois cette étape fait sur la modification du mot de passe je viens de remettre sur hd netboot et redémarré le serveur

jarod6827
30/01/2014, 15h05
la j'ai mis un nouveau mot de passe le resultat

root@rescue:~# passwd root
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully

jarod6827
30/01/2014, 15h04
c'est ce que j'ai fait j'ai remis en HD et rebooter le serveur mais le pass ne fonctionne pas

BBR
30/01/2014, 15h03
le pass a été modifié puis tu fais ton test comment ?
parce que une fois sorti de la console rescue, tu dois aller sur le manager, changer le netboot et le remettre en HD puis relancer le serveur, là si tu as changé correctement le pass, tu dois pouvoir te connecter avec

jarod6827
30/01/2014, 15h03
et si je fais more /root/.p ca me donne le mot de passe rescue

jarod6827
30/01/2014, 15h01
root@rescue:~# ls -alh /mnt
total 0
drwxr-xr-x 2 root root 40 Jan 30 13:56 .
drwxrwxrwt 17 root root 420 Jan 30 13:57 ..

nowwhat
30/01/2014, 15h00
Question test:
Que donne :
ls -alh /mnt

et ça:
fdisk -l

jarod6827
30/01/2014, 14h58
quand je fais chroot /mnt/ en ssh il me dit

chroot: failed to run command `/bin/bash': No such file or directory

jarod6827
30/01/2014, 14h56
Je relance un test et je vous écrit les étapes

jarod6827
30/01/2014, 14h54
J'ai modifier le pass comme expliquer

j'ai eu la confirmation que le pass UNIX à été modifier et la je test cela ne fonctionne pas

BBR
30/01/2014, 14h50
tu as suivi le guide depuis le début (montage des partitions) ?

jarod6827
30/01/2014, 14h39
J'ai essayé de change le mot de pass en rescu mais cela ne fonctionne pas

chroot /mnt/
chroot: failed to run command `/bin/bash': No such file or directory

BBR
30/01/2014, 13h13
et plus spécifiquement pour le pass root : http://forum.kimsufi.com/showthread....TO-Mode-rescue

nowwhat
30/01/2014, 12h09
Bonjour,

Je viens d'expliquer le même phénomène en VO : http://forum.kimsufi.com/showthread....493#post129493, çe matin encore.
Cette page http://guides.ovh.com/ModeRescue n'existe pas que pour les geeks mais pour ceux avec un disque dur cassé, ou un mot de passe root oublié (donc: pour tout le monde).

jarod6827
30/01/2014, 11h12
Bonjour,

Je rencontre un probleme avec mon mot de passe Root sur mon serveur ks3289448.kimsufi.com.
Je ne peu ni me connecter via SSH ni sur mon cpanel.
De plus mon serveur à des pannes et coupure depuis quelque jour

Merci pour votre aide

Jonathan MEDER