OVH Community, your new community space.

Mails non distribués


smp
02/02/2014, 18h12
"Si tu es sur liste grise c'est que google a des choses à reprocher "
Certainement personne n'est parfait !
Non sérieusement :
ce serveur gère seulement 5 sites qui ne font pas de newsletter.
Il a été effectivement hacké il y a 1 mois de cela par des faiseurs de spams suite à des codes malveillants et l'adresse à été bloquée par spam assassin du serveur ovh .
Nettoyage des sites incréminés, suppression des mails indésirables, nouvelle queue, déblocage ip chez ovh mais aucun blocage d'ip dans tous les listes qui sont toutes au vert.
le serveur de mail fonctionait normalement depuis, et là depuis hier problème,. Donc bien sûr j'ai vérifié les logs si quantité de mails en attente bizarre.... Pas de soucis juste une queue de 5 à 10 mails en attente

buddy
02/02/2014, 16h01
Citation Envoyé par smp
Voilà la suite
Les mails arrivent maintenant dans un délai de 10 minutes à 1 heure. C'est déjà mieux . Le problème de délai intervient principalement sur gmail et sur les log je vois qu'il est possible que mon ip du serveur soit en liste grise. Savez/vous ce que je peux faire pour sortir du "gris" ? Merci
Si tu es sur liste grise c'est que google a des choses à reprocher à ton ip car apparement tu l'as bien réglé ( 9.2 sur mail-tester ) ...

tu envoies des newsletters de pub ?
Ton serveur n'est pas compromis ?
open relay ? faille / trop de mail envoyés par rapport à l'activité normale de ton site.

smp
02/02/2014, 15h49
Voilà la suite
Les mails arrivent maintenant dans un délai de 10 minutes à 1 heure. C'est déjà mieux . Le problème de délai intervient principalement sur gmail et sur les log je vois qu'il est possible que mon ip du serveur soit en liste grise. Savez/vous ce que je peux faire pour sortir du "gris" ? Merci

smp
02/02/2014, 13h52
Je viens de refaire la queue par ssh et toujours le même problème pourtant la queue parait normale
monserveur ~ # df -h
Sys. de fich. Tail. Occ. Disp. %Occ. Mont? sur
/dev/md/1 10G 2,3G 7,2G 25% /
udev 3,9G 208K 3,9G 1% /dev
/dev/md/2 914G 5,9G 862G 1% /home
shm 3,9G 0 3,9G 0% /dev/shm

smp
02/02/2014, 13h38
Citation Envoyé par buddy
çà veut dire quoi ? 9/10 ? 10/10 ? spf OK ?
9,2 merci de ton implication mais vraiment je ne pense pas que cela vienne de la
Quand je fait l'essai sur d'autres serveurs que je possède avec ces adresses mails, tout cela fonctionne parfaitement

buddy
02/02/2014, 13h09
çà veut dire quoi ? 9/10 ? 10/10 ? spf OK ?

smp
02/02/2014, 13h08
Citation Envoyé par buddy
pour le message d'erreur google connait plein de réponses ... n'utilisant pas qmail à toi de les tester.

Sinon quid du test mail-tester ? tu l'as fait ? tu as envoyé un email à quelle adresse @mail-tester.com ?
quel est le résultat ?
Tout est ok du côté de mail-tester.com
merci

buddy
02/02/2014, 12h59
pour le message d'erreur google connait plein de réponses ... n'utilisant pas qmail à toi de les tester.

Sinon quid du test mail-tester ? tu l'as fait ? tu as envoyé un email à quelle adresse @mail-tester.com ?
quel est le résultat ?

smp
02/02/2014, 12h32
avant tout merci de vos réponses
Les mails arrivent en fait d'une manière aléatoire et avec des delais de 8 à 15 h.
Voici ce quj'ai trouvé dans les log qmail
try later
@4000000052edb3b2228987a4 warning: trouble injecting bounce message, will try later
Encore merci de votre aide

starouille
01/02/2014, 21h26
Citation Envoyé par buddy
Bonsoir,

il faudrait voir ce qu'il y a dans les logs mail /var/log/mail*

tu peux aussi voir si les emails que tu envoies sont fait comme les règles.

utilise ce site : http://www.mail-tester.com/


+1, ce site est tout simplement excellent, et m'a permis d'avoir 10/10 en ajoutant les sign DKIM.

Kitty
01/02/2014, 21h02
Essayer:
Code:
kill -ALRM `ps ax | grep [q]mail-send | awk '{print $1}'`
Cela enverra un signal alarm à la file d'attente-démon (qmail-send) qui devrait commencer le traitement de la file d'attente immédiatement.

buddy
01/02/2014, 21h01
Bonsoir,

il faudrait voir ce qu'il y a dans les logs mail /var/log/mail*

tu peux aussi voir si les emails que tu envoies sont fait comme les règles.

utilise ce site : http://www.mail-tester.com/

smp
01/02/2014, 20h37
Bonsoir je viens vers vous car mes mails ne sont plus distribués depuis ce jour
J'ai vérifier ma queue de mail et elle est normale (juste les mails qui sont en attente depuis ce jour), jai vérifié mon ip et celle ci n'est pas bloquée.
Donc en ssh j'ai arrété qmail puis je l'ai redemarré et cela n'a rien changé
NOM DU SERVEUR ~ # /etc/init.d/qmail stop
* Stopping Qmail ... [ ok ]
NOM DU SERVEUR ~~ # /etc/init.d/qmail start
* Starting Qmail ... [ ok ]
* Starting Pop ... [ ok ]
* Starting Smtp ... [ ok ]

Merci de votre aide