OVH Community, your new community space.

Mon site ne répond pas alors que le serveur KS est ok


Kitty
06/02/2014, 09h12
Citation Envoyé par Bastos23
Bon si le site est à nouveau accessible c'est parfait!! merci au sav anglophone de qualité et merci Kitty pour ton aide précieuse

Good if the site is accessible again this is perfect! thank you in English sav quality and thank you for your invaluable help Kitty
You're welcome

Au revoir!

Bastos23
06/02/2014, 09h11
Bon si le site est à nouveau accessible c'est parfait!! merci au sav anglophone de qualité et merci Kitty pour ton aide précieuse

Good if the site is accessible again this is perfect! thank you in English sav quality and thank you for your invaluable help Kitty

buddy
06/02/2014, 09h06
Hi,

yes it's ok. ( ISP / FAI : SFR - FRance )

Bastos23
06/02/2014, 09h05
you access to it or not?

http://www.you-see.it/

Kitty
06/02/2014, 09h02
It works

Code:
# nslookup
> server ks3294374.kimsufi.com.
Default server: ks3294374.kimsufi.com.
Address: 5.135.190.158#53
> you-see.it.
Server:         ks3294374.kimsufi.com.
Address:        5.135.190.158#53

Name:   you-see.it
Address: 5.135.190.158
Code:
# dig @ks3294374.kimsufi.com you-see.it

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.5 <<>> @ks3294374.kimsufi.com you-see.it
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11873
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;you-see.it.                    IN      A

;; ANSWER SECTION:
you-see.it.             14400   IN      A       5.135.190.158

;; AUTHORITY SECTION:
you-see.it.             14400   IN      NS      ks3294374.kimsufi.com.
you-see.it.             14400   IN      NS      ns.kimsufi.com.

;; Query time: 2 msec
;; SERVER: 5.135.190.158#53(5.135.190.158)
;; WHEN: Thu Feb  6 08:12:55 2014
;; MSG SIZE  rcvd: 96
Code:
# dig @ks3294374.kimsufi.com you-see.it +nssearch
SOA ks3294374.kimsufi.com. hostmaster.you-see.it. 2014020601 14400 3600 1209600 86400 from server 5.135.190.158 in 1 ms.
SOA ks3294374.kimsufi.com. hostmaster.you-see.it. 2014020601 14400 3600 1209600 86400 from server 213.186.33.199 in 4 ms.
SOA ks3294374.kimsufi.com. hostmaster.you-see.it. 2014020601 14400 3600 1209600 86400 from server 2001:41d0:3:1c7::1 in 4 ms.

Bastos23
06/02/2014, 09h01
http://prntscr.com/2pyeir

I think i had not successful?


YESSSSSSSSSSSSSSSSSSSSSS It's good youy'are really the best thank you very very much

Kitty
06/02/2014, 09h00
And it's CTRL-X to quit nano, not CTRL-Q (I use vim, which uses :q).

Sorry!

Kitty
06/02/2014, 08h54
Which file is that?

I made a mistake on the first one, see my edit. It should be nano /etc/bind/named.conf.local .

Bastos23
06/02/2014, 08h52
http://prntscr.com/2pydcw

I tell you the controls and me it was two

he asks me if I want to "write the file under a changed name?"

Kitty
06/02/2014, 08h46
OK

Code:
nano /etc/bind/named.conf.local
Paste this at the end
Code:
zone "you-see.it" { type master; file "/var/named/zones/you-see.it.db"; allow-query { any; }; };
Hit CTRL-O and then ENTER to save the file, followed by CTRL-X to quit.

Then
Code:
mkdir -p /var/named/zones
nano /var/named/zones/you-see.it.db
Paste this into the new, empty file:
Code:
$TTL 14400
@       IN      SOA     ks3294374.kimsufi.com.      hostmaster.you-see.it. (
                                                2014020601  ; serial
                                                14400 ; refresh after 4 hours
                                                3600 ; retry after 1 hour
                                                1209600 ; expire after 14 days
                                                86400 ) ; minimum ttl of 1 day

you-see.it.  14400   IN      NS      ks3294374.kimsufi.com.
you-see.it.  14400   IN      NS      ns.kimsufi.com.
you-see.it.  14400   IN      A       5.135.190.158
localhost       14400   IN      A       127.0.0.1
www     14400   IN      A       5.135.190.158
localhost       14400   IN      AAAA    ::1
Hit CTRL-O and then ENTER to save the file, followed by CTRL-X to quit.

Then
Code:
/etc/init.d/bind9 restart
EDIT: Fixed/Changed the first file name to .local

Bastos23
06/02/2014, 08h40
Code:
options {
        directory "/var/cache/bind";

        // If there is a firewall between you and nameservers you want
        // to talk to, you may need to fix the firewall to allow multiple
        // ports to talk.  See http://www.kb.cert.org/vuls/id/800113

        // If your ISP provided one or more IP addresses for stable 
        // nameservers, you probably want to use them as forwarders.  
        // Uncomment the following block, and insert the addresses replacing 
        // the all-0's placeholder.

        // forwarders {
        //      0.0.0.0;
        // };

        //========================================================================
        // If BIND logs error messages about the root key being expired,
        // you will need to update your keys.  See https://www.isc.org/bind-keys
        //========================================================================
        dnssec-validation auto;

        auth-nxdomain no;    # conform to RFC1035
        listen-on-v6 { any; };
        listen-on { any; };



        recursion yes;
        allow-recursion { 127.0.0.1; ::1; };
        allow-transfer { 213.186.33.199 ; 2001:41d0:3:1c7::1; };
        notify yes;
};
and

Code:
root@ks3294374:~# cat /etc/bind/named.conf.local
//
// Do any local configuration here
//

// Consider adding the 1918 zones here, if they are not used in your
// organization
//include "/etc/bind/zones.rfc1918";

Kitty
06/02/2014, 08h38
I have 20 minutes before I have to go.

Kitty
06/02/2014, 08h36
Paste the output of cat /etc/bind/named.conf.options and cat /etc/bind/named.conf.local here, between [code][/code] tags.

Bastos23
06/02/2014, 08h31
If I had you order it to help me as I wade completely .... I trust you so, please, help me to perform these manipulations ...

Kitty
06/02/2014, 08h26
I'm sorry, but I really don't feel comfortable getting that involved. I do appreciate it though. (But it's a very dangerous thing to do on your part!)

Your server is actually listening and responding to queries, it just isn't allowing them from outside. If you edit the files as above and restart named then I see no reason why it shouldn't work. The edit to named.conf.local should fix access, and the zone file will define the zone records.

You will need to restart or reload named after this. On Debian that's probably /etc/init.d/bind9 restart

Bastos23
06/02/2014, 08h12
take that please and see https://filetea.me/t1slTvDHeyLTNmB5dUwrE2wcA

Kitty
06/02/2014, 07h49
I'll try

You need a file to define the zone, and an entry in named.conf.local which references that file.

I would use /var/lib/named/zones/you-see.it.db as the zone file, so I would add this line to the existing named.conf.local:
Code:
zone "you-see.it" { type master; file "/var/named/zones/you-see.it.db"; allow-query { any; }; };
That will load the zone file and allow any machine to query for it, without turning your server into an open DNS server for all zones.

So, nano /etc/bind/named.conf.local and then paste that line at the end.

Then create the file /var/lib/named/zones/you-see-it.db and make it look like this. You should look up what this does, particularly in relation to the serial number, which you have to change every time you edit it. Make sure you replace ip.add.re.ss with the server's IP address.
Code:
$TTL 14400
@       IN      SOA     ks3294374.kimsufi.com.      hostmaster.you-see.it. (
                                                2014020601  ; serial
                                                14400 ; refresh after 4 hours
                                                3600 ; retry after 1 hour
                                                1209600 ; expire after 14 days
                                                86400 ) ; minimum ttl of 1 day

you-see.it.  14400   IN      NS      ks3294374.kimsufi.com.
you-see.it.  14400   IN      NS      ns.kimsufi.com.
you-see.it.  14400   IN      A       ip.add.re.ss
localhost       14400   IN      A       127.0.0.1
www     14400   IN      A       ip.add.re.ss
localhost       14400   IN      AAAA    ::1
So, nano /var/lib/named/zones/you-see-it.db and paste in the above (but change the ip.add.re.ss and check for errors on my part first!).

Restart named and things should work.

The serial is in the format YYYYMMDDnn where YYYY is the year, MM is the month, and DD is the date. nn is used for multiple changes on one date. It starts at at 01 and increments with each change on a single day. If you make a change on a new day, it should be reset to 01.

e2a: You may need to create /var/lib/named/zones with mkdir -p /var/lib/named/zones , or your distribution may have another place for zone files.

Bastos23
06/02/2014, 07h31
vous pouvez très bien m'expliquer en détail in english there's no problem

Kitty
06/02/2014, 07h11
Citation Envoyé par Bastos23
ce que je veux c'est un truc détaillé avec des commandes en ssh à entrer que je puisse faire ce qu'il faut
C'est peut-être plus facile avec une personne qui parle français.

Bastos23
06/02/2014, 07h10
http://prntscr.com/2pxz8q

voici la distrib en question

Kitty
06/02/2014, 07h09
Il faut quelque chose de ce genre dans named.conf (ou /etc/bind/named.local?):
Code:
zone "you-see.it" { type master; file "/var/named/zones/you-see.it.db"; allow-query { any; }; };
Et puis un fichier pour définir la zone.
Code:
$TTL 14400
@       IN      SOA     ks3294374.kimsufi.com.      hostmaster.you-see.it. (
                                                2014020601
                                                14400
                                                3600
                                                1209600
                                                86400 )

you-see.it.  14400   IN      NS      ks3294374.kimsufi.com.
you-see.it.  14400   IN      NS      ns.kimsufi.com.
you-see.it.  14400   IN      A       ip.add.re.ss
localhost       14400   IN      A       127.0.0.1
www     14400   IN      A       ip.add.re.ss
localhost       14400   IN      AAAA    ::1
Ceux-ci sont associés à un serveur maître. Il est différent pour les esclaves.

Les lieux, les noms et contentsof ces fichiers peuvent varier en fonction de la distribution. Vous devriez vérifier où vôtres sont par défaut.

Bastos23
06/02/2014, 07h01
ce que je veux c'est un truc détaillé avec des commandes en ssh à entrer que je puisse faire ce qu'il faut

Bastos23
06/02/2014, 06h56
Ceci suggère que le serveur est à l'écoute, mais refuse les demandes. Vous devez allow-query {any;}; quelque part, et prefereably dans le fichier de zone, pas la section globale.
je dois allow-query quelque part? c'est à dire? où? fichier de zone? quel fichier? la je nage grave !!

Kitty
06/02/2014, 06h48
Je pense que la langue / traduction n'aide pas.

Je pense que votre serveur est à l'écoute, mais refuser les demandes.

Avez-vous configuré la zone sur le serveur?

Pour d'informations:
Code:
# nslookup
> server ns.kimsufi.com
Default server: ns.kimsufi.com
Address: 2001:41d0:3:1c7::1#53
Default server: ns.kimsufi.com
Address: 213.186.33.199#53
> you-see.it
Server:         ns.kimsufi.com
Address:        2001:41d0:3:1c7::1#53

** server can't find you-see.it: NXDOMAIN
> server ks3294374.kimsufi.com
Default server: ks3294374.kimsufi.com
Address: 5.135.190.158#53
> you-see.it.
Server:         ks3294374.kimsufi.com
Address:        5.135.190.158#53

** server can't find you-see.it: REFUSED
> exit
Ceci suggère que le serveur est à l'écoute, mais refuse les demandes. Vous devez Allow-query {any;}; quelque part, et prefereably dans le fichier de zone, pas la section globale.

Bastos23
06/02/2014, 06h30
merci pour ces détails mais ce que vous comprenez pas c'est que je n'y connais rien à ces fichiers ou mêmes ces recherches

vous voulez mes axx serveurs pour y jeter un oeil et y voir ce qui cloche?

Kitty
06/02/2014, 06h21
Regardez dans chacun de ces fichiers jusqu'à ce que vous trouviez un qui ressemble à ceci:

Code:
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
        listen-on port 53 { 127.0.0.1; }; Changer ce
        listen-on-v6 port 53 { ::1; };
        directory       "/var/named";
        dump-file       "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
        allow-query     { localhost; };
        recursion yes;

Bastos23
06/02/2014, 06h16
http://prntscr.com/2pxqec

j'ai ça

Kitty
06/02/2014, 06h13
L'emplacement peut varier en fonction de la distribution.

Essayer /etc/bind/named.conf . Si vous ne trouvez toujours pas, essayez find /etc/ -name named.conf .

e2a: nano peut-être plus facile que vim

Bastos23
06/02/2014, 06h05
J' ai Notepad++ en éditeur et pour éditer quelle est la commande?
voilà en éditant le fichier

http://prntscr.com/2pxore

je fais quoi là

Kitty
06/02/2014, 06h02
Vous devez utiliser un éditeur de texte, tel que nano ou vi, éditer le fichier /etc/named.conf.

Ajouter (ou modifier) les déclarations en italique ci-dessus.

Bastos23
06/02/2014, 05h58
Euh oui je procède comment? c'est un peu du charabia pour moi là !! une méthode précise?

Kitty
06/02/2014, 05h55
Citation Envoyé par Bastos23
Il faudrait modifier la directive "listen-on" dans le fichier "named.conf".
Soit carrément la supprimer (la mettre en commentaire), soit ajouter
l'adresse IP publique du dédié.
Listen-on { any; }; ou Listen-on { 127.0.0.1; 5.135.190.158; };

Aussi, dans la section globale Allow-query { localhost; }; et dans dans la section de domaine Allow-query { any; };

Bastos23
06/02/2014, 05h50
quelqu'un pour m'aider là? je désespère un peu

Bastos23
05/02/2014, 10h51
http://prntscr.com/2po6qw

Voilà le rendu

Mon serveur est bien en écoute en UDP sur le port 53, mais seulement sur l'adresse IP
locale (127.0.0.1) et donc il ne répond pas au reste du monde sur son
adresse IP publique (5.135.190.158).

Il faudrait modifier la directive "listen-on" dans le fichier "named.conf".
Soit carrément la supprimer (la mettre en commentaire), soit ajouter
l'adresse IP publique du dédié.

mais comment effectuer correctement cette manoeuvre svp?

BBR
05/02/2014, 10h49
et vérifier que le serveur répond sur le port 53 et écoute sur l'ip du serveur

nowwhat
05/02/2014, 10h43
Yep.

whois you-see.it
Puis nous trouvons les DNS:
Nameservers
ns.kimsufi.com
ks3294374.kimsufi.com
Or,
dig @ks3294374.kimsufi.com you-see.it
me donne:
... status: REFUSED,

Pareil pour le DNS scondaire, il n'est plus sync du tout:
dig @ns.kimsufi.com you-see.it
..... Nada.

Conclusion: visibilité du nom de domaine sur le net : zéro... t'es plus la.


A vérifier: console SSH:
named-checkconf -z

Vérification serial SOA de la zone "you-see.it".

Dès démarrage bind sans erreurs:
netstat -taupn | grep 'named'
Il doit y avoir des programmes nommé 'named' ( = bind) à l'écoute sur la '53' (UDP et TCP).

et le magique:
dig @ks3294374.kimsufi.com you-see.it
doit donner une réponse pour le record A.

Bastos23
05/02/2014, 10h25
Oui apparemment soucis avec les DNS

sloomy
05/02/2014, 08h46
Bonjour,

Assez étonnant oui :

dig you-see.it

; <<>> DiG 9.9.4-P1 <<>> you-see.it
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 47958
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;you-see.it. IN A

;; Query time: 203 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Feb 05 07:45:32 CET 2014
;; MSG SIZE rcvd: 39

Pas de réponse ! avez-vous un soucis avec les DNS ?

Bruno

Bastos23
05/02/2014, 04h48
Bonsoir, mon serveur KS ks3294374 est ok , j'y accède SSH , ftp .... le contenu du site est ok , je n'ai fait aucune modif apache ...
par contre mon site : you-see.it/ ne marche pas , on dirait un problème DNS ! les autres sites répondent
Que faut-il vérifier ? j'ai debian7 et ispconfig
Merci pour votre aide