OVH Community, your new community space.

DNS Propagation


blackcat
04/03/2014, 11h52
Bonjour Buddy,

Voilà mes constatations, il ne faut pas enregistrer ses dns secondaires sur le serveur2 tout de suite après les avoir effacer du serveur1 sinon ns.kimsufi.com ne se mettra pas à jour et continuera à pointer vers le serveur1 même en attendant 4-5 jours! (bug à remonter).

Donc pour qu'il n'y ait pas de problème, effacer ses dns secondaire du serveur1, attendre 24h-48h
Voir que vous n'existez plus pour ns.kimsufi.com ici (http://www.kloth.net/services/dig.php)
Enregistrer les dns secondaire sur le serveur 2

Encore mieux, ne pas utiliser les dns secondaire de kimsufi, ça met la pagaille!

Cordialement.

buddy
03/03/2014, 21h32
C'est bon maintenant ton site pointe bien vers le nouveau serveur ( si çà n'est pas le cas sur ton PC c'est surement le cache DNS de ta box ou de ton PC )

par contre pourquoi tu as sdns1.ovh.net dans ta zone dns ?? c'est pas le bon serveur ..

buddy
03/03/2014, 20h51
Je ne vois pas le code ownercheck pour ton domaine... tu peux afficher ici ton fichier de zone pour ce domaine ??

buddy
03/03/2014, 20h50
Lis les logs de ton nouveau serveur alors..
Ns kimsufi doit essayer mais doit se prendre une erreur...

blackcat
03/03/2014, 17h56
C'est apparemment ns.kimsufi.com qui pointe encore sur l'ancien serveur qui me pose problème.
J'ai pourtant supprimé le nom dans mon manager depuis plusieurs jours serveur dédié> serveur secondaire
et enregistré sur le nouveau serveur à la place.

; <<>> DiG 9.7.3 <<>> @ns.kimsufi.com lecontemporain.net A
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46876
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;lecontemporain.net. IN A

;; ANSWER SECTION:
lecontemporain.net. 86400 IN A xxx <- ancien serveur

;; Query time: 21 msec
;; SERVER: 2001:41d0:3:1c7::1#53(2001:41d0:3:1c7::1)
;; WHEN: Mon Mar 3 16:51:30 2014
;; MSG SIZE rcvd: 52

Arret redémarrer
oui et le tuto c'est ce que j'avais déjà fait.

buddy
03/03/2014, 14h13
Tu as bien reload bind sur le nouveau serveur ?? Arret redémarrer ??

Tu as bien suivi cette procédure pour tous les domaines migrés pour les remettre sur ns.kimsufi.com
http://forum.kimsufi.com/showthread.php?20755-TUTO-Comment-ajouter-un-domaine ??

blackcat
03/03/2014, 14h09
Citation Envoyé par buddy
Alors supprime leur zone dns de l ancien serveur et reload /redémarre le bind sur ton ancien serveur. Je parle des domaines 100% migré s.
Voilà je viens de supprimer sa zone sur l'ancien serveur. ça m'embête de procéder comme ça pour les futures migrations, il risque d'avoir une interruption de service.

buddy
03/03/2014, 14h03
Alors supprime leur zone dns de l ancien serveur et reload /redémarre le bind sur ton ancien serveur. Je parle des domaines 100% migré s.

phil_
03/03/2014, 14h01
Citation Envoyé par buddy
Son serveur dns marche tres bien...
Effectivement, j'ai du tester pendant que son bind était down:
user@xxxxxx:~$ nmap -A ns3306208.ip-178-32-219.eu -p 53

Starting Nmap 5.00 ( http://nmap.org ) at 2014-03-03 12:59 CET
Interesting ports on ns3306208.ip-178-32-219.eu (178.32.219.141):
PORT STATE SERVICE VERSION
53/tcp open domain

Service detection performed. Please report any incorrect results at http://nmap.org/submit/ .
Nmap done: 1 IP address (1 host up) scanned in 15.26 seconds

blackcat
03/03/2014, 14h00
Je ne peux pas couper le daemon bind, j'ai encore besoin de l'ancien serveur où il y a des sites que je n'ai pas encore migré

Je viens de faire un nslookup du domaine ça pointe encore sur l'ancien serveur grrrr


Citation Envoyé par buddy
Au fait pense à relancer le service bind sur ton nouveau serveur pour qu il prennent en compte la modifixation de allow transfer et à le couper sur l ancien serveur.
ça été fait

buddy
03/03/2014, 13h59
Au fait pense à relancer le service bind sur ton nouveau serveur pour qu il prennent en compte la modifixation de allow transfer et à le couper sur l ancien serveur.

buddy
03/03/2014, 13h51
Citation Envoyé par blackcat
Ils n'y sont plus sur l'ancien.
.
Si ils y sont tjs sur l ancien... coupe le daemon bind sur ton ancien serveur.


; <<>> DiG 9.7.3 <<>> @ks28359.kimsufi.com lecontemporain.net SOA
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40704
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;lecontemporain.net. IN SOA

;; ANSWER SECTION:
lecontemporain.net. 86400 IN SOA lecontemporain.net. postmaster.lecontemporain.net. 2012021703 21600 3600 604800 86400

;; AUTHORITY SECTION:
lecontemporain.net. 86400 IN NS ks28359.kimsufi.com.
lecontemporain.net. 86400 IN NS ns.kimsufi.com.

;; Query time: 16 msec
;; SERVER: 91.121.92.189#53(91.121.92.189)
;; WHEN: Mon Mar 3 12:49:19 2014
;; MSG SIZE rcvd: 133

buddy
03/03/2014, 13h48
Son serveur dns marche tres bien...
; <<>> DiG 9.7.3 <<>> @ns3306208.ip-178-32-219.eu lecontemporain.net A
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63314
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;lecontemporain.net. IN A

;; ANSWER SECTION:
lecontemporain.net. 38400 IN A 178.32.219.141

phil_
03/03/2014, 13h38
Une remarque, un whois sur ton domaine me renvoie:
Domain Name: LECONTEMPORAIN.NET
Registrar: OVH
Whois Server: whois.ovh.com
Referral URL: http://www.ovh.com
Name Server: NS.KIMSUFI.COM
Name Server: NS3306208.IP-178-32-219.EU
Status: clientDeleteProhibited
Status: clientTransferProhibited
Updated Date: 27-feb-2014
Creation Date: 22-mar-2011
Expiration Date: 22-mar-2014
Mais tu n'as pas de nameserver qui écoute sur le port 53 ou il est filtré.
user@xxxxxx:~$ nmap -A ns3306208.ip-178-32-219.eu

Starting Nmap 5.00 ( http://nmap.org ) at 2014-03-03 12:24 CET
Interesting ports on ns3306208.ip-178-32-219.eu (178.32.219.141):
Not shown: 987 closed ports
PORT STATE SERVICE VERSION
21/tcp open ftp ProFTPD 1.3.4a
22/tcp open ssh OpenSSH 6.0p1 Debian 4 (protocol 2.0)
| ssh-hostkey: 1024 85:df:ea:ab:6e:55:63:7e:2c:de:9d:9a:e4:87:18:27 (DSA)
|_ 2048 ba:89:6b:24:46:a0:dc:f3:d2:e3:1c:3f:9f:24:ce:8a (RSA)
25/tcp open smtp Postfix smtpd
|_ smtp-commands: EHLO ns3306208.ip-178-32-219.eu, PIPELINING, SIZE 10240000, VRFY, ETRN, STARTTLS, AUT H PLAIN LOGIN, AUTH=PLAIN LOGIN, ENHANCEDSTATUSCODES, 8BITMIME, DSN
80/tcp open http Apache httpd 2.2.22 ((Debian))
110/tcp open pop3 Dovecot pop3d
|_ pop3-capabilities: USER CAPA RESP-CODES UIDL PIPELINING STLS TOP SASL(PLAIN)
143/tcp open imap Dovecot imapd
|_ imap-capabilities: LOGIN-REFERRALS STARTTLS IMAP4rev1 ENABLE AUTH=PLAIN LITERAL+ IDLE SASL-IR ID
443/tcp open http Apache httpd 2.2.22 ((Debian))
|_ html-title: Site doesn't have a title (text/html).
445/tcp filtered microsoft-ds
587/tcp open smtp Postfix smtpd
|_ smtp-commands: EHLO ns3306208.ip-178-32-219.eu, PIPELINING, SIZE 10240000, VRFY, ETRN, STARTTLS, AUT H PLAIN LOGIN, AUTH=PLAIN LOGIN, ENHANCEDSTATUSCODES, 8BITMIME, DSN
993/tcp open ssl/imap Dovecot imapd
|_ imap-capabilities: IMAP4rev1 AUTH=PLAIN ENABLE ID LITERAL+ IDLE SASL-IR LOGIN-REFERRALS
995/tcp open ssl/pop3 Dovecot pop3d
|_ pop3-capabilities: USER CAPA UIDL PIPELINING RESP-CODES TOP SASL(PLAIN)
10000/tcp open ssl/snet-sensor-mgmt?
20000/tcp open ssl/unknown
Et puis comme d'habitude. Quelle idée d'héberger son propre nameserver quand ceux d'OVH fonctionnent 100x mieux ?

nidecondor
03/03/2014, 13h32
Peux-tu poster ton fichier de config DNS : chez moi c'est ici /var/named/domaine.hosts

buddy
03/03/2014, 13h30
Ca pointe sur l ancien car ns.kimsufi.com est tjs syncro sur l ancien..

Je dirais que d ici 14h nskimsufi devrait etrez synchro.

blackcat
03/03/2014, 13h15
Ils n'y sont plus sur l'ancien.

Je pense qu'effectivement que ça vient du allow transfer.
Vous pensez que va prendre combien de temps la prise en compte de la modif ?

allow-transfer {127.0.0.1;localnets;};

> allow-transfer {xxxx;};


Citation Envoyé par nidecondor
Salut,
As-tu bien modifié le serveur primaire + secondaire chez ton registrar ?
Il semblerait que aucun serveur secondaire ne soit associé à ton domaine.
Oui c'est pour ça que je suis étonné que les enregistrements montrent bien le nouveau serveur primaire mais pointe toujours sur l'ancien.

nidecondor
03/03/2014, 13h04
Salut,
As-tu bien modifié le serveur primaire + secondaire chez ton registrar ?
Il semblerait que aucun serveur secondaire ne soit associé à ton domaine.

buddy
03/03/2014, 13h01
Il faut les enlever de l ancien dans tous les cas...

Coupe aussi la resolution dns de tes domaines sur ton ancien serveur.

buddy
03/03/2014, 12h59
Si ils sont sur le nouveau c est que tu les a supprimé de l ancien non ??

Je t ai mis un lien au dessus pdt que tu postais pour verifier que ton nouveau serveur accepte bien que Ns.kimsufi.com se syncro avec lui.

blackcat
03/03/2014, 12h57
Est ce que je dois les supprimer de mon nouveau avant car j'ai ce message :

lecontemporain.net realNameserver n'est pas défini à ksxxx.kimsufi.com

buddy
03/03/2014, 12h48
Va dans le manager de ton ancien serveur

Services
Dns secondaires
Supprime le domaine

Dans le manager de ton nouveau serveur
Services dns secondaires
Ajoute ton domaine.

Si tu as bien ajoute le dns secondaires sur ton nouveau serveur alors verifie que sur ton nouveau serveur tu as bien l ipv4 de ns kimsufi com dans allow transfer de ton bind.

Un tuto http://blog.idneo.fr/configuration-dns-bind9-linux-manager-ovh/

blackcat
03/03/2014, 12h42
Salut buddy,

Ancien serveur : ksxxx.kimsufi.com
Nouveau serveur : nsxxx.eu
Il est enregistré sur le nsxxx.eu mais pointe vers ksxxx.kimsufi.com

Merci

buddy
03/03/2014, 12h35
Bonjour,

Sans nom de domaine ca va nous prendre 6 plombes de t aider en partant dans des supposition s diverses et variées..
Avec le nom de domaine et les noms de ton nouveau et ancien serveur 5 min max...
Tu pourras les supprimer apres si tu veux.

blackcat
03/03/2014, 12h29
Bonjour,

J'ai fait le transfert de mes sites qui étaient sur un Kimsufi vers un nouveau plus puissant.
Et depuis mercredi dernier j'attends que la propagation se fasse mais j'ai l'impression que le problème vient d'ailleurs.
J'ai configuré correctement les ndd pour faire pointer vers mon nouveau nsxxx.eu et le ns.kimsufi.com
Configuré correctement le nouveau serveur pour enregistrer les dns secondaires et redémarrer le tout mais rien n'y fait mon ndd pointe toujours sur mon ancien ks.
J'ai bien effacé l'enregistrement dns secondaire de mon ancien serveur.

Pourquoi lorsque je ping mon ndd, c'est mon ancien serveur qui remonte alors que les whois indique bien le nouveau (modifié il y a 5 jours), comment est-ce possible

Est ce que quelqu'un à une idée d'où cela peu provenir ?

Merci pour votre aide