OVH Community, your new community space.

KS16-2012 + ESXi 5.0 + IPFailOver = trop de requêtes ARP


GrinGrin
05/03/2014, 00h34
Bonjour,

Je dispose d'un KS16G de 2012 avec 4 IP FailOver (petit bug lors d'une commande doublée) installé initialement avec ESXi 4.1.
Actuellement 3 VM sont en fonctionnement "continu" et 3/4 autres VM servent a faire des tests en tout genre. Toutes ont été sauvegardées de l'ancienne installation mais non upgradées en VM8.

Ce weekend j'ai utilisé ma 4ème IP FailOver pour installer un Sophos UTM9 sur une VM fraiche (VM8) et servir de passerelle à une autre machine pour faire des tests avec OpenVPN en mode bridge.

Lundi matin, première surprise: mail du support me signalant que l'une de mes IP émettait trop de requêtes ARP (type who has). Cela concernait l'IP du Sophos.J'ai donc en catastrophe arrêté la machine à distance pour limiter la casse.

Le soir je fais quelques vérifications dans la conf ESXi et de la VM pour voir si une option n'était pas activée par erreur au niveau ARP mais rien. Je réinstalle donc la VM sans procéder à la configuration des interfaces réseau avant d'aller me coucher.

Mardi matin, seconde surprise: nouveau mail du support d'avertissement avant blocage de l'IP pour la même raison.
Le soir j'ai donc installé un wireshark sur l'une des 3 autres VM, activé le mode promiscious du vSwitch connecté à l'extérieur et j'ai sniffé les paquets ARP, résultat les cartes réseau semble folles!

Je remarque des blocs de 3 ou 4 requêtes de la même carte:
Code:
80	20:39:03.418501000	Vmware_0a:77:08	Cisco_00:01:01	ARP	60	Who has 94.23.35.254?  Tell 87.98.153.19
81	20:39:04.418490000	Vmware_0a:77:08	Cisco_00:01:01	ARP	60	Who has 94.23.35.254?  Tell 87.98.153.19
82	20:39:05.418608000	Vmware_0a:77:08	Cisco_00:01:01	ARP	60	Who has 94.23.35.254?  Tell 87.98.153.19
En voyant le traffic passer, je décide de regarder ce que font les 3 autres cartes avec des IP FailOver: même constat
Etrangement, OVH ne s'est jamais plaint des autres IP alors qu'elles ont le même comportement!

Ne pouvant pas contacter le support, offre Kimsufi oblige, je ne peux même pas essayer de voir avec eux si en désactivant le mode promiscious les cartes envoient toujours des requêtes inconsidérées ou pas...

Donc si quelqu'un a déjà fait cette mauvaise expérience et l'a résolue et venait à passer par là, je suis preneur de toutes suggestions (même du support s'ils passent des fois ! )

Avant de changer de serveur pour réinstaller un ESXi, je préfèrerais savoir si je risque de rencontrer le même problème !

Merci à ceux qui se pencheront sur la question

Nico.