OVH Community, your new community space.

Erreur sur Gentoo avec emerge ffmpeg.


lc34500
05/03/2014, 12h56
Salut BBR,
Et quelle serait la bonne approche pour faire une install de ffmpeg sur gentoo ?

BBR
05/03/2014, 12h44
eh oui IL NE FAUT JAMAIS faire ça sur une release 2
tu as peut être (surement) cassé plein de trucs sur la R2 qui est hyper propriétaire et ne supporte pas ce genre de trucs.

lc34500
05/03/2014, 12h38
Bonjour,

J'ai cette erreur en faisant un simple "emerge ffmpeg" sur gentoo :
Quelqu'un aurait il une piste ?



!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
default/linux/x86/13.0

Calculating dependencies \ *
* ERROR: dev-lang/php4-ovh-4.4.8_pre20070816-r1 failed.
* Call stack:
* ebuild.sh, line 1590: Called source '/usr/local/portage-ovh/dev-lang/php4-ovh/php4-ovh-4.4.8_pre20070816-r1.ebuild'
* php4-ovh-4.4.8_pre20070816-r1.ebuild, line 29: Called inherit 'php4_4-sapi'
* ebuild.sh, line 1312: Called die
* The specific snippet of code:
* QA Notice: 'sed' called in global scope: eclass php4_4-sapi
* QA Notice: 'sed' called in global scope: eclass php4_4-sapi
* [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
* The die message:
* php4_4-sapi.eclass could not be found by inherit()
*
* If you need support, post the topmost build error, and the call stack if relevant.
* This ebuild is from an overlay: '/usr/local/portage-ovh/'
*
/!!! A file is not listed in the Manifest: '/usr/local/portage-ovh/dev-db/phpmyadmin/phpmyadmin-3.3.5.1.ebuild'
\ *
* ERROR: dev-lang/php5-ovh-5.2.13-r1 failed.
* Call stack:
* ebuild.sh, line 1590: Called source '/usr/local/portage-ovh/dev-lang/php5-ovh/php5-ovh-5.2.13-r1.ebuild'
* php5-ovh-5.2.13-r1.ebuild, line 26: Called inherit 'php5_2-sapi'
* ebuild.sh, line 1312: Called die
* The specific snippet of code:
* QA Notice: 'sed' called in global scope: eclass php5_2-sapi
* QA Notice: 'sed' called in global scope: eclass php5_2-sapi
* [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
* The die message:
* php5_2-sapi.eclass could not be found by inherit()
*
* If you need support, post the topmost build error, and the call stack if relevant.
* This ebuild is from an overlay: '/usr/local/portage-ovh/'
*
| *
* ERROR: dev-lang/php5-ovh-5.3.8 failed.
* Call stack:
* ebuild.sh, line 1590: Called source '/usr/local/portage-ovh/dev-lang/php5-ovh/php5-ovh-5.3.8.ebuild'
* php5-ovh-5.3.8.ebuild, line 26: Called inherit 'php5_3-sapi'
* ebuild.sh, line 1312: Called die
* The specific snippet of code:
* QA Notice: 'sed' called in global scope: eclass php5_3-sapi
* QA Notice: 'sed' called in global scope: eclass php5_3-sapi
* [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
* The die message:
* php5_3-sapi.eclass could not be found by inherit()
*
* If you need support, post the topmost build error, and the call stack if relevant.
* This ebuild is from an overlay: '/usr/local/portage-ovh/'
*
/ *
* ERROR: net-misc/openssh-5.5_p1 failed.
* Call stack:
* ebuild.sh, line 1590: Called source '/usr/local/portage-ovh/net-misc/openssh/openssh-5.5_p1.ebuild'
* openssh-5.5_p1.ebuild, line 5: Called inherit 'eutils' 'flag-o-matic' 'ccc' 'multilib' 'autotools' 'pam'
* ebuild.sh, line 1312: Called die
* The specific snippet of code:
* QA Notice: 'sed' called in global scope: eclass ccc
* QA Notice: 'sed' called in global scope: eclass ccc
* [ ! -e "$location" ] && die "${1}.eclass could not be found by inherit()"
* The die message:
* ccc.eclass could not be found by inherit()
*
* If you need support, post the topmost build error, and the call stack if relevant.
* This ebuild is from an overlay: '/usr/local/portage-ovh/'
*
/
!!! All ebuilds that could satisfy "ffmpeg" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-video/ffmpeg-0.10.11 (masked by: required EAPI 5, supported EAPI 1)
- media-video/ffmpeg-1.0.8 (masked by: required EAPI 4, supported EAPI 1)
- media-video/ffmpeg-1.2.5 (masked by: required EAPI 4, supported EAPI 1)
- media-video/ffmpeg-2.1.3 (masked by: required EAPI 5, supported EAPI 1)
/usr/portage/profiles/package.mask:
# Alexis Ballier (20 Jul 2013)
# New major release and lots of packages fail to build.
# Tracker bug is: https://bugs.gentoo.org/show_bug.cgi?id=476490

- media-video/ffmpeg-9999 (masked by: required EAPI 5, supported EAPI 1)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.