OVH Community, your new community space.

Changement de serveur DNS


armadeus
19/03/2014, 12h34
Sujet à déplacer dans le bon forum (entraide - administration - conseils), je me suis raté dans sa création.

armadeus
19/03/2014, 12h23
Bonjour,

J'ai récemment obtenu un serveur Kimsufi (appelons-le KS2) et je souhaite transférer un site (42pixels.fr) depuis un autre Kimsufi (appelons-le KS1).
KS1 était le serveur DNS du domaine, mais je souhaite maintenant revenir sur les DNS d'OVH.
(KS1 = 176.31.249.72 ; KS2 = 91.121.173.83)

J'ai donc activé la zone DNS dans le manager OVH en laissant tout par défaut et indiquant le KS2 dans le champ A :


J'ai mis à jour les noms des serveurs DNS toujours dans le manager OVH :


Si je fais un zoneCheck (http://www.afnic.fr/fr/produits-et-s...laire-complet/) en indiquant les serveurs DNS primaires et secondaires (dns200.anycast.me et ns200.anycast.me) tout est OK, et la propagation DNS se fait bien (https://www.whatsmydns.net/#A/42pixels.fr).

Par contre si je fais un zoneCheck sans indiquer les serveur DNS, j'ai droit à un message d'erreur :
Le domaine 42pixels.fr n'a pas été trouvé à partir du résolveur local
Depuis KS2 pareil, le domaine est résolu seulement si je lui indique le serveur DNS.

Code:
root@KS2$ dig 42pixels.fr

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> 42pixels.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 16423
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;42pixels.fr.                   IN      A

;; Query time: 13 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Mar 19 11:00:36 2014
;; MSG SIZE  rcvd: 29
Code:
root@KS2$ dig @dns200.anycast.me 42pixels.fr

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> @dns200.anycast.me 42pixels.fr
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13417
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;42pixels.fr.                   IN      A

;; ANSWER SECTION:
42pixels.fr.            3600    IN      A       91.121.173.83

;; Query time: 4 msec
;; SERVER: 46.105.198.200#53(46.105.198.200)
;; WHEN: Wed Mar 19 11:00:48 2014
;; MSG SIZE  rcvd: 45
Par contre depuis KS1 (oùj'ai supprimé la conf du domaine) il trouve tout seul comme un grand :

Code:
root@KS1dig 42pixels.fr

; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> 42pixels.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52994
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;42pixels.fr.                   IN      A

;; ANSWER SECTION:
42pixels.fr.            3235    IN      A       91.121.173.83

;; AUTHORITY SECTION:
42pixels.fr.            172435  IN      NS      dns200.anycast.me.
42pixels.fr.            172435  IN      NS      ns200.anycast.me.

;; ADDITIONAL SECTION:
ns200.anycast.me.       86035   IN      A       46.105.223.200
dns200.anycast.me.      86035   IN      A       46.105.198.200

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Mar 19 11:14:39 2014
;; MSG SIZE  rcvd: 128
Je tourne en rond sur google et divers forums depuis hier, je ne vois pas où est le soucis... Je suis tombé sur plusieurs problèmes similaires, mais c'était toujours la configuration de la zone DNS qui était en cause. Or là, la configuration est faite automatiquement par le manager OVH et je ne l'ai pas modifié, donc je doute qu'elle soit foireuse.