OVH Community, your new community space.

Problème .htacces


wicca18
21/03/2014, 18h29
Sur mon ks j'étais sur une distribution Linux realease 2 et la meme distribution mais sur release 3

BBR
21/03/2014, 17h28
je suppose que sur ton autre ks ce n'était pas la même distribution/configuration, c'est par là qu'il faut chercher.

wicca18
21/03/2014, 16h39
Oui celui-ci était bien créé de cette facon avec éditeur de texte. Celui marchait normalement il y a encore quelques jours sur mon autre KS. Aujourd'hui j'ai transféré sur un PS et ca ne marche pas.

BBR
21/03/2014, 15h10
à tout hasard : tu l'as bien créé avec un éditeur de texte ce fichier (style Notepad++) ?
la syntaxe à première vue parait correcte, regarde la configuration d'Apache

wicca18
21/03/2014, 14h36
Non c'est.juste moi qui est taper trop vite.
Mon fichier est écrit sur mon serveur : .htaccess

BBR
21/03/2014, 14h09
vu le nombre de fois où tu as écrit ht.acces je pense que tu as appelé ton fichier de cette façon, donc normal que tu aies des erreurs le bon nom c'est
.htaccess

wicca18
21/03/2014, 14h04
Bonjour à tous,
Je rencontre un souci avec mon ht.acces depuis la migration de mon site d’un KS sur un PS
Mon PS est sur release 3 CentOS Linux 6.5
Auparavant sur mon KS cela fonctionnait très bien mais plus maintenant…


Dans mon ht.acces j’ai cela :

RewriteEngine on
RewriteCond %{HTTP_HOST} ^XXX\-XXX\.com$
RewriteRule ^(.*)$ http://www.XXX-XXX.com/$1 [R=301,L]

RewriteCond %{REQUEST_URI} /XXX-XXX.com/$
RewriteRule ^(.*)$ http://www.XXX-XXX.com/$1 [R=301,L]

RewriteCond %{REMOTE_ADDR} !XX.XX.XXX.XXX
RewriteRule .* maj\.php


deny from all


--------------------------------------------------------------------------
Sur les guides ovh j’ai trouvé un aide:
Les erreurs 500 sont dues à la mauvaise configuration de votre site. Les origines peuvent être multiples.
.htaccess
Si la syntaxe de .htaccess n'est pas correcte, le serveur web affichera erreur 500. Il faut renommer .htaccess en .htaccess_bak par exemple. Si votre site refonctionne alors c'est bien .htaccess qui est en cause.
Je l'ai renommé et bingo ca remarche.....

Mais après trouver la solution la j’ai plus de mal...
A votre avis, d’où cela me venir ?
Merci de votre aide.