OVH Community, your new community space.

[ks355211] - Serveur SVN


StephaneC
24/03/2014, 14h30
Bonjour, quand vous installez subversion, c'est normal qu'il ne démarre pas automatiquement le serveur SVN.

Pour avoir un SVN qui fonctionne, il faut déjà créer des dépots avec la commande svnadmin --create /path/svn/depot
ensuite, il faut démarrer le démon, avec votre commande.
Si vous voulez que votre démon ce lance automatiquement au démarrage du serveur, vous pouvez copier cette commande dans le fichier /etc/rc.local (avant le exit).

Cordialement,
Stéphane

fox-ovh
24/03/2014, 10h26
Bonjour,

Sur mon serveur dédié Kimsufi [ks355211] sous Release 3, j'ai installé SVN avec cette commande :

Code:
yum install subversion
Pas de soucis tout s'installe bien mais le serveur SVN n'est pas accessible et je dois lancer cette commande pour dire au serveur d'écouter sinon j'ai ce genre de message : Can't connect to host 'XX.XX.XX.XX': Connection refused

Code:
svnserve -d --listen-port 3690 --listen-host XX.XX.XX.XX -r /home/svn
Pouvez-vous me dire comme faire en sorte de configurer SVN pour le serveur pour que cela fonctionne au démarrage ?

Pour la configuration, voici ce que j'ai fait :
- dans le fichier etc/xinetd.d/svnserve (que j'ai créé)

Code:
# default: on
# Subversion server
service svn
{
socket_type = stream
protocol = tcp
user = svn
wait = no
disable = no
server = /usr/bin/svnserve
server_args = -i -r /home/svn
port = 3690
}
- dans /etc/services

Code:
...
svn             3690/tcp                        # Subversion
svn             3690/udp                        # Subversion
...

Merci d'avance

Cordialement