OVH Community, your new community space.

Ajouter de domaine erreur creation base de donnée


janus57
14/01/2015, 15h14
Bonjour,

vous avez visualisé les BDD en root via phpMyAdmin ?

Sinon pourquoi choisir la R3 ?

Sachant que la R3 est peut être "prête à l'emploi", mais a aussi des bug et des limites, un petit Debian + Virtualmin serait tout aussi efficace d'après @BBR et d'autre personnes qui ont fait ce choix.

Cordialement, janus57

ilanb
14/01/2015, 15h11
Salut BBR,

Oui c'est ce que Janus57 a fait remarqué aussi, mais je doute, il n'y avait plus la base dans Mysql (verifier depuis le panel et sur PhpMyAdmin) après la suppression du domaine, le domaine a pu être recrée que quand j'ai changé le nom (login) qui sert ensuite de nom a la DB...
Je suis sur Release3 a jour, idem webmin.

Merci,

BBR
14/01/2015, 08h28
Il s'agit d'un bug sur la R3, quand on supprime un domaine cela ne supprime pas la BDD, il suffit donc d'aller dans phpmyadmin et la supprimer manuellement

ilanb
14/01/2015, 08h20
Merci Janus57,

Dsl pour le triple post, c'était plus pour expliquer le problème.
Bon finalement j'ai refait une install et reparamétrer tout ça, pour mysql je pense que le nom de ma DB était trop long en fait, cela fonctionne bien maintenant.
Pour la DB sur R3 elle avait bien était supprimé a titre indicatif.

Merci,

janus57
14/01/2015, 03h59
Bonjour,

déjà un petit conseil, on évite de faire du triple post.

Ensuite pour le problème avec la R3 il me semble que cela est dû au fait que la BDD ne se fait pas supprimer avec la suppression du domaine, donc faut aller supprimer la BDD à la main.

Après pour bind vous avez touché au mauvais fichier, vous devez laisser named.conf tranquille, sinon là vous allez tout "casser".

Donc maintenant faut allez voir dans le fichier "named.pharmacade.com.conf" pour voir ce qui manque.

Cordialement, janus57

ilanb
14/01/2015, 03h27
Si je commente dans le fichier named.conf la ligne include, je n'ai plus erreur et le service démarré bien :

Code:
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
	listen-on port 53 { any; };
	listen-on-v6 port 53 { any; };
	directory 	"/var/named/";
	dump-file 	"/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
	//allow-query { localhost; };
	notify yes;
	allow-transfer { 
	213.186.33.199; 
	};
	recursion yes;
	allow-recursion { 
	127.0.0.1; 
	};

	dnssec-enable yes;
	dnssec-validation yes;
	dnssec-lookaside auto;

	/* Path to ISC DLV key */
	bindkeys-file "/etc/named.iscdlv.key";
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
	type hint;
	file "named.ca";
};

include "/etc/named.rfc1912.zones";

//include "/etc/named/named.pharmacade.com.conf";

ilanb
14/01/2015, 02h47
J'ai essayé avec un autre nom de domaine, cela fonctionne mais j'ai cette erreur au redémarrage du service named :

/etc/rc.d/init.d/named restart
Arrêt de named*: [ OK ]
Démarrage de named*:
Error in named configuration:
/etc/named/named.pharmacade.com.conf:4: missing ';' before '/'
/etc/named/named.pharmacade.com.conf:4: '}' expected near '/'
[ÉCHOUÉ]

je ne vois pas de quoi cela peu venir...

Merci

ilanb
14/01/2015, 00h14
Bonjour,

j'ai crée depuis le manager release3 un domaine pour tester (j'ai reçu le mail...), que j'ai ensuite supprimé.

maintenant quand j'essai de recréer le domaine, j'ai un message d'erreur :

"Une erreur est survenue Une erreur est survenue lors de la creation de la base de donnees "

et le domaine ne se crée pas.

J'ai redémarré les service, webmin, le serveur ... rien a faire

Merci,