OVH Community, your new community space.

DNS...Je suis perdu.


akego
04/02/2015, 08h25
Bonjour,

Suite à une erreur de manipulation, j'ai malencontreusement supprimer le premier message.

Donc comme je disais, je n'arrive pas a mettre en place mon domaine (pris chez ovh) dans le manager Kimsufi, lorsque j'essaie d'entrer la configuration celui-ci m'affiche le message d'erreur suivant :


J'ai vérifier le, OWNERCHECK ce trouve bien dans la zone DNS chez OVH.
J'ai modifier la ligne ns IN A ip_serveur, du moins je pense (j'ai fait la modif dans le code ci c'est bien cela).
Mais cela ne change rien.

named.conf:
Code:
options {
                                   listen—on port 53 { l27.0.0.l; };
                                   listen—on—v6 port 53 { ::1; };
                                  directory "/var/named";
                                  dump—file "/var/named/data/cache_dump.db";
                                  statistics—file "/var/named/data/named_stats.txt";
                                  memstatistics—file "/var/named/data/named_mem_stats.txt";
                                  allow—query { localhost; };

                                  recursion yes;

                                 dnssec—enable yes;
                                 dnssec—validation yes;
                                 dnssec—lookaside auto;

               /* Path to ISC DLV key */
   bindkeys—file "/etc/named.iscdlv.key";

  managed—keys—directory "/var/named/dynamic";

  pid—file "/run/named/named.pid";
  session—keyfile "/run/named/session.key";

};
logging {
                   channel default_debug {
                               file "data/named.run";
                               severity dynamic;
               };
};

zone "xxxxxxxxx.ovh" {
                 type master;
                 file "/etc/db.xxxxxxxxx.ovh";
                 allow—transfer {2l3.l86.33.l99;};
};

zone "xx.xx.xx.xx.in—addr.arpa"{
                 type master;
                 file "/etc/xx.xx.xx.xx.in—addr.arpa";
                 allow—transfer {2l3.l36.33.l99;};
                 notify no;
};

zone "." IN {
                type hint;
                file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";
db.xxxxxxxxx.ovh :
Code:
$TTL    12H
$ORIGIN xxxxxxxx.ovh

xxxxxxxx.ovh.   IN      SOA     xxxxxxxxx.ip-xx-xx-xx.eu. xxxxxxx@gmail.com. (
		  2015020301	; Serial
		  8H		; Refresh
		  30M		; Retry
		  4W		; Expire
		  8H		; Minimum TTL
)


		IN	NS	xxxxxxxxx.ip-xx-xx-xx.eu
		IN	NS	ns.kimsufi.com.
xxxxxxxxxl.ovh.	IN	A	xx.xx.xx.xx
		IN	A	xx.xx.xx.xx
WWW		IN	CNAME	xxxxxxxxxx.ovh.
blog		IN	A	xx.xx.xx.xx
wiki		IN	A	xx.xx.xx.xx
ownercheck	IN	TXT	"xxxxxxxxx"

akego
03/02/2015, 23h41
Désoler, en voulant modifier le message j'ai malencontreusement supprimer celui-ci.

Donc comme je disais je n'arrive pas a mettre un place le Domaine, lors de l'ajout du serveur DNS sur le manager Kimsufi celui-ci m'indique une erreur :

Voici mon named.conf et mon db.domaine.ovh:
named.conf :
Code:
options {
                                   listen—on port 53 { l27.0.0.l; };
                                   listen—on—v6 port 53 { ::1; };
                                  directory "/var/named";
                                  dump—file "/var/named/data/cache_dump.db";
                                  statistics—file "/var/named/data/named_stats.txt";
                                  memstatistics—file "/var/named/data/named_mem_stats.txt";
                                  allow—query { localhost; };

                                  recursion yes;

                                 dnssec—enable yes;
                                 dnssec—validation yes;
                                 dnssec—lookaside auto;

               /* Path to ISC DLV key */
   bindkeys—file "/etc/named.iscdlv.key";

  managed—keys—directory "/var/named/dynamic";

  pid—file "/run/named/named.pid";
  session—keyfile "/run/named/session.key";

};
logging {
                   channel default_debug {
                               file "data/named.run";
                               severity dynamic;
               };
};

zone "xxxxxxxxx.ovh" {
                 type master;
                 file "/etc/db.xxxxxxxxx.ovh";
                 allow—transfer {2l3.l86.33.l99;};
};

zone "xx.xx.xx.xx.in—addr.arpa"{
                 type master;
                 file "/etc/xx.xx.xx.xx.in—addr.arpa";
                 allow—transfer {2l3.l36.33.l99;};
                 notify no;
};

zone "." IN {
                type hint;
                file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";
db.domain.ovh :
Code:
$TTL    12H
$ORIGIN xxxxxxxx.ovh

xxxxxxxx.ovh.   IN      SOA     xxxxxxxxx.ip-xx-xx-xx.eu. xxxxxxx@gmail.com. (
		  2015020301	; Serial
		  8H		; Refresh
		  30M		; Retry
		  4W		; Expire
		  8H		; Minimum TTL
)


		IN	NS	xxxxxxxxx.ip-xx-xx-xx.eu
		IN	NS	ns.kimsufi.com.
xxxxxxxxxl.ovh.	IN	A	xx.xx.xx.xx
		IN	A	xx.xx.xx.xx
WWW		IN	CNAME	xxxxxxxxxx.ovh.
blog		IN	A	xx.xx.xx.xx
wiki		IN	A	xx.xx.xx.xx
ownercheck	IN	TXT	"xxxxxxxxx"
Merci pour votre réponse,
J'ai retirer le NS IN A IP_SRV, du moin je crois (j'ai fait la modif dans le code aussi),
et j'ai vérifier le OWNERCHECKER est bien dans la zone DNS chez ovh mais cela ne change rien

BBR
03/02/2015, 22h39
tu peux mettre entre balises CODE c'est bien mieux que devoir aller sur un site extérieur ce qui n'est franchement pas pratique
mets aussi ta ligne ownercheck dans la zone dns du manager ovh du domaine
et ton ns c'est quoi cette ligne ? ?
mets juste IN A ip_serveur au lieu de ns IN A ip_serveur

akego
03/02/2015, 22h31
Bonjour/Bonsoir,

J'ai récemment fait l'acquisition d'un serveur, ainsi qu'un nom de domaine via ovh.

Après avoir modifié les DNS avec le manager OVH (merci au nombreux tuto que j'ai trouver), je me suis attaquer à BIND.

J'ai configuré mon named.conf ainsi que mes zone, et j'ai rajouté la ligne "ownercheck IN TXT xxxxxxx" .

Malgré tout lors de l'ajout du DNS secondaire sur le manager Kimsufi, j'ai continuellement le message d'érreur :



Il est fort probable que le problème vienne de mon côté, mais malgré mes maintes tentatives... j'échoue encore et toujours.

L'un de vous aurait-il l'amabilité de regarder mes fichier de conf afin de m'indiquer mes erreurs ?

named.conf.local :
Code:
options {
                                   listen—on port 53 { l27.0.0.l; };
                                   listen—on—v6 port 53 { ::1; };
                                  directory "/var/named";
                                  dump—file "/var/named/data/cache_dump.db";
                                  statistics—file "/var/named/data/named_stats.txt";
                                  memstatistics—file "/var/named/data/named_mem_stats.txt";
                                  allow—query { localhost; };

                                  recursion yes;

                                 dnssec—enable yes;
                                 dnssec—validation yes;
                                 dnssec—lookaside auto;

               /* Path to ISC DLV key */
   bindkeys—file "/etc/named.iscdlv.key";

  managed—keys—directory "/var/named/dynamic";

  pid—file "/run/named/named.pid";
  session—keyfile "/run/named/session.key";

};
logging {
                   channel default_debug {
                               file "data/named.run";
                               severity dynamic;
               };
};

zone "xxxxxxxxx.ovh" {
                 type master;
                 file "/etc/db.xxxxxxxxx.ovh";
                 allow—transfer {2l3.l86.33.l99;};
};

zone "xx.xx.xx.xx.in—addr.arpa"{
                 type master;
                 file "/etc/xx.xx.xx.xx.in—addr.arpa";
                 allow—transfer {2l3.l36.33.l99;};
                 notify no;
};

zone "." IN {
                type hint;
                file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";
db.xxxxxxxxx.ovh :
Code:
$TTL    12H
$ORIGIN xxxxxxxx.ovh

xxxxxxxx.ovh.   IN      SOA     xxxxxxxxx.ip-xx-xx-xx.eu. xxxxxxx@gmail.com. (
		  2015020301	; Serial
		  8H		; Refresh
		  30M		; Retry
		  4W		; Expire
		  8H		; Minimum TTL
)


		IN	NS	xxxxxxxxx.ip-xx-xx-xx.eu
		IN	NS	ns.kimsufi.com.
xxxxxxxxxl.ovh.	IN	A	xx.xx.xx.xx
ns		IN	A	xx.xx.xx.xx
WWW		IN	CNAME	xxxxxxxxxx.ovh.
blog		IN	A	xx.xx.xx.xx
wiki		IN	A	xx.xx.xx.xx
ownercheck	IN	TXT	"xxxxxxxxx"