OVH Community, your new community space.

Connexion serveur impossible


BBR
11/03/2015, 19h28
Tu n'aurais pas bloqué ton ip par hasard ou empêché la connexion par user/pass ?
Désactive le firewall, idem fail2ban si installé et vois si cela résout le problème
montre le contenu du fichier /etc/ssh/sshd_config
en particulier :
PermitRootLogin
PermitEmptyPasswords
PasswordAuthentication

Indianabins
11/03/2015, 15h18
Bonjour,

J'ai regardé les tests matériels en mode rescue et apparement aucune erreur.
Je me suis booter en mode rescue et j'ai monté les partitions sda2 et 3 ( / et /home)
J'ai essayé de réinstallé ssh + apache mais rien n'y fait j'ai toujours
ssh: connect to host ns328178.ip-37-187-113.eu port 22: Connection refused
Je commence vraiment à me poser des questions, ai-je fait une erreur ?

Comment est-ce possible de ne plus pouvoir se connecter en ssh et que rien ne marche en http (/var/www) ?

Merci d'avance,

nowwhat
03/03/2015, 19h15
Citation Envoyé par Indianabins
J'ai mis le serveur en mode rescue ssh/cron reboot et surprise, ça fonctionne.
Normal.
C'est bien ton serveur qui démarre - mais pas du tout TON (lui de ton serveur) disque dur qui n'est pas 'démarré" (mounté) du tout - le serveur démarre à partir d'un partition monté à partir d'un serveur de KS/OVH (pré paramétré avec l’utilisateur 'root' et un mot de passe 'temporaire' que t'as reçu par mail.
Ce qui prouve que le processus de démarrage, présent sur ton disque dur, est "cassé", par exemple par ce qu'il y a un erreur de configuration, ou un disque dur qui commence à rendre l'âme.
C'est classique.
C'est pour ça que t'as des sauvegardes

Citation Envoyé par janus57
que donne les logs du serveur en rescue ?
Les test matériel ?
Les logs - TES logs, pas lui de l'OS "rescue" -> va mounter tes partitions d'abord :
http://guide.ovh.com/ModeRescue
https://www.ovh.com/fr/g920.rescue_mode
http://forum.kimsufi.com/showthread....TO-Mode-rescue

édit: pendant l'écriture de mon message }# je suis donc tombé sur le SSH du mode rescue de ton serveur, c'est ça ?
Ok, ça va de suite déjà mieux ^^

SD90078-OVH
03/03/2015, 18h28
Bonjour,

un fsck qui bloque au boot car secteurs défectueux ?

je pense qu'il est nécessaire de regarder les logs en bootant en rescue et faire les tests matériels.

janus57
03/03/2015, 17h35
Bonjour,

que donne les logs du serveur en rescue ?
Les test matériel ?

De mon côté un ,map ne dit qu'il ya zéro services ouvert sur le serveur (firewall mal réglé ?)

Cordialement, janus57

Indianabins
03/03/2015, 17h05
Bonjour nowwhat,

Effectivement le serveur était accessible il y a quelque minute, mais après un reboot même problème.
Normalement je me connecte avec ssh user@bins-dev.com, mais cela ne fonctionne plus.
J'ai mis le serveur en mode rescue ssh/cron reboot et surprise, ça fonctionne.
Cependant après un reboot même problème, si tu tentes de te connecter tu auras le message d'erreur.

Je fais principalement du dev web je suis un peu largué sur la conf. serveur.

Cdt,

Alexis

Indianabins
03/03/2015, 17h00
Bonjour,

J'ai effectué la manipulation "rescue" et j'ai donc pu me rendre sur le serveur pour redémarrer ssh et cron mais à chaque reboot du serveur même erreur :
" ssh: connect to host nsXXXXXX.ip-XX-XXX-XXX.eu port 22: Connection refused "

De plus je n'ai toujours pas accès à mon http

L'adresse de mon serveur est ns328178.ip-37-187-113.eu

Pensez-vous qu'il y a un problème avec le ssh ? J'ai l'impression qu'il y a eu de gros problèmes mais impossible de comprendre ce qu'il s'est passé.

Merci d'avance,

Alexis

nowwhat
03/03/2015, 16h56
Stop stop stop.
Juste une question.:
Ceci est vrai :
Citation Envoyé par Indianabins
......
Réponse du telnet :
Bin's ~/Desktop 15:38:21 $> telnet bins-dev.com 22
Trying XX.XXX.XXX.XX...
telnet: connect to address XX.XXX.XXX.XX: Connection refused
telnet: Unable to connect to remote host
Bin's ~/Desktop 15:39:08 $>
???

T'as vraiment lancé un serveur telnet sur ton serveur qui écoute la porte 22 (lui de SSH) ?

J'ai cru que le dernier serveur telnet a été démarré avant 2000 - que ce protocole n'existe plus (sauf dans une machine à café, sèche ligne et autre bac à plantes)

Normalement, moi je fais ceci:

ssh root@bins-dev.com

Comme ceci:
[2.2-RELEASE][admin@pfsense.mon-boulot-que-jadore-.net]/root: ssh root@bins-dev.com
The authenticity of host 'bins-dev.com (37.187.113.14)' can't be established.
ECDSA key fingerprint is 46:7e:46:02:98:ed:14:7e:cb:c6:2f:36:4c:a8:6e:4f.
No matching host key fingerprint found in DNS.
Are you sure you want to continue connecting (yes/no)? y
Please type 'yes' or 'no': yes
Warning: Permanently added 'bins-dev.com' (ECDSA) to the list of known hosts.
root@bins-dev.com's password:
Puis ça bloque sur le mot de passe.
Tu me la fille stp

Pour moi, sur ton serveur, l'accès SSH est fonctionnelle.
Lui de telnet sur la porte 23 (vingt trois) : non

PS : Sur un PC + Windows, je me fais encore moins chier que ça,j'utilise ..... Putty.

PS2 : t'as dit travailler énormément avec ton serveur .....
Travailler comment ?
Moi aussi, j'ai bosse dessus - par accès SSH justement .... pour mes sauvegarder, maintenance, conception, programmation, trafic web, stats et j'en passe. L'accès "chef" (boss, patron, maître, ..) ça se passe par le SSH. Je me suis trompé ?

janus57
03/03/2015, 16h07
Bonjour,

sans IP ou nom de KS impossible pour nous de vérifier, donc vous devez passer le serveur en rescue et faire les tests vous même.

Cordialement, janus57

Indianabins
03/03/2015, 15h33
Bonjour à tous,

Depuis 2 jours, il m'est impossible de me connecter à mon serveur.
Je n'ai pas effectué d'installation/changement dernièrement sur celui-ci. Il me sert principalement à héberger des sites.
Dans l'interface de Kimsufi tout est ok, apparemment le serveur est actif et en marche cependant impossible de me connecter en ssh :
" ssh: connect to host nsXXXXXX.ip-XX-XXX-XXX.eu port 22: Connection refused "
Et aucune réponse en http non plus " Page Web inaccessible "

J'ai énormément de travail sur ce serveur, qu'est ce qui à bien pu se passer ?

Réponse du telnet :
Bin's ~/Desktop 15:38:21 $> telnet bins-dev.com 22
Trying XX.XXX.XXX.XX...
telnet: connect to address XX.XXX.XXX.XX: Connection refused
telnet: Unable to connect to remote host
Bin's ~/Desktop 15:39:08 $>


Merci d'avance pour votre aide,

Cordialement,

PREVOT Alexis