OVH Community, your new community space.

port 25 non fonctionnel


janus57
02/04/2015, 00h19
Bonjour,

ah bah là au en fonction de ce que vous recherchez à faire et de votre temps.

Postfix est le logiciel le plus utilisé en messagerie (je pense...)

Exim4 lui beaucoup moins, néanmoins les 2 peuvent fonctionne si bien config et on chacun leur "domaine" d'action je dirais.

Perso j'utilise exim4 sur un VPS car j'ai pas besoin de messagerie (qui est géré chez un autre hébergeur et 100% par lui, comme ça j'ai ça en moins à gérer et à mettre en place des services de secours en cas de crash VPS), et juste car le VPS a besoin d'envoyer des mails (genre inscription, pass oublié, mail() php etc... rien de bien poussé).

Postifx lui au contraire peu servir à bien plus de choses (exim4 aussi mais je pense que pour le coup c'est vraiment pas le top).

Voilà après j'ai jamais utilisé postfix sans panel, car après avoir vu la doc de postifx (http://postfix.traduc.org/) j'ai moyennement envie (pour le moment) de me plonger dans sa config et bien config tout le reste (SPF/DKIM/DMARC) alors qu'un hébergeur le fait à ma place =)

EDIT :
bon maintenant on vois le mail sur mail-tester donc prochaine étape, config un peu mieux postfix

Changer le reverse DNS + le hostname du serveur et surtout demander le dé-blacklistage après avoir changer le reverse.

EDIT 2 :
Serveur compromis, car sur mail-tester il se fait blacklister chaque jour par plusieurs RBL qui disent avoir reçus des mails sur leur adresse robots y a moins de 24H

Cordialement, janus57

Ryan0108
01/04/2015, 23h51
Donc le plus simple est de virer postfix-et de le reinstaller si j'y tiens-ou bien d'installer exim ?

En tout cas merci pour votre temps et votre patience...

janus57
01/04/2015, 23h36
Bonjour,

postfix est très bien si on utilise son serveur comme messagerie (réception + envoie de mails).

Mais si on a simplement besoin d’envoyer des mails (inscriptions ou autre) sans avoir de retour exim4 est tout aussi bien et bien plus léger.

Bref si vous voulez garder postfix il va falloir très bien le config car là y a un peu trop de warning je pense et du coup je pense que la config postfix n'est pas correcte.
Vous pouvez toujours ré-essayer la commande qui permet d'envoyer un mail en SSH, mais je pense pas que cela va fonctionner :/

Cordialement, janus57

Ryan0108
01/04/2015, 23h24
ci joint le resultat:

service postfix restart
[ ok ] Stopping Postfix Mail Transport Agent: postfix.
[....] Starting Postfix Mail Transport Agent: postfixpostconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_overquota_bounce=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_maps=mysql:/etc/postfix/mysql-virtual_quotas.cf
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_maildir_limit_message="La boite mail de votre destinataire est pleine, merci de reessayez plus tard."
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_create_maildirsize=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_extended=yes
/usr/sbin/postconf: warning: /etc/postfix/main.cf: unused parameter: virtual_mailbox_limit_override=yes
. ok


je dois avouer que j'ai installé postfix sans imaginer qu'il existait des alternatives plus simples...!

janus57
01/04/2015, 23h11
Bonjour,

pour solr ou apachetomcat je m'en fou de son install, mais je parlé de postfix.

Que donne un
Code:
service postfix restart
?

Car ici c'est postfix le problème et pas solr ou je ne sais quoi (enfin je pense).

Perso depuis mon VPS bêta OVH j'ai juste installé exim4 et j'arrive déjà a envoyer des mails (très "sale" car pas config, mais ça s'envoie tranquille, cf : http://www.mail-tester.com/web-ObM1sF).

Cordialement, janus57

Ryan0108
01/04/2015, 23h00
Merci pour tous ces conseils...j'apprends toujours un peu plus !

Solr a été installé en suivant ce guide: http://info.figarola.fr/2013/06/27/d...ation-drupal7/

voici le log de cat /var/log/mail.log
Apr 1 20:40:22 _ postfix/master[12142]: fatal: bind 0.0.0.0 port 10025: Address already in use
Apr 1 21:32:19 _ postfix/master[14796]: fatal: bind 0.0.0.0 port 10025: Address already in use
Apr 1 22:08:21 _pop3d: Connection, ip=[::ffff:_]
Apr 1 22:08:21 _imapd: Connection, ip=[::ffff:_]
Apr 1 22:08:21 _pop3d: Disconnected, ip=[::ffff:_]
Apr 1 22:08:21 _imapd: Disconnected, ip=[::ffff:_], time=0
Apr 1 22:08:39 _imapd: Connection, ip=[::ffff:_]
Apr 1 22:08:39 _pop3d: Connection, ip=[::ffff:_]
Apr 1 22:08:40 _imapd: Disconnected, ip=[::ffff:_], time=1
Apr 1 22:08:40 _pop3d: Disconnected, ip=[::ffff:_]

y a t'il un autre log ?

janus57
01/04/2015, 22h45
Bonjour,

ces tuto sont relativement vieux et non sont pas à prendre aux pieds de la lettre.

Pour le FTP j'ai rien dit c'est ProFTPD qui génère aussi le "oftpd", par contre si on a un accès au serveur FTP est très souvent superflus, SFTP existe.

Pour le port SSH autre que 22, j'ai suivi les recommadnations du site sus cité, arguant que le port 22 est le premier à être scanné...
Et ? il suffit de mettre un chien de garde (fail2ban) et le problème est réglé,sinon suffit de regarder mon lien en anglais qui explique de mettre SSH ailleurs que sur le port 22 est tout aussi dangereux que de le laisser sur le port 22 (voir plus dangereux de le mettre ailleurs).

Ensuite j'ai installé apache Solr, mais j'avoue que pour postfix, je n'ai pas cherché à trop bidouiller...
Vous l'avez installé comment ? en suivant quel guide ?

la commande plus haut ne répond rien, et je ne recois pas l'email sur le site (j'ai essayé avec gmail, il l'a recu tout de suite).
il faut regarder les logs d’envois de postfix alors.

Sinon pourquoi avoir utilisé postfix (car si c'est juste de l'envois sans réception postifx est un peu "too much") ?

Cordialement, janus57

Ryan0108
01/04/2015, 22h45
En tout cas merci pour le lien et l'article, c'est fort intéressant...!

Ryan0108
01/04/2015, 22h39
Etant débutant sur linux et pour la gestion d'un serveur, j'ai suivi pas à pas les tuto sur ce site : http://www.tutoriels-video.fr/ et un peu ici http://www.alsacreations.com/tuto/li...exion-SSH.html
Je tatonne et bidouille pas mal, mais je ne me souviens pas avoir installé 2 logiciels ftp...
Pour le port SSH autre que 22, j'ai suivi les recommadnations du site sus cité, arguant que le port 22 est le premier à être scanné...
Ensuite j'ai installé apache Solr, mais j'avoue que pour postfix, je n'ai pas cherché à trop bidouiller...

la commande plus haut ne répond rien, et je ne recois pas l'email sur le site (j'ai essayé avec gmail, il l'a recu tout de suite).

janus57
01/04/2015, 22h30
Bonjour,

vous pouvez retirer ce log (c'est mon IP lors du scan NMAP).

Je sais pas vous avez quoi sur votre serveur mais la config me semble assez anarchique.

Code:
PORT     STATE    SERVICE

21/tcp   open     ftp
25/tcp   filtered smtp
53/tcp   open     domain
80/tcp   open     http
110/tcp  open     pop3
445/tcp  filtered microsoft-ds
8080/tcp open     http-proxy
Et plus en détails :
Code:
PORT      STATE    SERVICE      VERSION

21/tcp    open     ftp          ProFTPD 1.3.4a

25/tcp    filtered smtp

53/tcp    open     domain
| dns-nsid: 
|_  bind.version: 9.8.4-rpz2+rl005.12-P1

80/tcp    open     http         Apache httpd
|_http-methods: GET HEAD POST OPTIONS
|_http-title: Site doesn't have a title (text/html).

110/tcp   open     pop3         Courier pop3d
|_pop3-capabilities: USER PIPELINING LOGIN-DELAY(10) TOP UIDL IMPLEMENTATION(Courier Mail Server)

445/tcp   filtered microsoft-ds
1984/tcp  open     ssh          OpenSSH 6.0p1 Debian 4+deb7u2 (protocol 2.0)
| ssh-hostkey: 
|   1024 23:e5:70:34:a4:84:64:52:6a:5f:f6:eb:6b:9f:33:86 (DSA)
|   2048 1d:a6:09:0d:65:ab:8a:3c:86:3b:5c:ad:ad:97:36:d3 (RSA)
|_  256 5e:7c:c7:bc:dc:b5:f4:f3:ad:ba:5c:bd:c4:1e:0b:5a (ECDSA)

8080/tcp  open     http         Apache Tomcat/Coyote JSP engine 1.1
| http-methods: GET HEAD POST PUT DELETE OPTIONS
| Potentially risky methods: PUT DELETE
|_See http://nmap.org/nsedoc/scripts/http-methods.html
|_http-open-proxy: Proxy might be redirecting requests
|_http-title: Apache Tomcat

10025/tcp open     imap         Courier Imapd (released 2011)
|_imap-capabilities: THREAD=REFERENCES THREAD=ORDEREDSUBJECT completed SORT ACL OK ACL2=UNIONA0001 QUOTA IDLE CAPABILITY NAMESPACE UIDPLUS CHILDREN IMAP4rev1

65000/tcp open     ftp          oftpd
Donc déjà du SSH ailleurs que le port 22 = mauvaise idée (Cf : https://www.adayinthelifeof.nl/2012/...2-is-bad-idea/)

Et sinon que donne la commande donné plus haut, la commande mail ? (2ième fois que je demande)

Cordialement, janus57

Ryan0108
01/04/2015, 22h15
zut alors, je comprend pas trop pourquoi...

ci joint le log de cat /var/log/mail.log

Apr 1 22:08:21 _ pop3d: Connection, ip=[::ffff:_]
Apr 1 22:08:21 _ imapd: Connection, ip=[::ffff:_]
Apr 1 22:08:21 _ pop3d: Disconnected, ip=[::ffff:_]
Apr 1 22:08:21 _ imapd: Disconnected, ip=[::ffff:_], time=0
Apr 1 22:08:39 _ imapd: Connection, ip=[::ffff:_]
Apr 1 22:08:39 _ pop3d: Connection, ip=[::ffff:_]
Apr 1 22:08:40 _ imapd: Disconnected, ip=[::ffff:_], time=1
Apr 1 22:08:40 _ pop3d: Disconnected, ip=[::ffff:_]

janus57
01/04/2015, 22h06
Bonjour,

donc votre port 25 est bien débloqué, le support KS va vous envoyé sur le forum car là c'est bien votre logiciel qui est HS (postfix ou autre).

Et si vous souhaitez envoyé un mail avec :
Code:
echo "Mon super message" | mail -s "essai de mon serveur mail" web-ObM1sF@mail-tester.com
c'est quoi l'erreur ?

Cordialement, janus57

Ryan0108
01/04/2015, 22h03
ah oui, pardon:

telnet -4 smtpz4.laposte.net 25
Trying 194.117.213.1...
Connected to smtpz4.laposte.net.
Escape character is '^]'.
220 lpn-prd-vrin013 ESMTP Postfix (Ubuntu)
quit
221 2.0.0 Bye
Connection closed by foreign host.

telnet -4 gmail-smtp-in.l.google.com 25
Trying 64.233.184.27...
Connected to gmail-smtp-in.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP z5si5134522wjz.64 - gsmtp
quit
221 2.0.0 closing connection z5si5134522wjz.64 - gsmtp
Connection closed by foreign host.

janus57
01/04/2015, 21h50
Bonjour,

non le telnet faut le faire depuis le verseur vers les serveur de google par exemple.

sa sert à rien de le faire su son propre serveur depuis votre connexion.

EDIT :
Votre port 25 me rejette, sachant que OVH/KS bloque uniquement le port 25 en sortie de leur réseau et que moi j'ai fait le teste en entrant et depuis le réseau OVH, je dirais que le problème se situe à votre niveau.

Sauf si OVH a changé sa politique et bloque le port 25 dans les 2sens + à l'intérieur de leur réseau.

Cordialement, janus57

Ryan0108
01/04/2015, 21h07
Bonsoir, merci pour votre aide.

voici le telnet:
telnet IP
Trying IP...
telnet: Unable to connect to remote host: Connection timed out
dans quel fichier... /var/log/? ? peux on trouver les logs ?

update:
ci joint les dernières lignes du log var/log/mail.log
Apr 1 20:40:22 postfix/master[12142]: fatal: bind 0.0.0.0 port 10025: Address already in use
Apr 1 21:32:19 ns333613 postfix/master[14796]: fatal: bind 0.0.0.0 port 10025: Address already in use

janus57
01/04/2015, 20h57
Bonjour,

et des logs ?
Sinon que donne les résultats de la commande telnet comme demandé ?

Cordialement, janus57

Ryan0108
01/04/2015, 20h52
Bonsoir,
Impossible d'envoyer un email sur mail-tester...Pas de soucis avant, les emails partaient bien. Depuis que j'ai été bloqué, ça marche plus. J'ai envoyé un email au support, j'attends la réponse...

janus57
31/03/2015, 13h03
Bonjour,

telnet c'est pas pour envoyer un mail.

Par contre tu peu envoyer un mail avec une commande depuis ton SSH normalement.

Exemple :
Code:
echo "Mon super message" | mail -s "essai de mon serveur mail" web-ObM1sF@mail-tester.com
Cordialement, janus57

Ryan0108
31/03/2015, 12h18
Ok, merci pour tous les conseils.
Arf, pas si simple d'avoir assez temps pour tout faire, mais c'est passionnant, et j'adore ça !

Merci pour vos réponses et le temps passé, je pensai que certaines personnes qui répondaient faisaient partie du staff KS...

du coup c'est votre serveur/ip qui doit être bloqué en face, soit parce que assez de spam sont passé pour vous passer en blackliste, soit car votre config est pourrie.

Envoyé un mail ici : web-ObM1sF@mail-tester.com
Puis regardez ici : http://www.mail-tester.com/web-ObM1sF
Comment fais t'on pour envoyer un email ? j'ai regardé pour le faire via telnet, mais quel serveur d'envoi faut il utiliser du coups ? ou existe t'il une autre méthode ?

Merci pour votre aide

nowwhat
30/03/2015, 14h25
Citation Envoyé par Ryan0108
Savez vous si il y a encore des emails de bloqués ? le port n'est pas bloqué par KS.
Nous ne pouvons le savoir.
Sachant que c'est toi qui le demande, il me reste te proposer deux solutions:
1) Va embaucher un 'admin'
2) Soit, il est temps de devenir une ...

BBR
30/03/2015, 13h18
Savez vous si il y a encore des emails de bloqués ?
Il n'y a que toi qui peut le savoir, ici ce sont des clients comme toi qui te répondent, pas le support, donc on n'en sait rien ^^

janus57
30/03/2015, 12h55
Bonjour,

du coup c'est votre serveur/ip qui doit être bloqué en face, soit parce que assez de spam sont passé pour vous passer en blackliste, soit car votre config est pourrie.

Envoyé un mail ici : web-ObM1sF@mail-tester.com
Puis regardez ici : http://www.mail-tester.com/web-ObM1sF

Cordialement, janus57

Ryan0108
30/03/2015, 12h38
Bonjour,

Plusieurs fois que j'essaye de répondre...mais à chaque fois mon message doit être modéré (et j'attends toujours qu'il le soit...)

J'ai fait ce qui a été dit plus haut, et j'obtiens la même chose...

update:
Magnifique, je peux répondre (sisi, c'est vrai, ça marchait pas !)

Bref, en gros j'ai fait exactement ce qui était proposé au post précédent, exactement les mêmes résultats...Du coups, une idée ? Savez vous si il y a encore des emails de bloqués ? le port n'est pas bloqué par KS.

Merci beaucoup

Ryan0108
20/03/2015, 18h54
Bonjour,

J'ai fait exactement ce qui a été proposé :
"root@ns300465:~# telnet -4 smtpz4.laposte.net 25
Trying 194.117.213.1...
Connected to smtpz4.laposte.net.
Escape character is '^]'.
220 lpn-prd-vrin019 ESMTP Postfix (Ubuntu)
quit
Connection closed by foreign host.
root@ns300465:~# telnet -4 gmail-smtp-in.l.google.com 25
Trying 173.194.71.26...
Connected to lb-in-f26.1e100.net.
Escape character is '^]'.
220 mx.google.com ESMTP mz5si13932675lbb.168 - gsmtp
quit
221 2.0.0 closing connection mz5si13932675lbb.168 - gsmtp
Connection closed by foreign host. "

j'ai exactement la même chose...
j'ai voulu répondre, mais mon message passe pas... ?!

Ryan0108
19/03/2015, 19h57
merci beaucoup,

Ci joint les résultats des tests demandés...

root@myid:~$ telnet -4 smtpz4.laposte.net 25
Trying 194.117.213.1...
Connected to smtpz4.laposte.net.
Escape character is '^]'.
220 lpn-prd-vrin018 ESMTP Postfix (Ubuntu)
quit
221 2.0.0 Bye
Connection closed by foreign host.
root@myid:~$ telnet -4 gmail-smtp-in.l.google.com 25
Trying 173.194.66.27...
Connected to we-in-f27.1e100.net.
Escape character is '^]'.
220 mx.google.com ESMTP m8si10494595wik.106 - gsmtp
quit
221 2.0.0 closing connection m8si10494595wik.106 - gsmtp
Connection closed by foreign host.

Ryan0108
19/03/2015, 19h55
Merci beaucoup,
ci joint le resultat des telnet:

root@id:~$ telnet -4 smtpz4.laposte.net 25
Trying 194.117.213.1...
Connected to smtpz4.laposte.net.
Escape character is '^]'.
554 lpn-prd-vrin015 ESMTP not accepting connections
quit
221 2.0.0 Bye
Connection closed by foreign host.
root@id:~$ telnet -4 gmail-smtp-in.l.google.com 25
Trying 173.194.67.27...
Connected to wi-in-f27.1e100.net.
Escape character is '^]'.
220 mx.google.com ESMTP cn12si1215310wjb.46 - gsmtp
quit
221 2.0.0 closing connection cn12si1215310wjb.46 - gsmtp
Connection closed by foreign host.

Ryan0108
19/03/2015, 09h52
Merci beaucoup,
ci joint le resultat des telnet:

root@id:~$ telnet -4 smtpz4.laposte.net 25
Trying 194.117.213.1...
Connected to smtpz4.laposte.net.
Escape character is '^]'.
554 lpn-prd-vrin015 ESMTP not accepting connections
quit
221 2.0.0 Bye
Connection closed by foreign host.
root@id:~$ telnet -4 gmail-smtp-in.l.google.com 25
Trying 173.194.67.27...
Connected to wi-in-f27.1e100.net.
Escape character is '^]'.
220 mx.google.com ESMTP cn12si1215310wjb.46 - gsmtp
quit
221 2.0.0 closing connection cn12si1215310wjb.46 - gsmtp
Connection closed by foreign host.

nowwhat
19/03/2015, 00h23
Concrètement, que donne:

root@ns300465:~# telnet -4 smtpz4.laposte.net 25
Trying 194.117.213.1...
Connected to smtpz4.laposte.net.
Escape character is '^]'.
220 lpn-prd-vrin019 ESMTP Postfix (Ubuntu)
quit
Connection closed by foreign host.
root@ns300465:~# telnet -4 gmail-smtp-in.l.google.com 25
Trying 173.194.71.26...
Connected to lb-in-f26.1e100.net.
Escape character is '^]'.
220 mx.google.com ESMTP mz5si13932675lbb.168 - gsmtp
quit
221 2.0.0 closing connection mz5si13932675lbb.168 - gsmtp
Connection closed by foreign host.
Vert = ce que tu tape.
Noir, une réponse si tout va bien.
Copie-colle la réponse ici.

janus57
18/03/2015, 22h57
Bonjour,

comme dit plus haut, dans un premier temps tester une simple connexion vers l'extérieur.

Si la connexion réussit c'est que côté KS vous êtes débloqué, mais que y a peut être eu trop de spam en face et que c'est le serveur en face qui vous bloque.

Cordialement, janus57

Ryan0108
18/03/2015, 22h45
Ok, merci bcp pour l'aide...
Concrètement, que faire ? Debutant avec KS (c'est l'idée ) je n'ai jamais été confronté à ça !!!

nowwhat
18/03/2015, 08h33
Citation Envoyé par Ryan0108
... j'ai donc debloqué le port 25, mais il ne marche toujours pas sur mon serveur, pouvez vous jeter un coups d'oeil ?
Pour que ça ré-fonctionne, il faut effectivement débloquer dans le manager cette blocage.
Mais il est fort probablement une autre action aura lieu:
Soit le stream de sortie en ensuite mis sur une liste de surveillance étroite - qui va demander une gestion manuelle coté équipe KS, ce qui va demander du temps.
Soit, la première fois, la durée du blocage est une heure, la deuxième fois une journée, la troisième fois une semaine, et la quatrième fois un mois, même si vous débloquez la situation et que vous avez réparez la situation. Ces délais, même cette possibilité n'est qu'au titre indicatif de ma part mais sache que "se faire hacker le serveur pour qu'il devient un spam relay sauvage" n'est guère différent que de "se faire hacker le serveur tout court", et le dernier, au bout de trois fois, vous faites perdre le serveur entier sans autre procès.

édit: ce qui est vu aussi : le déblocage fonctionne, mais le queue de ton serveur mail est encore archi-plein. Normal que le mails passent pas, le queue (avec des milliers des spams (?!) doivent passer d'abord

édit2: KS(OVH) scan les mails, il ne les arrête pas (jusqu’au moment de la blocage). T'as donc des serveurs mails "en face" qui ont pu former un idée de la qualité de ton serveur mail. Tu te confronte maintenant à des représailles : on aime plus ton serveur mail et il se fait balader par un grey-listing, voire pire.

janus57
18/03/2015, 00h25
Bonjour,

que donne un simple telner vers un serveur mail google et/ou orange et/ou free et/ou laposte.net ?

Cordialement, janus57

Ryan0108
17/03/2015, 23h38
Bonjour,

Kimsufi a bloqué le port 25 pour detection de spams...
Le problème est réglé, j'ai donc debloqué le port 25, mais il ne marche toujours pas sur mon serveur, pouvez vous jeter un coups d'oeil ?

Merci