OVH Community, your new community space.

Serveur en "Mitigation" oublié par le support, 90% des services HS ...


WolwX
27/03/2015, 20h40
Citation Envoyé par janus57
Bonjour,


En même temps tu poste sur un forum ou le staff passe quand il en a envie, le vrais support KS c'est sur le manager/mail, les membres n'ayant pas accès aux outils du staff KS (encore heureux) tu souhaite qu'on t'aide comment ???
Penses tu que je suis venu poster sur le forum à cause d'une envie compulsive ?

Je suis venu car j'avais un problème et que les moyens officiels n'avaient pas porté leur fruit (ticket et email étaient tous deux sans réponses) ...

Citation Envoyé par janus57
non, d'après la page OVH dédié à l'anto-DDoS la durée minimal est de 26H après la fin de l'attaque contre le serveur.
La protection reste donc en place le temps de l'attaque + 26H une fois l'attaque finit dans le cas ou l'attaquant souhaite reprendre durant ce lapse de temps de 26H (par contre si il connait ces contraintes des 26H c'est claire qu'il va recommencer 28H plus tard).
J'ai eu effectivement confirmation du support que ce n'était pas normal.

Citation Envoyé par janus57
Après pour remonter les problème de communication avec certaines API une fois derrière le VAC, pourquoi ne pas essayer de contacter toi même les API (en curl, wget ou autre outils à ta disposition et compatible avec les API en face) en mettant tout au niveau de débug maximal pour le faire remonter au support ?
Je suis un client, pas un beta testeur, je n'ai pas vocation à faire des debugs et des tests à tout va dans le but d'améliorer les services de mon fournisseur ...

Citation Envoyé par janus57
Car je le répète le forum ce n'est pas le support, si @Fabian passe c'est surement pour éviter les spams et/ou valider les messages en modération.
CF réponse à la première citation ...

#######

Enfin bon, je viens poster ici même les résultats finaux, car si cela arrive à d'autres personnes ce topic pourrais être utile.

Après plusieurs échanges avec le support par mail (réponse ticket qui m'étaient transmises par email), il y à clairement eu un problème à cause d'une double "Mitigation" sur mon serveur dédié.

En effet, suite à une attaque, le système automatique à activé une "Mitigation" automatique, cependant une intervention manuelle à ensuite eu lieux, et un technicien du support à placé ensuite mon serveur en "Mitigation" manuelle.
Résultat, la "Mitigation" automatique c'est bien désactivée après un délai raisonnable, cependant la "Migitation" manuelle à était oubliée ...

Citation Envoyé par Fabian
Bonjour,

L'ip est plus actuellement sous mitigation :
Après l'intervention de Fabian, tout est de nouveau revenu fonctionnel, vraisemblablement car Fabian lui même à remontée l'information avant de faire sa réponse.
En effet, même si il ne le dis pas clairement, j'avais fait énormément de traceroute avant, et le fait que tout soit rentré dans l'ordre juste après ça réponse laisse comprendre un lien entre les deux ...

Point important, d'après le support la "Mitigation" n'entraîne pas de problème avec des services d'hébergements vocaux tel que TeamSpeak, ou des API web, mais je n'ai pas eu plus de détail, cela voudrait probablement dire que ceci est vrai concernant la "Mitigation" automatique, pas la manuelle.

Au final tout est rentré dans l'ordre, même si mon serveur dédié était dans les choux pour bon nombre de services pendant plus de 72h, le support à fini par me présenter ces excuses pour le délais (mais pas pour l'erreur), et je sais à quoi m'en tenir si d'aventure j'ai de nouveau un soucis de ce genre.

nicobilaine
25/03/2015, 07h23
Citation Envoyé par buddy
je le lui ai conseillé car je pensais que tout était down ... d'ailleurs, le port 22 de son serveur ne répondait pas.
D'après son premier message, seul ses API ne fonctionnaient plus, les services de base étaient OK :
...
En effet, je me suis rendu compte que lors de la mise en "Mitigation" d'un serveur dédié, le ping, et les services "classiques" tel que le ssh, ou la navigation sur serveur apache, fonctionnent parfaitement, mais 90% des autres services sont HS ...
...

buddy
24/03/2015, 19h57
Citation Envoyé par nicobilaine
Il faut éviter le hard reboot par le manager tant qu'on accède à la ligne de commande (SSH) car il arrête brutalement le serveur (coupure du courant) avec toutes les conséquences qui peuvent en découler.
je le lui ai conseillé car je pensais que tout était down ... d'ailleurs, le port 22 de son serveur ne répondait pas.

janus57
24/03/2015, 13h14
Bonjour,

A chaque fois qu'un utilisateur est mécontent je constate qu'on balance les CGV et autre SLA ...

Effectivement je vais surcharger le support avec mes requêtes ...

Belle réponse d'entre aide.
En même temps tu poste sur un forum ou le staff passe quand il en a envie, le vrais support KS c'est sur le manager/mail, les membres n'ayant pas accès aux outils du staff KS (encore heureux) tu souhaite qu'on t'aide comment ???

Une mitigation active depuis plus de 80h alors que normalement ce n'est pas plus de 1 à 24h d'après ce que j'ai compris, c'est bien qu'il y à un problème dont je ne suis pas responsable et que je ne peux pas régler sans le support Kimsufi.
non, d'après la page OVH dédié à l'anto-DDoS la durée minimal est de 26H après la fin de l'attaque contre le serveur.
La protection reste donc en place le temps de l'attaque + 26H une fois l'attaque finit dans le cas ou l'attaquant souhaite reprendre durant ce lapse de temps de 26H (par contre si il connait ces contraintes des 26H c'est claire qu'il va recommencer 28H plus tard).

Après pour remonter les problème de communication avec certaines API une fois derrière le VAC, pourquoi ne pas essayer de contacter toi même les API (en curl, wget ou autre outils à ta disposition et compatible avec les API en face) en mettant tout au niveau de débug maximal pour le faire remonter au support ?

Car je le répète le forum ce n'est pas le support, si @Fabian passe c'est surement pour éviter les spams et/ou valider les messages en modération.

Cordialement, janus57

nicobilaine
24/03/2015, 11h13
Il faut éviter le hard reboot par le manager tant qu'on accède à la ligne de commande (SSH) car il arrête brutalement le serveur (coupure du courant) avec toutes les conséquences qui peuvent en découler.

WolwX
24/03/2015, 10h03
Citation Envoyé par Fabian
Bonjour,

L'ip est plus actuellement sous mitigation :

traceroute to 37.59.46.137 (37.59.46.137), 30 hops max, 60 byte packets
[...]
7 * gsw-1-6k.fr.eu (178.33.100.221) 1.373 ms *
8 gsw-g1-a9.fr.eu (213.186.32.157) 1.766 ms 1.760 ms 1.742 ms
9 rbx-g2-a9.fr.eu (91.121.215.151) 5.422 ms rbx-g2-a9.fr.eu (91.121.131.213) 5.933 ms rbx-g2-a9.fr.eu (91.121.215.151) 5.346 ms
10 vss-8a-6k.fr.eu (91.121.215.187) 5.350 ms vss-8b-6k.fr.eu (91.121.128.37) 5.550 ms *
11 www1.n1-servers.net (37.59.46.137) 5.965 ms 6.632 ms 5.980 ms

Fabian
Bonjour,

Effectivement vous l'avez visiblement enfin désactivée et tout mes services web semble de nouveau fonctionner normalement dorénavant.

Pouvez vous me confirmer que c'était une erreur ou un oublie du serveur en Mitigation, ou à contrario que c'était normal afin que je sache m'organiser en conséquence si nécessaire à l'avenir.

Merci à vous.

Fabian
24/03/2015, 09h47
Bonjour,

L'ip est plus actuellement sous mitigation :

traceroute to 37.59.46.137 (37.59.46.137), 30 hops max, 60 byte packets
[...]
7 * gsw-1-6k.fr.eu (178.33.100.221) 1.373 ms *
8 gsw-g1-a9.fr.eu (213.186.32.157) 1.766 ms 1.760 ms 1.742 ms
9 rbx-g2-a9.fr.eu (91.121.215.151) 5.422 ms rbx-g2-a9.fr.eu (91.121.131.213) 5.933 ms rbx-g2-a9.fr.eu (91.121.215.151) 5.346 ms
10 vss-8a-6k.fr.eu (91.121.215.187) 5.350 ms vss-8b-6k.fr.eu (91.121.128.37) 5.550 ms *
11 www1.n1-servers.net (37.59.46.137) 5.965 ms 6.632 ms 5.980 ms

Fabian

WolwX
24/03/2015, 07h35
Citation Envoyé par buddy
Bonjour,

normalement la mitigation ne bloque que les pings/traceroute ... le reste des services doit rester actifs. quels sont ces services d'ailleurs ?
çà ne serait pas l'attaque qui a surchargé le serveur, remplit la RAM + swap et tout fait planter ? un reboot / redémarrage des rd services ne marche pas ? tu as essayé un redémarrage HARD via le manager ?
Bonjour Buddy,

Ok je tente le reboot Hard par manager et pas système :
Etes-vous certain(e) de vouloir redémarrer le serveur ns331873.ip-37-59-46.eu?

Attention: Il s'agit d'un redémarrage à froid (reboot hard).

Les services en rade vont de l'hébergement vocal (Mumble) à des soucis DNS, mais les plus gros viennent de soucis avec les API web tel que Akismet (antispam WordPress) ou des boutiques avec automatisation comme WHMCS.

Aucun soucis de surcharge RAM ou Swap après vérification.

Édit : Reboot Hard pour le sport, strictement aucun changement constaté, les mêmes soucis pour mes API web, PayPal et autre ...

BBR
24/03/2015, 07h26
La mitigation n'empêche pas le serveur de fonctionner, comme te le suggère Buddy, tente un reboot.

buddy
24/03/2015, 07h20
Bonjour,

normalement la mitigation ne bloque que les pings/traceroute ... le reste des services doit rester actifs. quels sont ces services d'ailleurs ?
çà ne serait pas l'attaque qui a surchargé le serveur, remplit la RAM + swap et tout fait planter ? un reboot / redémarrage des services ne marche pas ? tu as essayé un redémarrage HARD via le manager ?

WolwX
24/03/2015, 07h15
[
Citation Envoyé par janus57
Bonjour,

vu l'heure le support KS te répondra pas avant demain 9H.

De plus 2 tickets support pour la même chose ne sert à rien à part ralentir le support et le traitement de tes tickets.

De plus la mitigation KS est au même prix que les serveur KS, donc "minimal".

Cordialement, janus57
Bonjour Janus57,

A chaque fois qu'un utilisateur est mécontent je constate qu'on balance les CGV et autre SLA ...

Effectivement je vais surcharger le support avec mes requêtes ...

Belle réponse d'entre aide.

Qui t'a dis que les deux tickets étaient ouvert pour la même chose ?

Le premier ticket à était ouvert mystérieusement par le support lui même mais sans aucune infos ou réponse faite.
Le second je l'ai ouvert moi même avec toute les infos clairement indiquées et un titre approprié.

Une mitigation active depuis plus de 80h alors que normalement ce n'est pas plus de 1 à 24h d'après ce que j'ai compris, c'est bien qu'il y à un problème dont je ne suis pas responsable et que je ne peux pas régler sans le support Kimsufi.

Citation Envoyé par t0t0
Je vais peut être dire une bêtise mais il n'y a pas l'option pour dans le manager ? (partie "dédié" puis "IP")
En fait je crois que ce réglage n'existe que sur les offres OVH, pas les Kimsufi, ceci étant mis et enlevé automatiquement par le support.

janus57
23/03/2015, 23h59
Bonjour,

non, la mitigation automatique est enlevé normalement 26H après la fin de l'attaque.

Cordialement, janus57

t0t0
23/03/2015, 23h10
une simple désactivation de la "Mitigation" de mon serveur ... ?
Je vais peut être dire une bêtise mais il n'y a pas l'option pour dans le manager ? (partie "dédié" puis "IP")

janus57
23/03/2015, 22h51
Bonjour,

vu l'heure le support KS te répondra pas avant demain 9H.

De plus 2 tickets support pour la même chose ne sert à rien à part ralentir le support et le traitement de tes tickets.

De plus la mitigation KS est au même prix que les serveur KS, donc "minimal".

Cordialement, janus57

WolwX
23/03/2015, 22h34
Serait il possible d'avoir un peu de support, une simple désactivation de la "Mitigation" de mon serveur ... ?

En attendant que le support veuille bien me répondre je reste avec de gros problème de gestion qui vont me pousser à migrer l'ensemble de mes services sur un autre dédié si ça continue ...

Pour info j'ai 2 tickets de support sans aucune réponse, ce topic consulté ce matin mais vite oublié, et un mail envoyé dans la journée restant lui aussi sans réponse ....

WolwX
23/03/2015, 09h21
Meme login que sur le forum et boite email :
wolwx@hotmail.com

2 tickets en cours sur mon interface (je ne sais pas où trouver le numéro des tickets)
Ip du dédié sur le traceroute suivant.

Trace route depuis http://ping.eu/traceroute/ :

Traceroute – Traces the route of packets to destination host from our server
IP address or host name:

traceroute to 37.59.46.137 (37.59.46.137), 30 hops max, 60 byte packets


1 * * *


2 hos-tr3.juniper2.rz13.hetzner.de 213.239.224.65 de 0.166 ms
hos-tr2.juniper1.rz13.hetzner.de 213.239.224.33 de 0.132 ms
hos-tr4.juniper2.rz13.hetzner.de 213.239.224.97 de 0.143 ms


3 core21.hetzner.de 213.239.245.81 de 0.261 ms 0.251 ms 0.205 ms


4 core12.hetzner.de 213.239.245.214 de 2.772 ms
core11.hetzner.de 213.239.245.221 de 2.804 ms
core11.hetzner.de 213.239.245.225 de 2.796 ms


5 juniper4.rz2.hetzner.de 213.239.203.138 de 2.851 ms 2.841 ms 2.840 ms


6 et-1-0-0-710.nbg40.core-backbone.com 81.95.15.5 de 2.816 ms 2.887 ms 2.919 ms


7 ae5-2003.fra20.core-backbone.com 80.255.15.22 de 5.891 ms 5.908 ms 5.896 ms


8 decix.routers.ovh.net 80.81.192.209 de 5.800 ms * *


9 sbg-g2-a9.fr.eu 91.121.128.82 fr 8.840 ms 8.972 ms 8.875 ms


10 vac2-0-a9.fr.eu.vaccum 178.33.100.97 fr 10.658 ms 10.991 ms 12.924 ms


11 vac2-1-n7.fr.eu.firewall 178.33.100.98 fr 9.467 ms 9.092 ms 9.141 ms


12 vac2-2-n7.fr.eu.tilera 37.187.36.247 fr 9.301 ms 9.041 ms 8.899 ms


13 * * *


14 * * *


15 * * *
No reply for 3 hops. Assuming we reached firewall.

Fabian
23/03/2015, 09h10
Bonjour,

Il faudrait mentionner une information comme nom du serveur son ip, ou un numéro de commande/facture.

Fabian

WolwX
23/03/2015, 08h36
Bonjour à tous,

Suite à une attaque de type DDOS, mon serveur à était placé en "Mitigation" chez OVH depuis vendredi vers les 18h, et depuis, c'est le trou noir ....
L'attaque n'à pas duré très longtemps, et à bien entendu pût être contenu grace à ce système de "Mitigation", cependant, il semblerait que le support ai oublié d'enlever mon serveur de ce système, et je suis donc depuis 48h sans aucun fonctionnement de 90% de mes services.

En effet, je me suis rendu compte que lors de la mise en "Mitigation" d'un serveur dédié, le ping, et les services "classiques" tel que le ssh, ou la navigation sur serveur apache, fonctionnent parfaitement, mais 90% des autres services sont HS ...
C'est ainsi que je me retrouve avec un serveur DNS dans les choux, des API de site web non fonctionnelles (whmcs ou akismet par exemple), des serveurs vocaux injoignable, etc ....

Avez vous déjà connu une situation pareil ?

Je m'inquiète car le support Kimsufi à la réponse à tout par cette phrase "pas de support" ...
Donc en attendant d'avoir une réponse à l'un de mes tickets, je suis venu chercher l'avis et les conseils d'utilisateur sur le forum.