OVH Community, your new community space.

Issue with SSH Keys


elmario
07/04/2015, 04h06
I have had no alternative but to reinstall the server using a new SSH key, this fixed the problem. I don't know what is going on, but clearly the OVH panel was not updating the authorized_keys file for this machine

@nowwhat thank you for your response however I've already tried what you have mentioned, not only this but I tried to reply to this thread with a few images explaining everything more clearly, but the moderators didn't approve it or something so it didn't appear. I've been using this kimsufi server for 3 years, and this is the only time I've had a problem with SSH keys. It's a big shame, but I can't complain over 5 EUR a month I guess

elmario
07/04/2015, 01h05
Hi,

Thank you very much for your reply. I've tried everything you have mentioned please see the following images:

Managerv3 does not have SSH config: http://gyazo.com/b93dc42ab4edf26308a450e6826cbf62
but new manager does have it.

I have set the key up using the new manager, and clicked the key icon to make it default for rescue mode: http://gyazo.com/377fde4df895b3beea2ef819475ae586 as you can see the key is in the correct format, and is accepted by the OVH manager..

The server is also in rescue mode, and has been rebooted. So everything should work correctly right? http://gyazo.com/5d7c9da77557caeb9816300a43058534

Here is my Putty config: http://gyazo.com/8a0aa6822a33374a1019d03896da8da7 it's clearly loading the same private key I used when generating the public key inside the manager...

This is what I see when I click "open": http://gyazo.com/96d1ce9e5ca373c707906b9aaa421b94 it asks me for login username, and login password, which it shouldn't do... so I do not understand which step of the process is wrong.

nowwhat
06/04/2015, 23h44
Hi !

I had a KS for years, and believe it, or, not, the ManagerV3 HAS an option so you can put in a valid public key. I used that method for years.
This key will not be put on your server, of course. KS(OVH) can't access your server - but ..... this key will be used when booting in rescue mode. KS(OVH) will build a remote-network-boot environment just for you that uses your public key, so you can enter right away using SSH and the private key.

Of course, the public key you past in the Manager has to have a good format, like:
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAAAgQCrCSZsgoTBAPouYiDfau NedKIytrpk0YNu9tf+g0DBHO0CWuVYdGoJu9tazagzTdo57Ly6 4VDvjmwQ4CevT1To0SFw2BZoKG9GNm5sHT6NShociUnRIKLEwz mJ 7W9ybax8fZbUjGRumVG4k2bl5P/u2cvbJmi5zoyWFS5meRAexw== root@whatever.tld
No space or newlines it please.

The nice part about is that you will not need the root+password that should have been send to you by mail. So, no mail, or a mail, you don't care
Just setting up Putty to use the private key, and you're in.
I've tried that, as said, and it works very well. As a matter of fact, I even use that solution right now with my SYS server - when booting to rescue I just connect Putty and I'm in. The same public key is on my server (in /root/.ssh/authorized_keys) and in the Manager6 (?) that's being used for SYS managaging. So, recue mode, or not, I even don't need to setup Putty differently, I'm getting in the same way - without changing anything.

Of course, as soon as your are 'in' rescue mode, you mount your partitions, you edit your /mnt/root/.ssh/authorized_keys2 (or /mnt/root/.ssh/authorized_keys) [ I'm using basic, standard, world-wide known OS like Debian, where ever thing is 'normal' - your milage may vary) and you put in your new public key - save - set to normal HD boot in Manager, reboot server and all is well again. You can enter with your new private key.

Questions : When was the last time you booted in rescue mode ? Did it work ?
Better have your mail address being changed - it's throwing away mails you NEED, not a good sign. You checked the spam folder, right ?

Btw: things can get nastier: your portable will be fine, but your server's hard disk blows up ..... Good keys won't help you then, neither rescue mode.

Btw2: this is a pure 100 % software issue.
As you might know: OVH (KS !!) can't support 'ssh' problems, they didn't even wrote the software.
KS server contract even states "You agree that YOU handle YOUR problems". Don't think you received a special treatment: the same goes for me, him, her, etc, all software issues are not supported by KS - they just can't (red: WE never paid them to do so anyway, so now you understand why the price is so low).

and 3) this http://forum.kimsufi.com/showthread....imsufi-Manager is valid - works, has been tested.

PS: To get help even faster, think about pressing the enter key one and a while

elmario
06/04/2015, 21h21
Hi,

Before I continue I've already tried contacting support, checking online tutorials, OVH guides and viewing previous threads. Recently the laptop containing the SSH keys I used to connect to my Kimsufi server has died, and therefore I'm using a new laptop. Obviously when I try to connect to the server I can't because I don't have the keys on the new laptop. I've tried generating new keys using Puttygen, and then adding them to my account via the new admin panel, but I keep on getting "Server refused our key" error. I've tried setting the key as default for rescue mode, and then booting the server into rescue mode, but I cannot connect. When I set the server to rescue mode I don't receive an email with the new login details like I'm supposed to. It seems as if the admin panel isn't doing anything and it generally feels really buggy. I've been stuck with the issue for almost 2 weeks, with very little support from OVH who simply told me to use their support form. I sent out a support request using that form almost 1.5 weeks ago, but I still havent received a response, so I would appreciate any replies. I've tried the manager v3, however it doesn't have any option to manage SSH keys, or boot the server into rescue mode.