OVH Community, your new community space.

timezone php.ini


-romu-
18/05/2015, 18h23
Merci fred !
Effectivement, j'avais pas fait attention !

j'ai 3 ini
/etc/php5/apache2/php.ini
/etc/php5/cgi/php.ini
/etc/php5/cli/php.ini

C'est tout bon maintenant

fred2541
18/05/2015, 17h53
je ne pense pas que les guillemets soit important.
Fait bien attention au php.ini que tu édite !

"php -i" utilise chez moi "/etc/php5/cli/php.ini"

alors que apache utilise "/etc/php5/apache2/php.ini "

Il y a deux version différente de php.ini. Une pour la console et une autre pour apache.

BBR
18/05/2015, 17h05
Code PHP:
date_default_timezone_set('Europe/Paris'); 
à mettre sur ta page

nowwhat
18/05/2015, 17h03
Citation Envoyé par -romu-
Pourtant, j'ai bien configuré le fichier php.ini
date.timezone = "Europe/Paris"
Humm.

J'ai ceci :
[Date]
; Defines the default timezone used by the date functions
; http://php.net/date.timezone
date.timezone = Europe/Paris
donc sans les " "......

-romu-
18/05/2015, 16h59
Bonjour à tous,

J'ai voulu installé Symfony sur mon kimsufi et j'ai constaté quelques erreurs...
Surtout pour l'utilisation par la console qui serait du au timezone...

ex : avec la commande php -i | grep "php.ini"
J'ai le message suivant :

Code:
PHP Warning:  Unknown: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone. in Unknown on line 0
Pourtant, j'ai bien configuré le fichier php.ini
date.timezone = "Europe/Paris"

Avez vous une idée ?
Merci