OVH Community, your new community space.

Notifications Munin


StephaneC
22/05/2015, 13h52
Bonjour,
J'ai désactivé le plugin "df" hier soir, pour l'instant je n'ai pas reçus de mail.
Évidemment, je pense aussi que le problème de notification viens de ce plugins, vu que dans le mail nous avons les stats des disques, mais Ce que je ne comprends pas c'est pourquoi je reçois toujours des notification pour 1 ou deux serveurs, mais jamais pour mes autres serveurs.
Les disques sont loin d'être pleins ( et loins de la barrière "warning").
Je ne fais pas de grosse écritures non plus.

Merci tout de même, je vais aller voir du côté des bugtracker.
Cordialement,
Stéphane

janus57
21/05/2015, 20h06
Bonjour,

est-ce que vous pouvez vous passer du plugin munin "df" pendant 24 à 48H pour voir si c'est lui qui génère ce problème ?

Car il me semble avoir vu sur le bugtracker de redhat ce genre de problème.

Cordialement, janus57

StephaneC
21/05/2015, 16h15
Bonjour,

La version de munin-node est la même sur toutes les VMs (même version pour munin aussi) : 2.0.25-1
Je n'ai pas touché au temps (5 min, pour le refresh, il me semble)

Les notifications que je reçois vient des machines virtuelle, il ne me semble pas en avoir reçus pour le serveur physique.
C'est du débiant 8, mais je recevais déjà les notification en Debian 7 (avant update) ...

J'ai un mount sur toutes mes VMs, mais il n'est pas présent dans les lignes de notification.

Voilà, je ne vois pas quels autres détails peuvent influencés sur ça :/

Cordialement,
Stéphane

janus57
21/05/2015, 15h45
Bonjour,

vous avez touché au temps de pool munin ? même version partout ?
Autre détails ?

Cordialement, janus57

StephaneC
21/05/2015, 13h30
Bonjour,

J'ai un petit soucis avec munin. J'ai un serveur sous Proxmox, avec plusieurs VMs.
J'ai installé des munin-nodes sur toutes les VMs (et mon proxmox), et j'ai configuré munin pour m'envoyer des notifications en cas de problème.
Ce point à l'air de fonctionner.

Le problème est que, je reçois de temps à autre des mails de munin me disant que tout vas bien. (Sans avoir levé d'erreur avant)

Exemple :
Hier, 13H30 :
Code:
##### :: 090-VM1.#####  :: Disk usage in percent
        OKs: /run/user/0 is 0.00, /sys/fs/cgroup is 0.00, /dev/shm is 0.00, /run is 12.57, / is 20.21, /run/lock is 0.00.

#####  :: 002-VM2.#####  :: Disk usage in percent
        OKs: /run/user/0 is 0.00, /run/lock is 0.00, / is 22.44, /run is 3.08, /sys/fs/cgroup is 0.00, /dev/shm is 0.00.
Hier, 20H00 :
Code:
##### :: 002-VM2.#####:: Disk usage in percent
        OKs: /run/lock is 0.00, /run/user/0 is 0.00, /sys/fs/cgroup is 0.00, / is 22.44, /run is 3.08, /dev/shm is 0.00.
Hier, 21H50 :
Code:
##### :: 002-VM2.##### :: Disk usage in percent
        OKs: /run/user/0 is 0.00, / is 22.44, /sys/fs/cgroup is 0.00, /run is 3.08, /run/lock is 0.00, /dev/shm is 0.00.

Pas de mails reçus entre ceux affichés.
Je n'en reçois pas tous les jours, mais ça peut monter à 5/6 par jours.
Voilà, si vous avez des idées sur ce qui pourrait provoquer ça, je suis preneur !

Cordialement,
Stéphane