OVH Community, your new community space.

hidepid being forced for /proc


teknogeek
04/06/2015, 17h27
Hi, I have a dedicated server running Ubuntu 14.10. There are multiple users on it and the accounts other than root cannot see processes belonging to other users in htop, top, or ps. 99% of the time, the reason that this happens is because the /proc file system has hidepid set to 1 or 2. I checked the mount flags on it and hidepid is apparently not set. I even tried doing
Code:
mount -o remount,rw,hidepid=0 /proc
and it is still not possible to see processes not belonging to yourself. The reason that I am not just setting a sudoers rule specifically for htop, ps, etc is because it needs to be able to work without running specifically with sudo and I would rather not set aliases to run it as such.

Here is the output of the mounts from /proc/mounts:
Code:
user@host:~$ grep /proc /proc/mounts
none /proc proc rw,relatime 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
Any help would be very much appreciated!