OVH Community, your new community space.

Mon serveur kimsufi freeze régulièrement


nicobilaine
19/10/2015, 09h41
Citation Envoyé par ancy
J'ai installé munin

Je ferai les tests en rescue pendant une nuit
Pourquoi attendre la nuit? Il ne devrait pas y avoir de production critique sur un Kimsufi...
Il faut vraiment faire les tests, car si le disque est bon ça peut venir du CPU ou de la RAM et il n'y a que les tests en rescue qui le diront.

nowwhat
17/10/2015, 13h55
Citation Envoyé par ancy
....
Pour l'instant je ne remarque rien dans logs Apache / Munin
Retour vers https://www.test-domaine.fr/munin/pa...org/index.html - il me semble qu'il surveiller un peu plus que 'Apache'.
Citation Envoyé par ancy
....
J'ai des sauvegardes en permanence mais si c'est bien le disque, est-ce que vous connaissez un outil qui permette de faire un snapshot puis restore sans se cogner toute la réinstallation du serveur ? est-ce que OVH peut monter le nouveau en raid ?
Raid ?
Un raid 1 j'espère.
Il s'agit d'un KS - ou, d'ailleurs, n'importe quel serveur chez OVH, c'est à l'admin de sauvegarder - et remettre les données en place en cas de panne.
KS (OVH) s'occupe pas non plus de installation logique de ton disque/raid - c'est à toi.

Go Rescue et test tes disques. Mémoire aussi.

ancy
17/10/2015, 07h16
Mon serveur est de nouveau inaccessible. Si c'est le disque ce sera son troisième...

J'ai envoyé un fichier de 35Go entre 17h et 19h sur le serveur en plus de la charge normale, mais le serveur était encore disponible.

Voici les graphiques OVH qui me paraissent les plus pertinents :


On voit bien le transfert de fichier.


Le disque dur n'est pas saturé, on voit le traffic.





De ces graphiques je serai tenté de déduire que ce n'est pas le disque mais une charge soudaine qui fait saturer le serveur de requêtes ? Mais il se bloque ensuite au lieu de traiter son stock de charge ?

Pour l'instant je ne remarque rien dans logs Apache / Munin

Comment interpréter la différence entre loadaverage et cpu ?

Le swap est fixe à 0% (ou alors le graphique ne fonctionne pas).

La mémoire vive utilisée est inférieure à 5% et grimpe à 8% au moment du plantage.

J'ai activé le mode rescue mais j'ai rebooté trop vite il ne l'a pas pris en compte. Je vais déjà analyser ce que j'ai sous la main.

J'ai des sauvegardes en permanence mais si c'est bien le disque, est-ce que vous connaissez un outil qui permette de faire un snapshot puis restore sans se cogner toute la réinstallation du serveur ? est-ce que OVH peut monter le nouveau en raid ?

Merci d'avance pour les remarques et avis que cela pourra vous inspirer

ancy
16/10/2015, 15h40
J'ai installé munin

Je ferai les tests en rescue pendant une nuit

ancy
16/10/2015, 15h35
Merci pour vos réponses je vais commencer par là !

Je pensais que le problème suivant permettait peut être de donner une piste
- La connexion SSH se fait, je peux m'authentifier, la mire de connexion à Ubuntu s'affiche, mais ne me rends jamais la main pour faire une saisie clavier.

nowwhat
16/10/2015, 14h29
.... puis, quitte à perdre un peu (très peu) de puissance, faire une collecte des données pour voir, très utile au bout de certain temps.
Exemple :https://www.test-domaine.fr/munin/pa...org/index.html

Car, il faut un max des doonées pour comprendre "pourquoi ça ne marche plus".

Il est aussi impossible de demander à ton garagiste (par téléphone) pourquoi ta voiture devant ta porte "ne démarre plus".
Il ne saurais pas te répondre.

nicobilaine
15/10/2015, 14h53
Et surtout arrêter les redémarrage depuis le manager, qui ne feront qu'aggraver le problème si le disque dur est mourant.

BBR
15/10/2015, 11h41
démarrer en rescue et faire les tests matériels pour commencer

ancy
15/10/2015, 10h28
Bonjour,

Mon serveur kimsufi freeze régulièrement :
- Apache ne répond plus
- La connexion SSH se fait, je peux m'authentifier, la mire de connexion à Ubuntu s'affiche, mais ne me rends jamais la main pour faire une saisie clavier.

Si je redémarre le serveur c'est bon, mais aucune trace dans les logs sinon le redémarrage. Dans le manager OVH le CPU est calme, la mémoire idem.

OVH le redémarre de temps en temps (sans que je le demande, lorsqu'ils s’aperçoivent du problème):
Date 2015-10-04 15:57:19, kevin D a fait Reboot HARD:
Voici le detail de l'intervention realisee:
Serveur 'freeze'. Pas de reponse clavier.

Actions entreprises:
Redemarrage hardware du serveur.

Resultat:
Boot OK. Serveur sur 'login'. Ping OK, services demarres.
C'est une Kimsufi 16G i5-2320 CPU @ 3.00GHz 16Go 2To sata

Est-ce que vous reconnaissez un symptôme particulier ?
Que contrôler ?

Merci d'avance pour vos idées