OVH Community, your new community space.

Mon domaine est HS depuis hier. Problème de DNS, autres ?


nowwhat
04/11/2015, 21h38
Citation Envoyé par FleuryK
...
.....et je remplace "v=spf1 a mx -all" par "v=spf1 a mx ~all" dans mon fichier db.fleuryk.tk si j'ai bien compris ?
SPF entrée pendant la phase de test => v=spf1 a mx ~all (quand ça fail, ce n'est pas grave)
SPF entrée pendant APRÈS phase de test => v=spf1 a mx -all (quand ça fail, ce est grave, ce que tu cherche : quelqu'un qui envoi un mail avec TON domaine comme expéditeur, mais le mail n'est pas partie de ton domaine, sera rejeté - c'est ça le but d'un SPF)

BBR
04/11/2015, 21h37
Code:
      IN TXT    "v=spf1 a mx ~all"

Freemaster
04/11/2015, 21h05
ouais

FleuryK
04/11/2015, 21h01
Bonsoir @Freemaster,

Donc je vire ce "v=spf1 a mx ip4:151.80.46.90 ~all" et je remplace "v=spf1 a mx -all" par "v=spf1 a mx ~all" dans mon fichier db.fleuryk.tk si j'ai bien compris ?

Cordialement.

Freemaster
04/11/2015, 18h39
sauf que ton domaine contient :
v=spf1 a mx ip4:151.80.46.90 ~all
v=spf1 a mx -all

c'est l'un ou l'autre... même mieux seulement v=spf1 a mx ~all aurait le même effet

FleuryK
04/11/2015, 16h50
Bonjour,

J'ai mis ces codes dans mon fichier db.fleuryk.tk :
Code:
SPF 	"v=spf1 a mx ip4:151.80.46.90 ~all"
TXT 	"v=spf1 a mx ip4:151.80.46.90 ~all"
Car sur mail-tester.com ils n'indiquent pas si c'est un SPF ou TXT donc par précaution, j'ai mis les 2 dans mon fichier, restart bind9 et pour le moment, la note est de 7/10 donc je pense que je patiente un peu avant de retrouver le 9/10.

Mais pour le moment le problème est résolu, mon domaine fleuryk.tk refonctionne à merveille depuis hier après-midi.

nowwhat
04/11/2015, 16h15
Citation Envoyé par FleuryK
Bonjour @Freemaster et @nowwhat,

@nowwhat : Pour répondre à tes questions, je suis sur et certain quand j'ai mis ce code, avoir redémarré bind mais sans doute dans la semaine ou j'ai mis ce code il s'est sans doute arrêté sans aucune raison. Concernant les logs, pour bind, je ne sais pas ou ça se trouve :s ....
C'est comme Google, pour trouver un truc, il faut trouver "la phrase".
Sachant que le nom du processus est "named"
....
et que tout le monde cherche depuis des années '60 des 'truc' dans des fichiers très balaises, ils ont inventé ...
grep

On y va:
cd /var/log
grep -R 'named' *
et t'aura une liste avec les fichiers dans laquelle 'named' est mentionné ....

Il suffit de voir dans ce fichiers (cherche dedans avec la fonction 'rechercher' de ton traitement de texte).


edit:
Code:
...
	TXT 	"v=spf1 a mx -all"
	SPF 	"v=spf1 a mx -all"
"v=spf1 a mx ip4:151.80.46.90 ~all"
$ORIGIN fleuryk.tk.
...
provoque bien sur un énorme erreur de syntaxe.
ceci
Code:
"v=spf1 a mx ip4:151.80.46.90 ~all"
est balancé en vrac dans le fichier. Pas bon.

Ceci est plus juste :
Code:
	SPF 	"v=spf1 a mx ip4:151.80.46.90 ~all"
ou
Code:
	TXT 	"v=spf1 a mx ip4:151.80.46.90 ~all"
Mais e camps SPF est abbandoné, donc ceci est parfait
Code:
	TXT 	"v=spf1 a mx -all"
teste-le toi même.
Place
Code:
"v=spf1 a mx ip4:151.80.46.90 ~all"
dans ton fichier de zone est lance un
named-checkconf -z
Il va hurler !!

FleuryK
04/11/2015, 16h00
Bonjour @Freemaster et @nowwhat,

Je vais mettre le fichier de db.fleuryk.tk partiel ou j'avais mis ce code (mis en gras) :
Code:
...
	TXT 	"v=spf1 a mx -all"
	SPF 	"v=spf1 a mx -all"
"v=spf1 a mx ip4:151.80.46.90 ~all"
$ORIGIN fleuryk.tk.
...
Ensuite avec la commande named-checkconf -z. J'ai ceci en réponse :
Code:
zone localhost/IN: loaded serial 2
zone 127.in-addr.arpa/IN: loaded serial 1
zone 0.in-addr.arpa/IN: loaded serial 1
zone 255.in-addr.arpa/IN: loaded serial 1
zone fleuryk.tk/IN: loaded serial 2015110301
@nowwhat : Pour répondre à tes questions, je suis sur et certain quand j'ai mis ce code, avoir redémarré bind mais sans doute dans la semaine ou j'ai mis ce code il s'est sans doute arrêté sans aucune raison. Concernant les logs, pour bind, je ne sais pas ou ça se trouve :s ....

nowwhat
03/11/2015, 20h30
Citation Envoyé par FleuryK
.
J'ai viré ce "v=spf1 a mx ip4:151.80.46.90 ~all" de mon fichier db.fleuryk.tk et restart bind9 et le résultat est concluant car mon domaine refonctionne à nouveau.
Virer le champs SPF (ou TXT) et ça marche ?
Bizarre.
C'est vrai que le ""v=spf1 a mx -all" que t'as mis à la place est bien mieux.

AVANT de démarrer ou redémarrer bind, exécute toujours d’abord un
named-checkconf -z
et si pas d'erreur, démarre ou redémarre.

La question est que : bind tourné encore (juste avant) ? Et sinon, pourquoi il s’arrêté ? T'as regardes tes logs pour trouver la réponse ?

Freemaster
03/11/2015, 18h30
faut voir comment tu l'as mis ce code, il est fort probable qu'il y a une erreur de syntaxe, genre un "." par exemple

FleuryK
03/11/2015, 13h33
Bonjour janus57,

J'ai viré ce "v=spf1 a mx ip4:151.80.46.90 ~all" de mon fichier db.fleuryk.tk et restart bind9 et le résultat est concluant car mon domaine refonctionne à nouveau.

Cordialement.

janus57
03/11/2015, 13h15
Bonjour,

fleuryk.tk@ns.kimsufi.com.:

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.37.rc1.el6_7.4 <<>> ANY +additional fleuryk.tk. @ns.kimsufi.com.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 1822
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;fleuryk.tk. IN ANY

;; Query time: 98 msec
;; SERVER: 213.186.33.199#53(213.186.33.199)
;; WHEN: Tue Nov 3 13:14:01 2015
;; MSG SIZE rcvd: 28

fleuryk.tk@ns3008845.ip-151-80-46.eu.:

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.37.rc1.el6_7.4 <<>> ANY +additional fleuryk.tk. @ns3008845.ip-151-80-46.eu.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 24889
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;fleuryk.tk. IN ANY

;; Query time: 97 msec
;; SERVER: 151.80.46.90#53(151.80.46.90)
;; WHEN: Tue Nov 3 13:14:01 2015
;; MSG SIZE rcvd: 28


www.fleuryk.tk@ns.kimsufi.com.:

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.37.rc1.el6_7.4 <<>> ANY +additional www.fleuryk.tk. @ns.kimsufi.com.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 25302
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;www.fleuryk.tk. IN ANY

;; Query time: 113 msec
;; SERVER: 213.186.33.199#53(213.186.33.199)
;; WHEN: Tue Nov 3 13:14:01 2015
;; MSG SIZE rcvd: 32

www.fleuryk.tk@ns3008845.ip-151-80-46.eu.:

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.37.rc1.el6_7.4 <<>> ANY +additional www.fleuryk.tk. @ns3008845.ip-151-80-46.eu.
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 7780
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;www.fleuryk.tk. IN ANY

;; Query time: 99 msec
;; SERVER: 151.80.46.90#53(151.80.46.90)
;; WHEN: Tue Nov 3 13:14:01 2015
;; MSG SIZE rcvd: 32
Donc le problème viens de votre KS qui ne renvoie rien qui le DNS secondaire qui c'est synchro avec et donc renvoie rien non plus.

Cordialement, janus57

FleuryK
03/11/2015, 10h24
Bonjour,

Comme je sais pas s'il faut que j'ouvre un ticket ou un sujet sur ce forum, j'ai préféré de poster mon problème sur ce forum.

J'ai un problème depuis hier 20h :
Mon domaine www.fleuryk.tk ne fonctionne plus. Sous Firefox il me met adresse introuvable.

J'ai regardé sur le site ou j'ai commandé ce domaine, il n'a pas été supprimé et les DNS sont bons.

J'ai regardé sur l'espace client de Kimsufi si ou cas ou mon serveur est passé en anti-hack mais non. RAS de ce côté.

Et d'après ce site : http://dnslookup.fr/www.fleuryk.tk, il m'indique qu'il ne peut pas résoudre myserv.fleuryk.tk.

Donc je pense qu'il y a un problème de liaison (de communication) entre mon domaine et mon serveur. Et le plus bizarre c'est que je n'ai rien touché à mes fichiers bind sauf pour mail-tester je sais pas pourquoi je suis retombé à 8/10 et mail-tester m'a indiqué qu'il fallait mettre "v=spf1 a mx ip4:151.80.46.90 ~all" afin que j'ai à nouveau 10/10 (ou 9/10).

Est-ce que c'est ce code qui m'a fait foirer ou c'est autre chose (DNS ?) ?

Cordialement.