OVH Community, your new community space.

Comment activer ipv6 ?


Johny2
06/11/2015, 18h41
Bonjour,

j'ai un serveur kimsufi (FreeBSD 10.2). J'aimerais activer ipv6 afin que le site web hébergé dessus soit accessible en ipv6.
J'ai essayé de suivre le guide suivant: http://guide.ovh.com/Ipv4Ipv6 mais les instructions ne semblent pas à jour.

Lorsque je tape `ifconfig`, il semble bien qu'une adresse ipv6 soit déjà associée à mon interface (em0):

Code:
em0: flags=8843 metric 0 mtu 1500
options=4219b
ether 01:23:45:67:89:ab
inet 12.34.156.78 netmask 0xffffff00 broadcast 12.34.56.255 
inet6 fe80::123:4567:89ab:cdef%em0 prefixlen 64 scopeid 0x1 
inet6 2001:1234:a:1234::1 prefixlen 128 
nd6 options=23
media: Ethernet autoselect (100baseTX )
status: active
(j'ai édité les adresses ethernet/ip pour éviter de les divulguer sur le forum)

J'ai bien effectué les deux premières étapes: modifier /etc/sysctl.conf pour fixer "net.inet6.ip6.accept_rtadv=1", puis relancer

Code:
/etc/rc.d/sysctl restart
/etc/rc.conf semblait lui déjà préconfiguré avec les infos relatives à ipv6.

Code:
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
local_unbound_enable=yes
ifconfig_em0="inet 12.34.156.78 netmask 255.255.255.0 broadcast 12.34.56.255"
defaultrouter="12.34.56.254"

# IPv6 configuration
ipv6_enable="YES"
ipv6_network_interfaces="em0"
ifconfig_em0_ipv6="inet6 2001:1234:a:1234::1 prefixlen 128"
ipv6_static_routes="ovhgw"
ipv6_route_ovhgw="2001:1234:A:26ff:ff:ff:ff:ff -prefixlen 128 -interface em0"
ipv6_defaultrouter="2001:1234:A:26ff:ff:ff:ff:ff"
hostname="xxxxxxxx.ip-65-43-21.eu"
(encore une fois, adresses éditées pour éviter de les divulguer sur le forum)
Remarque: je n'ai pas encore associé de nom de domaine à mon serveur donc j'utilise le nom de domaine du style "xxxxxxxx.ip-65-43-21.eu" fourni par ovh pour l'instant.

Parcontre, à l'étape

Code:
/etc/rc.d/network_ipv6 restart
ça ne fonctionne plus car il n'y a pas de fichier network_ipv6 dans /etc/rc.d

Merci pour votre aide.