OVH Community, your new community space.

Reverse DNS


nowwhat
19/11/2015, 21h41
Citation Envoyé par DeeJay
....
Apparemment toujours un soucis de NS quand je check le lien que tu as donné (http://www.dnsinspect.com/insidebox.tk)
Mais ca semble déjà mieux que les résultats que j'avais hier
Pas de soucis, les petites manquant sont bénin.
De toute façon 'dnsinspect' explique bien ce qu'il te reste à faire

DeeJay
19/11/2015, 17h00
Bonjour nowwhat et merci pour ta réponse

J'ai donc modifié les fichiers comme ceci:

151.80.38.148.in-addr.arpa :
Code:
$TTL 12H
@          IN              SOA             ns3003176.ip-151-80-38.eu. postmaster.insidebox.tk. (
           2015111902      ; Serial
           8H              ; Refresh
           30M             ; Retry
           4W              ; Expire
           8H              ; Minimum TTL
)
           IN NS   ns3003176.ip-151-80-38.eu.
           IN NS   ns.kimsufi.com.
           IN PTR  insidebox.tk.
db.insidebox.tk :
Code:
$TTL 12H
$ORIGIN insidebox.tk.
@          IN              SOA             ns3003176.ip-151-80-38.eu. postmaster.insidebox.tk. (
           2015111902      ; Serial
           8H              ; Refresh
           30M             ; Retry
           4W              ; Expire
           8H              ; Minimum TTL
)
               IN              NS              ns3003176.ip-151-80-38.eu.
               IN              NS              ns.kimsufi.com.
               IN              MX      10      mail.insidebox.tk.
insidebox.tk.  IN              A               151.80.38.148
ns             IN              A               151.80.38.148
mail           IN              A               151.80.38.148
roubaix        IN              A               151.80.38.148
www            IN              CNAME           insidebox.tk.
ftp            IN              CNAME           insidebox.tk.
ownercheck     IN              TXT             "xxxxxxxx"

named.conf.local :
Code:
//
// Do any local configuration here
//

// Consider adding the 1918 zones here, if they are not used in your
// organization
//include "/etc/bind/zones.rfc1918";

zone "insidebox.tk" {
  type master;
  file "/etc/bind/zones/db.insidebox.tk";
  allow-transfer {213.186.33.199; };
  notify-source 151.80.38.148;
  notify yes;
};

zone "151.80.38.148.in-addr.arpa" {
  type master;
  file "/etc/bind/zones/151.80.38.148.in-addr.arpa";
  allow-transfer {213.186.33.199; };
  notify-source 151.80.38.148;
  notify yes;
};
Résultat de la commande named-checkconf -z :
Code:
zone insidebox.tk/IN: loaded serial 2015111902
zone 151.80.38.148.in-addr.arpa/IN: loaded serial 2015111902
Résultat de la commande dig insidebox.tk +nssearch :
Code:
SOA ns3003176.ip-151-80-38.eu. postmaster.insidebox.tk. 2015111902 28800 1800 2419200 28800 from server 151.80.38.148 in 0 ms.
SOA ns3003176.ip-151-80-38.eu. postmaster.insidebox.tk. 2015111902 28800 1800 2419200 28800 from server 213.186.33.199 in 2 ms.
SOA ns3003176.ip-151-80-38.eu. postmaster.insidebox.tk. 2015111902 28800 1800 2419200 28800 from server 2001:41d0:3:1c7::1 in 7 ms.
Contenu du fichier /etc/hostname :
Code:
roubaix.insidebox.tk
Contenu du fichier /etc/hosts :
Code:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
151.80.38.148           roubaix.insidebox.tk    insidebox
2001:41d0:e:0b94::1     roubaix.insidebox.tk    insidebox

# The following lines are desirable for IPv6 capable hosts
#(added automatically by netbase upgrade)

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
Chez le registrar de mon nom de domaine, les nameservers sont:
Code:
ns3003176.ip-151-80-38.eu
ns.kimsufi.com
Dans le manager kimsufi (onglet DNS), j'ai bien ajouté insidebox.tk et l'IP à ns.kimsufi.com

Apparemment toujours un soucis de NS quand je check le lien que tu as donné (http://www.dnsinspect.com/insidebox.tk)
Mais ca semble déjà mieux que les résultats que j'avais hier

nowwhat
19/11/2015, 08h41
Ça:
Code:
.....
@          IN              SOA             roubaix.insidebox.tk. postmaster.insidebox.tk. (
.....
               IN              NS              roubaix.insidebox.tk.
               IN              NS              ns.kimsufi.com.
.....
insidebox.tk.  IN              A               151.80.38.148

roubaix        IN              A               151.80.38.148
sachant que ton dopmaine est "insidebox.tk", ça ne va pas le faire.
SAUF si t'as préparé des glue-record (chez ton registrar).

Je te conseille d'utiliser
ns3003176.ip-151-80-38.eu
et
ns.kimsufi.com
comme des noms pour tes serveurs DNS.
Pourquoi ?

Si moi j'utilise ton nom de domaine (insidebox.tk) mon DNS va demander au super chef DNS de "tk" qui gère "insidebox".
Il y a aura (au minimum) deux réponses:
va voir chez:
ns3003176.ip-151-80-38.eu
ou
ns.kimsufi.com
SI la réponse été :
va voir chez:
insidebox.tk
ou
ns.kimsufi.com
t'as logiquement une sacre erreur .... demander qui est "insidebox.tk" chez "insidebox.tk" ..... ça ne va pas.

C'est d'ailleurs UNE des raisons pourquoi OVH te livre un nom de domaine pour ton serveur (ns3003176.ip-151-80-38.eu) qui est résolué (DNS) en dehors de ton serveur (c'est OVH qui s'occupe de la zone ip-151-80-38.eu) - ton serveur y est ajouté dès sa construction).

Donc:
Modifié ton fichier:
Code:
$TTL 12H
$ORIGIN insidebox.tk.
@          IN              SOA             ns3003176.ip-151-80-38.eu. postmaster.insidebox.tk. (
           2015111901      ; Serial
           8H              ; Refresh
           30M             ; Retry
           4W              ; Expire
           8H              ; Minimum TTL
)
               IN              NS              ns3003176.ip-151-80-38.eu.
               IN              NS              ns.kimsufi.com.
               IN              MX      10      mail.insidebox.tk.
insidebox.tk.  IN              A               151.80.38.148
ns             IN              A               151.80.38.148
mail           IN              A               151.80.38.148
roubaix        IN              A               151.80.38.148
www            IN              CNAME           insidebox.tk.
ftp            IN              CNAME           insidebox.tk.
ownercheck     IN              TXT             "xxxxxxxx"
Ajoute (change) à named.conf.local

Code:
zone "insidebox.tk" {
        type master;
        file "/etc/bind/zones/db.insidebox.tk";
        allow-transfer { 213.186.33.199; };
        notify-source 151.80.38.148;
        notify yes;
};

Un test de cohérence sur mon serveur donne :
Code:
named-checkconf -z
...
zone insidebox.tk/IN: loaded serial 2015111901
....
Test aussi comme ça:
Code:
root@ns311465:/etc/bind# dig @ns3003176.ip-151-80-38.eu insidebox.tk ANY +short
roubaix.insidebox.tk. postmaster.insidebox.tk. 2015111806 28800 1800 2419200 28800
ns.kimsufi.com.
roubaix.insidebox.tk.
10 mail.insidebox.tk.
151.80.38.148
Si localement, ton serveur DNS à l'air bien paramétré - redémarre-le.
Puis refait le test avec dig.

A ce stade, pas nécessaire de tester ns.kimsufi.com, car il ne sera probablement pas encore synchronisé avec ton serveur maître, le ns3003176.ip-151-80-38.eu ou : ton serveur.
Le sync venant de ns.kimsufi.com est très lent ...... n'insiste pas, in ne passe, si nécessaire, que deux fois par jour, voir moins. C'est comme ça chez OVH.

Puis, si t'as pas d'erreur, change la zone dans le Manager de ton Regsitrar (OVH) pour que t'as DEUX serveurs DNS:
ns3003176.ip-151-80-38.eu
et
ns.kimsufi.com

Plus tard, ceci:
dig @ns.kimsufi.com insidebox.tk ANY +short
doit donner la même réponse que
dig @ns3003176.ip-151-80-38.eu insidebox.tk ANY +short

Il est possible de savoir quand le serveur DNS esclave 'passe' chez ton serveur pour synchroniser:
Fouille dans le logs de 'bind', et tu trouveras après le moment que t'as démarré bind:
(ces logs sont important - on peut voir si coté DNS tout va bien - car sinon ... ton domaine pourrait disparaître (plus visible car plus résolu) de l'Internet ...)

Code:
xx-xxxx-2015 hh:yy:ww.421 xfer-out: client 213.186.33.199#33324 (insidebox.tk): transfer of 'nsidebox.tk/IN': AXFR-style IXFR started
xx-xxxx-2015 hh:yy:ww.422 xfer-out: client 213.186.33.199#33324 (insidebox.tk): transfer of 'nsidebox.tk/IN': AXFR-style IXFR ended
Pour que 'bind' ce ganre des détails, j'ai édité named.conf.options et j'ai ajouté ceci:

Code:
logging {
        channel "debug" {
                file "/var/log/bind9/debug.log" versions 10 size 5m;
                print-time yes;
                print-category yes;
                severity dynamic;
        };
        category "default" { "debug"; };
        category "database" { "debug"; };
        category "security" { "debug"; };
        category "config" { "debug"; };
        category "resolver" { "debug"; };
        category "xfer-in" { "debug"; };
        category "xfer-out" { "debug"; };
        category "notify" { "debug"; };
        category "client" { "debug"; };
        category "unmatched" { "debug"; };
        category "network" { "debug"; };
        category "update" { "debug"; };
        category "dispatch" { "debug"; };
        category "dnssec" { "debug"; };
        category "lame-servers" { null; };

        channel "general" {
                file "/var/log/bind9/general.log" versions 10 size 5m;
                print-time yes;
                print-category yes;
                severity dynamic;
        };
        category "general" { "general"; };

        channel b_query {
                file "/var/log/bind9/query.log" versions 10 size 5m;
                print-time yes;
                print-category yes;
                severity dynamic;
        };
        category "queries" { "b_query"; };
};
ATTENTION : j'utilise des chemins comme /var/log/bind9/ - ce répertoire DOIT exister (sinon, change-les) et .... le processus bind (il tourne avec l’indenté 'named') doit avoir le droit d'écrire dedans !!

Je pense que t'as du comprendre aussi qu'il faut aussi visiter le Manager de TON SERVEUR, le ns3003176.ip-151-80-38.eu
Dans la partie DNS secondaire, il faut ajouter "insidebox.tk" et son (futur) IP "151.80.38.148" à "ns.kimsufi.com".
Logique, car comment ns.kimsufi.com saura qu'il faut qu'il joue le DNS secondaire pour "151.80.38.148" sinon ?
Mais normalement, t'as du déjà du faire ça.



PS ceci:
Code:
;
; BIND data file for v*y*ll*-co.fr
;
$TTL    3h
v*y*ll*-co.fr. IN SOA ns1.v*y*ll*-co.fr. postmaster.v*y*ll*-co.fr. (
        2015100308; Serial
        3h ; Refresh
        60m ; Retry
        2w ; Expire
        3h ) ; Negative Cache TTL
;
  IN NS ns1.v*y*ll*-co.fr.
  IN NS ns3.v*y*ll*-co.fr.
  IN NS ns4.v*y*ll*-co.fr.
  IN NS ns5.v*y*ll*-co.fr.
T'as vu ? Plus de trace de ns3003176.ip-151-xx-yy.eu ni ns.kimsufi.com etc.
Il faut paramétrer les records glue, une possibilité qui doit être présent dans le manager de ton Domaine (OVH, ou pas).....


PS2 : Passe par ici http://www.dnsinspect.com pour tester ton domaine !!!
Je t'invite à inspecter test-domaine.fr, un des mes domaines - tu découvre que
1) il ne faut pas oublier le IPv6 (le IPv4 est quasiment mort .....)
2) il ne faut pas croire qu'il faut s'arrêter avec qu'UN serveur DNS escalve - prends-en 3 !!!! c'est gratuit, plus sur, très formateur, etc.
3) les reverses de tout ça doit être Ok !
4) plein d'autre truc encore.
va pour le "A" et surtout pas moins.

DeeJay
18/11/2015, 23h36
Toujours entrain d'essayer de résoudre cela..

Pour ne plus avoir cet erreur, il suffit d'ajouter au fichier 151.80.38.148.in-addr.arpa
Code:
           IN A  151.80.38.148
Mais cela en engendre une autre donc j'imagine que ce n'est pas non plus la solution..

J'ai fais un tas de modif et à chaque fois je suis confronté à un nouveau problème

DeeJay
18/11/2015, 14h14
En ayant modifié la ligne par:
Code:
           IN NS   roubaix.insidebox.tk.
J'obtiens maintenant une erreur en utilisant la commande named-checkzone insidebox.tk 151.80.38.148.in-addr.arpa
Code:
zone insidebox.tk/IN: NS 'roubaix.insidebox.tk' has no address records (A or AAAA)
zone insidebox.tk/IN: not loaded due to errors.
Voici maintenant le contenu du fichier db.insidebox.tk :
Code:
$TTL 12H
$ORIGIN insidebox.tk.
@          IN              SOA             roubaix.insidebox.tk. postmaster.insidebox.tk. (
           2015111803      ; Serial
           8H              ; Refresh
           30M             ; Retry
           4W              ; Expire
           8H              ; Minimum TTL
)
               IN              NS              roubaix.insidebox.tk.
               IN              NS              ns.kimsufi.com.
               IN              MX      10      mail.insidebox.tk.
insidebox.tk.  IN              A               151.80.38.148
ns             IN              A               151.80.38.148
mail           IN              A               151.80.38.148
roubaix        IN              A               151.80.38.148
www            IN              CNAME           insidebox.tk.
ftp            IN              CNAME           insidebox.tk.
ownercheck     IN              TXT             "xxxxxxxx"
Et celui de 151.80.38.148.in-addr.arpa :
Code:
$TTL 12H
@          IN              SOA             roubaix.insidebox.tk. postmaster.insidebox.tk. (
           2015111803      ; Serial
           8H              ; Refresh
           30M             ; Retry
           4W              ; Expire
           8H              ; Minimum TTL
)
           IN NS   roubaix.insidebox.tk.
           IN NS   ns.kimsufi.com.
           IN PTR  insidebox.tk.

BBR
18/11/2015, 14h05
as-tu bien incrémenté ton serial (sans en changer la date) ?
oui ns300etc ne devrait plus apparaitre nulle part

DeeJay
18/11/2015, 13h31
Oui effectivement concernant la date c'est un erreur, j'ai sauté un jour..

Ok donc maintenant roubaix.insidebox.tk renvoi bien sur 151.80.38.148 et inversement.

Par contre j'ai toujours l'erreur ici:
Code:
nslookup 151.80.38.148 roubaix.insidebox.tk
Server:         roubaix.insidebox.tk
Address:        2001:41d0:e:b94::1#53

** server can't find 148.38.80.151.in-addr.arpa: REFUSED
J'ai bien redémarré bind

Edit1: en regardant la config de 151.80.38.148.in-addr.arpa au dessus, ne suis-je pas censé également modifier cette ligne:
Code:
          IN NS   ns3003176.ip-151-80-38.eu.
Par:
Code:
          IN NS   roubaix.insidebox.tk.
?

Edit2: Je l'ai modifié mais toujours le même problème

BBR
18/11/2015, 13h08
avec un serial donnant une date dans le futur la mise à jour de ta zone ne sera prise en compte qu'au delà de cette date :
Code:
2015111902      ; Serial
soit le 19/11/2015 pourquoi as-tu mis le 19 ?
et ceci :
Code:
IN              SOA             ns3003176.ip-151-80-38.eu.
devrait plutot être comme ceci si ton nom de serveur n'est plus ns3003176.ip-151-80-38.eu
Code:
IN              SOA             roubaix.insidebox.tk

DeeJay
18/11/2015, 12h28
Comme j'aime bien chipoter et que j'aimerais résoudre ce problème je persévère..

J'ai cependant un problème :

Code:
nslookup insidebox.tk. ns3003176.ip-151-80-38.eu
Server:         ns3003176.ip-151-80-38.eu
Address:        151.80.38.148#53

Name:   insidebox.tk
Address: 151.80.38.148
Par contre à l'inverse:

Code:
nslookup 151.80.38.148 ns3003176.ip-151-80-38.eu
Server:         insidebox.tk
Address:        151.80.38.148#53

** server can't find 148.38.80.151.in-addr.arpa: REFUSED
Voici le contenu du fichier db.insidebox.tk :

Code:
$TTL 12H
$ORIGIN insidebox.tk.
@          IN              SOA             ns3003176.ip-151-80-38.eu. postmaster.insidebox.tk. (
           2015111902      ; Serial
           8H              ; Refresh
           30M             ; Retry
           4W              ; Expire
           8H              ; Minimum TTL
)
               IN              NS              ns3003176.ip-151-80-38.eu.
               IN              NS              ns.kimsufi.com.
               IN              MX      10      mail.insidebox.tk.
insidebox.tk.  IN              A               151.80.38.148
ns             IN              A               151.80.38.148
mail           IN              A               151.80.38.148
roubaix        IN              A               151.80.38.148
www            IN              CNAME           insidebox.tk.
ftp            IN              CNAME           insidebox.tk.
ownercheck     IN              TXT             "xxxxxxxx"
et celui de 151.80.38.148.in-addr.arpa :

Code:
$TTL 12H
@          IN              SOA             ns3003176.ip-151-80-38.eu. postmaster.insidebox.tk. (
           2015111902      ; Serial
           8H              ; Refresh
           30M             ; Retry
           4W              ; Expire
           8H              ; Minimum TTL
)
           IN NS   ns3003176.ip-151-80-38.eu.
           IN NS   ns.kimsufi.com.
           IN PTR  insidebox.tk.
Merci

Edit: à ce stade je suis déjà censé avoir indiqué le reverse de l'IP dans le manager kimsufi ou peu importe ?
Edit2: je re précise que j'ai déjà modifié /etc/hostname et /etc/hosts pour correspondre à roubaix.insidebox.tk

BBR
17/11/2015, 15h40
ton tuto c'est juste pour mettre un reverse, mais il faut faire tout le reste

DeeJay
17/11/2015, 14h48
Tout ca m'a l'air vraiment très compliqué comparé au lien du tuto de mon premier poste.

Je vais laisser tomber, merci quand même pour tes réponses.

BBR
17/11/2015, 14h38
tu mélanges un peu tout
Soit c'est le registar de ton nom de domaine qui gère la zone dns dans ce cas sur la zone de ce registar tu dois au moins mettre l'ip de ton serveur en champ A (regarde ce tuto et adapte à ton registrar http://www.how-to.ovh/viewtopic.php?f=21&t=2 )
si ce n'est pas le registar mais le serveur qui gère les dns tu dois créer les zones, et toute la config
Comment as-tu ajouté le domaine sur ton serveur ?
Les modifs que tu as faites sur le manager kimsufi ne servent que si c'est ton serveur qui gère la zone

DeeJay
17/11/2015, 14h27
Pour l'instant, tout ce que j'ai fais est précisé au dessus

D'après le tuto que j'ai suivi il ne parle pas de changer les "nameserver" donc je suppose que de cette façon, c'est le registar qui les gère.

freenom est apparemment le nom qu’utilise les domaine dot.tk

Citation Envoyé par BBR
as-tu modifié la zone dns (bind) puis relancé ?
Excuse moi mais ou et comment faire cela ?

PS: Je précise que j'ai suivi le tuto indiqué sur mon premier poste à la lettre, tout ce qui y figure (y compris les changement dans /etc/hosts ainsi que /etc/hostname ont été fait

BBR
17/11/2015, 14h11
Tu gères les DNS sur ton serveur ou c'est le registrar du nom de domaine qui le fait ?

BBR
17/11/2015, 14h06
modifs à faire dans :
/etc/hosts
/etc/hostname
et tu relances
/etc/init.d/hostname.sh start
as-tu modifié la zone dns (bind) puis relancé ?
Code:
 ; <<>> DiG 9 <<>> @localhost insidebox.tk ANY
 ; (1 server found)
 ;; global options: +cmd
 ;; Got answer:
 ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 15848
 ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 0
 
 ;; QUESTION SECTION:
 ;insidebox.tk.			IN	ANY
 
 ;; ANSWER SECTION:
 insidebox.tk.		253	IN	SOA	ns01.freenom.com. soa.freenom.com. 1447761890 10800 3600 604800 3600
 insidebox.tk.		253	IN	NS	ns01.freenom.com.
 insidebox.tk.		253	IN	NS	ns04.freenom.com.
 insidebox.tk.		253	IN	NS	ns03.freenom.com.
 insidebox.tk.		253	IN	NS	ns02.freenom.com.
le soa devrait être ton reverse, le serial devrait être sous cette forme AAAMMJJnn par exemple 2015111701
qui est ce freenom.com ?

DeeJay
17/11/2015, 13h25
Bonjour à tous,

Ceci fera un poste de plus concernant ce sujet (car oui, j'ai utilisé la fonction "recherche" et j'en ai vu un paquet déjà) cependant j'avoue que je suis un peu perdu et mes connaissances sont assez maigre en la matière.

Je possède un kimsufi depuis quelques jours et j'ai un domaine .tk
Afin que le poste soit le plus clair possible, je vous donne directement les info:

Mon domaine: insidebox.tk
Kimsufi: ns3003176.ip-151-80-38.eu
OS: Debian 7.5 64b
Nom du serveur que je souhaites: roubaix.insidebox.tk
Objetctif: que l'IP de mon serveur renvoi sur roubaix.insidebox.tk et inversement

Ce que j'ai fais jusqu'à présent:

J'ai suivit ce tuto: https://guides-serveur.ovh/comment-c...rveur-kimsufi/
Via le manager de dot.tk j'ai donc ajouté un champ A avec le nom de mon serveur (roubaix.insidebox.tk) qui renvoi vers son adresse IP
J'ai également edité les fichiers /etc/hostname ainsi que /etc/hosts pour correspondre au nom de mon serveur.

Cependant je me suis rendu compte que dans le manager kimsufi, pour pouvoir ajouter le reverse sous l'onglet "IP" je devais au préalable ajouter le domaine sous l'onglet "DNS", pour cela j'ai donc du ajouter un champ TXT avec ownercheck et le code dans le manager du registar dot.tk, ce que j'ai fais.

Après cela, j'ai pu ajouter le reverse sous l'onglet IP par le nom de serveur

Situation actuelle:

Quand je fais un /dns sur roubaix.insidebox.tk, il me renvoi bien vers l'IP de mon serveur, à l'inverse l'IP de mon serveur me renvoi toujours vers ns3003176.ip-151-80-38.eu

Dans mon manager kimsufi, le reverse indiqué est bien roubaix.insidebox.tk

Merci d'avance pour votre aide