OVH Community, your new community space.

Probleme de configuration DNS avec domaine chez nfrance


arnaud1974
11/01/2016, 13h56
Justement le MX je le défini comment ?

J'ai modifié le fichier de configuration de bond en ajoutant à la fin
meluzine.org. IN MX 5 mta-gw.infomaniak.ch.

Car oui pour faire simple le serveur de mail est chez infomaniak

Voici le contenu de mon fichier
$TTL 1800
meluzine.org. IN SOA ns377604.ip-37-59-40.eu. hostmaster.meluzine.org. (
2016011110 ; serial à changer à chaque modification
1800 ; refresh, 30mn
3600 ; retry, 1h
1209600 ; expire
86400 ) ; negative cache, 24h
meluzine.org. IN NS ns377604.ip-37-59-40.eu.
meluzine.org. IN NS ns.kimsufi.com.
meluzine.org. IN A 37.59.40.89
www IN A 37.59.40.89
IN MX 5 mta-gw.infomaniak.ch

@ IN A 37.59.40.89
; verif DNS secondaire kimsufi
ownercheck IN TXT "d5417d7c"
;
;mail IN A 37.59.40.89
;meluzine.org. IN A 37.59.40.89


Citation Envoyé par nowwhat
Comme il a dit, et c'est le cas :
Pas de MX déclaré => pas de mail (géré par le serveur).
C'est un vague quand même :

Ça va commencer avec un:
1) Ajouter un champs MX au zone DNS (éventuellement un sous domaine mail.meluzine.org. ou pas : meluzine.org.)
2) Paramétrer un serveur mail comme postfix ....
3) Faire pas mal (voir énormément) des tests avant d'utiliser (envoyer avec) des mails ... (sinon pas bon ...)

nowwhat
11/01/2016, 13h40
Citation Envoyé par BBR
ça ne résoudra pas le fait que son serveur n'a pas de serveur mail...
Comme il a dit, et c'est le cas :
Pas de MX déclaré => pas de mail (géré par le serveur).
C'est un vague quand même :
j'ai loupé les mails...
J'ai cru comprendre qu'il fallait configurer un MX....
Ça va commencer avec un:
1) Ajouter un champs MX au zone DNS (éventuellement un sous domaine mail.meluzine.org. ou pas : meluzine.org.)
2) Paramétrer un serveur mail comme postfix ....
3) Faire pas mal (voir énormément) des tests avant d'utiliser (envoyer avec) des mails ... (sinon pas bon ...)

BBR
11/01/2016, 13h06
ça ne résoudra pas le fait que son serveur n'a pas de serveur mail...

nowwhat
11/01/2016, 12h45
Citation Envoyé par arnaud1974
....
Je revenais pour ne pas créer de nouveau sujet mais visiblement j'ai loupé les mails...
J'ai cru comprendre qu'il fallait configurer un MX....
Plus précisément ?
Quelles mails ?

Ah, ça (peut être) :
Hostmaster (e-mail): hostmaster.meluzine.org.
( venant de http://www.dnsinspect.com ).
C'est effecivement pas très beau ça:
Dire dans le SOA qu'on puis contacter hostmaster @ meluzine.org (pour tout soucis lié a ce domaine)
or
t'as aucun serveur mail qui travaille pour "meluzine.org" (il te manque le MX - et probablement tout le paramétrage d'un serveur mail derrière ...) donc l'adresse hostmaster at meluzine.org n'existe même pas.....

Solution : change "hostmaster.meluzine.org." pour un mail qui existe vraiment, genre 'ton-mail-chez-gmail.gmail.com."
(change le serial dans le SOA (2015120607 => 20160101101) puis redémarre bind.

arnaud1974
11/01/2016, 12h00
Bonjour à tous,

Je revenais pour ne pas créer de nouveau sujet mais visiblement j'ai loupé les mails...
J'ai cru comprendre qu'il fallait configurer un MX....

nowwhat
07/12/2015, 12h18
Citation Envoyé par BBR
....
puis
Code:
ln -s /etc/apache2/sites-available/meluzine.org /etc/apache2/sites-enabled/meluzine.org
plus moderne :
a2ensite meluzine.org
puis redémarre apache2

BBR
07/12/2015, 10h37
profites-en aussi pour mettre un .htaccess à la racine pour éviter le duplicate content que google n'aime pas
Code:
RewriteEngine on
RewriteCond %{HTTP_HOST} ^meluzine\.org$ [NC]
RewriteRule ^(.*) http://www.meluzine.org/$1 [QSA,L,R=301]

BBR
07/12/2015, 10h34
oui sauf que... si on ne met pas les www on arrive sur la page d'apache its works
as-tu ceci sur ton virtualhost ?
Code:
ServerName www.meluzine.org
ServerAlias meluzine.org *.meluzine.org

arnaud1974
07/12/2015, 10h26
Merci BBR visiblement je manquais encore un peut de patience pour les DNS.

Merci beaucoup mon problème est résolu et j'en est profité pour inverser les 2 DNS comme tu me le indiquais

BBR
05/12/2015, 08h22
dans /etc/apache2/sites-available/meluzine.org.conf
tu devrais avoir ce fichier avec quelque chose de ce style (à adapter) :
Code:

        ServerAdmin postmaster@meluzine.org
        ServerName www.meluzine.org
        ServerAlias meluzine.org *.meluzine.org
        DocumentRoot /home/meluzine/public_html/
        
                Options -Indexes FollowSymLinks MultiViews
                AllowOverride All
        
        ErrorLog /home/meluzine/logs/error.log
        LogLevel warn
        CustomLog /home/meluzine/logs/access.log combined
        ServerSignature Off
puis
Code:
ln -s /etc/apache2/sites-available/meluzine.org /etc/apache2/sites-enabled/meluzine.org
Code:
/etc/init.d/apache2 restart

BBR
05/12/2015, 08h10
déjà là c'est le contraire
DNS 1 : ns.kimsufi.com
DNS 2 : ns377604.ip-37-59-40.eu
le dns1 c'est ton serveur

meluzine.org. IN NS ns377604.ip-37-59-40.eu.
meluzine.org. IN NS ns.kimsufi.com.
inutile

ton site est accessible, du moins on arrive sur "It's work"
tu as paramétré ton virtualhost apache ?

arnaud1974
05/12/2015, 07h43
Bonjour à tous,

Après une soirée à arracher mes quelques cheveux je n'arrive toujours pas à configurer les DNS pour qu'ils pointent sur mon kimsufi.

J'ai un domaine meluzine.org qui est géré par nfrance, dans la zone d'administration j'ai mis comme DNS les informations suivantes :
DNS 1 : ns.kimsufi.com
DNS 2 : ns377604.ip-37-59-40.eu

Coter kimsufi
J'ai le db.meluzine.org
$TTL 1800
meluzine.org. IN SOA ns377604.ip-37-59-40.eu. hostmaster.meluzine.org. (
2015120607 ; serial à changer à chaque modification
1800 ; refresh, 30mn
3600 ; retry, 1h
1209600 ; expire
86400 ) ; negative cache, 24h
meluzine.org. IN NS ns377604.ip-37-59-40.eu.
meluzine.org. IN NS ns.kimsufi.com.
meluzine.org. IN A 37.59.40.89
www IN A 37.59.40.89
; verif DNS secondaire kimsufi
ownercheck.meluzine.org. IN TXT "XXXXXXXX"
;
;mail IN A 37.59.40.89
;meluzine.org. IN A 37.59.40.89
;meluzine.org. IN MX 10 meluzine.org.

J'ai réussi à ajouter le DNS secondaire, mais malgré tous je ne me connecte toujours pas à mon site.

Le named.con.local
zone "meluzine.org" IN {

# Zone de type maître
type master;

# Fichier de zone
file "/etc/bind/db.meluzine.org";

# On autorise le transfert de la zone aux serveurs DNS secondaires
allow-transfer { 213.186.33.199; };

# On autorise tout le monde à envoyer des requêtes vers cette zone
allow-query { any; };

# Prévenir les serveurs DNS secondaires qu'un changement a été effectué dans la zone maître
notify yes;
};

Le named.conf.option
options {
directory "/var/cache/bind";

# Activer DNSSEC
dnssec-enable yes;
dnssec-validation auto;
auth-nxdomain no; # RFC1035

listen-on { any; };
listen-on-v6 { any; };

# Autoriser les requêtes récursives locales uniquement
allow-recursion { 127.0.0.1; ::1; };

# Ne pas transférer les informations des zones aux DNS secondaires
allow-transfer { none; };

# Ne pas autoriser la mise à jour des zones maîtres
allow-update { none; };

version none;
hostname none;
server-id none;
};

Et j'ai laisser les autres fichiers dans leur état d'origine.

Quesque j'ai pu louper ?

Merci d'avance.