OVH Community, your new community space.

[UBUNTU 15.10 - POSTFIX]Recipient address rejected Access denied


Nixtis
07/12/2015, 17h51
Salut à tous !

Je me suis pris 2 serveurs chez Kimsufi, un pour mon site et un pour mes mails, sauf que je ne m'attendais pas à ce que configurer un serveur mail soit aussi complexe (à la base je suis dev). Du coup après 3 jours de galère voilà où j'en suis :

J'ai installé postfix, courier-imap et procmail. mes tests depuis mon serveur sont plutôt bons :

Voilà ma config postfix (main.cf) :
Code:
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no
append_dot_mydomain = no
delay_warning_time = 4h
readme_directory = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
myhostname = nsXXXXXX.ip-XX-XX-XX.eu
mydomain = mondomaine.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = mondomaine.com, smtp.mondomaine.com, nsXXXXXX.ip-XX-XX-XX.eu, localhost.ip-XX-XX-XX.eu, localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_size_limit = 5120000000
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
mailbox_command = /usr/bin/procmail -a "$EXTENSION" DEFAULT=$HOME/Maildir/ MAILDIR=$HOME/Maildir
home_mailbox = Maildir/
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_path = smtpd
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_reject_unlisted_recipient = no
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 2
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
setgid_group = postdrop
mail_owner = postfix
mail_spool_directory = /var/spool/mail
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
program_directory = /usr/lib/postfix
queue_directory = /var/spool/postfix
Mon telnet (qui pose probleme par contre) :

Code:
telnet smtp.mondomaine.com 25
Trying XX.XX.XX.XX...
Connected to smtp.mondomaine.com.
Escape character is '^]'.
220 nsXXXXXX.ip-XX-XX-XX.eu ESMTP Postfix (Ubuntu)
ehlo mondomaine.com
250-nsXXXXXX.ip-XX-XX-XX.eu
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
MAIL FROM:
250 2.1.0 Ok
RCPT TO:
554 5.7.1 : Recipient address rejected: Access denied
ça fonctionne si je m'authentifie avec AUTH LOGIN :

Code:
telnet smtp.mondomaine.com 25
Trying XX.XX.XX.XX...
Connected to smtp.mondomaine.com.
Escape character is '^]'.
220 nsXXXXXX.ip-XX-XX-XX.eu ESMTP Postfix (Ubuntu)
ehlo mondomaine.com
250-nsXXXXXX.ip-XX-XX-XX.eu
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
AUTH LOGIN
334 VXNlcm5hbWU6
nomutilisateurenbase64
334 UGFzc3dvcmQ6
motdepasseenbase64
235 2.7.0 Authentication successful
MAIL FROM:
250 2.1.0 Ok
RCPT TO:
250 2.1.5 Ok
quit
221 2.0.0 Bye
Connection closed by foreign host.
Je ne comprends pas, il faudrait que les gens qui m'envoient des mails soient authentifiées à mon SMTP ? lol

Et quand je teste ma connexion sasl :

Code:
testsaslauthd -u mon.compte -p monmotdepasse
0: OK "Success
Une autre chose très étrange, lorsque je j'ajoute mon compte mails sur mon iPhone 6 ou sur mon Macbook (application mail) je parviens à récupérer mes mails (ceux que je me suis envoyé en local depuis le serveur avec la commande "mail"), j'arrive aussi à envoyer des mails sur d'autres boites comme gmail, par contre impossible de m'envoyer à moi-même un mail ni depuis l'extérieur vers moi-même... Et autre chose, il me demande bien un login/password pour le serveur IMAP mais pas pour le SMTP... Sur Thunderbird c'est simple il ne parvient même pas à trouver les bons paramétrages pour ajouter mon compte mail...

Pour info ça fait une 10aines de fois que j'essaye plusieurs configs, j'ai aussi essayé Dovecot mais sans succès (ça fonctionne seulement si je fait tout en local depuis le serveur, je reçois bien aussi les mails depuis l'extérieur... Mais impossible d'utiliser un client mail)

Voilà, j'espère que c'est assez clair, honnêtement je commence à saturer...

Merci beaucoup d'avance.