OVH Community, your new community space.

Ports/Firewall


Unknow64
08/12/2015, 15h37
Bonjour,

J'utilise Xubuntu Desktop 14.04 "Trusty Tahr" et je me connecte via X2Go

Grand débutant dans le domaine des serveurs dédiés, j'ai voulu commencer avec une interface, plutôt que de tout faire en

SSH.

Jusque là tout aller bien, j'ai réussi à installer tous ce dont j'avais besoin jusqu’à qu'un problème survienne.

J'ai un serveur KS1, avec deux noms de domaines, j'ai farfouillé sur le web sans vraiment trouver le résultat qu'il me

fallait pour essayer de sortir plusieurs noms de domaines sous la même IP.

Exemple : www.exemple1.com et www.exemple2.com

J'utilise lampp, j'ai donc mis les sites dans le dossier /opt/lampp/lampp/htdocs si je me rappelle bien du chemin "vue

que je n'ai plus accès à mon desktop"

Or, mon problème c'est que j'arrivais à faire marcher un site mais il pointé toujours sur l'IP principale. Je ne pouvais

donc mettre qu'un seul site.

En cherchant sur le net j'ai trouvé des sujets qui proposaient de changer de Ports pour faire pointer les sites dessus
Exemple : xx.xx.xx.xxx.:80 xx.xx.xx.xxx.:8080

J'ai donc tapé plusieurs commandes pour ouvrir par exemple le port 8080 et faire pointer mon deuxième site dessus j'ai

apparemment aussi ouvert le Firewall et je pense que mon problème viens de la..

En gros je voulait que : /opt/lampp/lampp/htdocs/www.exemple1.com pointe sur xx.xx.xx.xxx.:80 pour mon premier site
et
/opt/lampp/lampp/htdocs/www.exemple2.com pointe sur xx.xx.xx.xxx.:8080 pour mon deuxième site

Personnellement, je ne sais même pas si ça aurais pu marché comme ça.


N'ayant pas trouvé la solution, j'ai éteint mon serveur pour reprendre le lendemain or en essayant de me connecter le

lendemain, j’obtiens un Timeout connection to xx.xx.xx.

J'ai contacté le support qui me donne des réponses déjà toutes prêtes, j'ai cherché sur les guides qu'ils m'envois, sans

trouver de réponse à mon problème, je viens donc sur le forum en essayant de trouver une meilleure aide.

Je ne sais pas si il existe une commande mais j'aimerais réinitialiser les Ports et/ou éteindre le Firewall

Voici mon nmap maintenant que je ne peux plus me connecter via x2Go, mais je peux toujours en SSH

Starting Nmap 6.00 ( http://nmap.org ) at 2015-12-07 09:10 EET
Initiating Ping Scan at 09:10
Scanning xx.xxx.xx.xxx [4 ports]
Completed Ping Scan at 09:10, 0.04s elapsed (1 total hosts)
Initiating SYN Stealth Scan at 09:10
Scanning xx.xxx.xx.xxx (xx.xxx.xx.xxx) [100 ports]
Discovered open port 21/tcp on xx.xxx.xx.xxx
Discovered open port 22/tcp on xx.xxx.xx.xxx
Discovered open port 443/tcp on xx.xxx.xx.xxx
Discovered open port 111/tcp on xx.xxx.xx.xxx
Discovered open port 81/tcp on xx.xxx.xx.xxx
Completed SYN Stealth Scan at 09:10, 1.25s elapsed (100 total ports)

[+] Nmap scan report for xx.xxx.xx.xxx (xx.xxx.xx.xxx)
Host is up (0.0088s latency).
Not shown: 94 closed ports

PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
81/tcp open hosts2-ns
111/tcp open rpcbind
443/tcp open https
445/tcp filtered microsoft-ds

Nmap done: 1 IP address (1 host up) scanned in 1.51 seconds
Raw packets sent: 116 (5.080KB) | Rcvd: 104 (4.326KB)

le port 80 est fermé, donc je pense que le problème viens de là, mais je suis perdu..

Cordialement,