OVH Community, your new community space.

Migration R2 -> Debian : Problème d'accent


sim
15/01/2016, 22h20
Suite aux conseils d'un forumeur, j'ai résolu mon problème d'accent pour la base de données.
Il suffisait de rajouter un : mysql_query("SET NAMES 'UTF8'"); après la connexion a la base.


En revanche, lorsque j'ai fais le rsync de gentoo vers debian, j'ai perdu mes accents non encodés dans mes pages (je dis bien DANS mes pages, pas le nom de la page hein...). Du coup les é se sont transformés en carrés. Y a t il moyen de faire un rsync qui ne provoque pas ce bug ? Ou bien est-ce un réglage de putty ?

Merci d'avance pour vos bons conseils.

sim
15/01/2016, 21h31
Salut a tous,

J'ai un dernier souci suite a ma migration de R2 (Gentoo) vers Debian 8 + Virtualmin
Mes accents et caractère spéciaux qui s'affichent bizarrement ...
Alors voilà la situation :
Sur ma R2 je m'étais les accents sans les encoder (pas bien! je sais ! lol).
Le problème se pose essentiellement sur les bases de données.

Est-il possible de faire une modification au niveau d'apache pour que mon affichage se fasse comme sous gentoo, sinon ca va m'obliger a faire du utf8_encode et du utf8_decode partout... dans tous mes scripts, sur tous mes sites.

Un exemple concret :

http://www.emyor.com/ placé sur Debian

http://ns387861.ip-176-31-248.eu/~emyor/ sur mon ancienne distrib : gentoo.

J'ai essayé de modifier php.ini (stocké ici /etc/php5/apache2/php.ini) avec default_charset = "ISO-8859-1", mais je n'ai pas l'impression que ca ait changé quoique ce soit ...

Dans ma base de données l'interclassement était (et est toujours d'ailleurs) : latin1_swedish_ci ; je ne sais pas si ca a son importance ^^

Merci d'avance, d'aider un newbie comme moi

Cordialement,

sim