OVH Community, your new community space.

Problème de mails - KS < > Gmail


nowwhat
09/02/2016, 08h37
Citation Envoyé par MrLLp
.....
• Pour l'explication du reverse dns, j'ai bien trouvé l'option dans mon manager. Mais je me pose une question, on ne peut en choisir qu'un ? Car j'ai plusieurs domaines, qui utilisent chacun des adresse email donc si je mets un reverse dns d'un des me domaines "mail.xxx.be", que se passe t'il pour les autres domaines ?
C'est vrai, plus facile serais "une domaine == un IPv4 et un IPv6" pour que chaque IP possède son propre reverse correctement.
Mais, ce n'est pas si rare que ça que derrière chaque IP il y a plusieurs nom de domaines.
C'est accepté que, quand ton serveur se connecte à un serveur mail à distance pour envoyer un mail, il va dire qu'il s'appelle "mail.xxxx.be" or le reverse de son IP est "mail.yyy.be".
Il suffit de prévoir pour mail.xxxx.be un SPF valide, genre:
xxxx.be. IN SPF "v=spf1 ip4:91.121.76.131 -all"
Coté DKIM il n'y pas de liaison entre 'IP et le nom de domaine.

Dernier problème > arriver à envoyer à partir de ces adresses avec Gmail où je n'arrive pas à configurer le serveur smtp :
Échec de l'authentification. Veuillez vérifier votre nom d'utilisateur/mot de passe.
[Réponse du serveur : 334 PDM5NTY4OTc0NTkuMTIxMTUyNDBAbnMzMDMxOTM5LmlwLTkxLT EyMS03Ni5ldT4= code(334) ]
Ces adresses == quel adresse ?
Envoyer un postmaster@mrsmith.be avec ton compte gmail ? Peut être c'est possible.
Mais bof, j'envoie pas non plus un blablabla@sfr.fr avec mon tuutuut@orange.fr non plus.
Pour info : ton serveur mail (postfix) sur ton serveur va déposer chez gmail un mail qui termine avec "@gmail.com" et il n'a pas besoin de s'authentifier pour faire ça.


Informer postfix pour qu'il n'utilise plus IPv6 : c'est simple :
inet_protocols = ipv4

MrLLp
08/02/2016, 19h26
Bonsoir,

Update :

- J'ai converti toutes mes adresses mails de simple "forward" en "mailbox".
- J'ai quand même réussi à activer DomainKeys via Plesk...
- J'ai mis le reverse DNS comme tu m'a dit 91.121.76.131 >< mail.mrsmith.be (je posais la question dans le post du dessus, quid des autres domaines qui ont aussi des adresses mail ? Ça ne pose pas de souci ?)
- Je dois encore voir pour ne plus utliser l'IPv6 mais ça a l'air d'aller comme ça pour l'instant.

Quand j'envoie via Roundcube, ça marche bien, j'ai 9/10 dans Mail-tester (-1 car blacklisté sur SORBS-SPAM, apparemment un truc de 2013, je n'avais pas encore le serveur)

Dernier problème > arriver à envoyer à partir de ces adresses avec Gmail où je n'arrive pas à configurer le serveur smtp :

Échec de l'authentification. Veuillez vérifier votre nom d'utilisateur/mot de passe.
[Réponse du serveur : 334 PDM5NTY4OTc0NTkuMTIxMTUyNDBAbnMzMDMxOTM5LmlwLTkxLT EyMS03Ni5ldT4= code(334) ]
Tu as une idée de ce que je devrais faire ?

J'ai dis une bêtise dans mon précédent post, j'ai bien tout le fichier /etc/postfix/main.cf, j'avais mal vu ;-) Je suppose que je dois changer des choses là dedans ?

Merci,
Laurent

MrLLp
08/02/2016, 13h57
• En fait j'utilisais le serveur smtp d'OVH car je n'arrivais pas à configurer Gmail pour "Envoyer des e-mails en tant que".
C'est pour ça que j'avais créé un compte mail sur un start10m...

EDIT: je pensais avoir réglé le problème en installant Qmail à la place de Postfix mais malgré que Google ait accepté les paramètres, ça fait encore plus de problèmes... Donc je vais remettre Postfix.

J'ai lu que je devais aller décommenter des lignes dans /etc/postfix/main.cf pour régler le problème d'authentification, mais il n'y a pas grand chose dans le fichier et pas les fameuses lignes


• Pour l'explication du reverse dns, j'ai bien trouvé l'option dans mon manager. Mais je me pose une question, on ne peut en choisir qu'un ? Car j'ai plusieurs domaines, qui utilisent chacun des adresse email donc si je mets un reverse dns d'un des me domaines "mail.xxx.be", que se passe t'il pour les autres domaines ?


Grand merci à toi.

nowwhat
05/02/2016, 17h08
Citation Envoyé par MrLLp
....
J'obtiens un score de 9/10 avec mail-tester, il m'a fait modifier mon champ SPF en v=spf1 +a +mx include:mx.ovh.com ~all
Ajouter "include:mx.ovh.com" ?????
Mais ça implique tu as envoyé des mails avec le serveur mail d'OVH !!!!
Dans ce cas, pas (plus) besoin de t'occuper d'un serveur mail sur ton serveur .....

IL faut envoyer vers https://www.mail-tester.com/ un mail à partir de ton serveur - le serveur mail de ton domaine.
Osef totalement de "mx.ovh.com", tu a été délivré de ce serveur mail extrêmement médiocre - t'as ton propre serveur mail maintenant.

Citation Envoyé par MrLLp
....
Après recherches, j'ai bien cerné tout ce que tu m'as dit :
- DKIM n'est pas encore dispo via Plesk mais apparemment c'est pour bientôt, je vais essayer en ligne de commande mais je n'oserais pas trop m'aventurer
- J'ai du mal à trouver comment ne plus utiliser IPv6 mais je continue à chercher...

- Et une question pour les RDNS :

J'ai lu quelque part "This is something your server/network provider needs to set, not your control panel vendor."
Mais si je comprends bien, le reverse dns est géré via la zone dns de mon domaine, donc via mon Plesk ?
Tu as sûrement un tool pour voir ma zone, je vois qu'il y a déjà : 91.121.76.131 / 24 PTR mrsmith.be.

Je ne suis pas sûr du champ que je dois ajouter pour ce que tu m'as dit ici. Je ne vois pas de champ PTR avec ns3031939.ip-91-121-76.eu.

J'ajoute ça ; 91.121.76.131 / 24 PTR mail.mrsmith.be. ?
Le reverse d'un IPv4 ou IPv6 ne se fait pas avec Plesk, ni nulle part ailleurs sur ton serveur.
Ça se fait ici : https://www.kimsufi.com/fr/manager/?lang=fr_FR#/login (le Manager de KS - car ces deux IP's sont liés à ton serveur)

MrLLp
05/02/2016, 14h57
Hello,

J'obtiens un score de 9/10 avec mail-tester, il m'a fait modifier mon champ SPF en v=spf1 +a +mx include:mx.ovh.com ~all

Après recherches, j'ai bien cerné tout ce que tu m'as dit :
- DKIM n'est pas encore dispo via Plesk mais apparemment c'est pour bientôt, je vais essayer en ligne de commande mais je n'oserais pas trop m'aventurer
- J'ai du mal à trouver comment ne plus utiliser IPv6 mais je continue à chercher...

- Et une question pour les RDNS :

J'ai lu quelque part "This is something your server/network provider needs to set, not your control panel vendor."
Mais si je comprends bien, le reverse dns est géré via la zone dns de mon domaine, donc via mon Plesk ?
Tu as sûrement un tool pour voir ma zone, je vois qu'il y a déjà : 91.121.76.131 / 24 PTR mrsmith.be.

Je ne suis pas sûr du champ que je dois ajouter pour ce que tu m'as dit ici. Je ne vois pas de champ PTR avec ns3031939.ip-91-121-76.eu.

To serveur mail habite ici : mail.mrsmith.be (c'est le URL de ton "MX" qui tu expose au monde), fait en sorte que le reverse se son IP (== 91.121.76.131) est "mail.mrsmith.be" - ne garde surtout pas "ns3031939.ip-91-121-76.eu" comme reverse.
J'ajoute ça ; 91.121.76.131 / 24 PTR mail.mrsmith.be. ?

Merci pour ton aide,
Laurent

MrLLp
05/02/2016, 11h41
Ok super, grand merci pour les réponses, je vais checker tout ça et je reviens ici si j'ai des questions ;-)

Bonne journée

nowwhat
05/02/2016, 09h30
Citation Envoyé par MrLLp
....
J'utilise Plesk pour le forward vers mon compte Gmail ...et un start10m pour l'envoi (histoire avec Google qui a besoin de vérifier un smtp afin de pouvoir envoyer via Gmail).
Attention : recevoir des mails sur ton serveur (tes domaines) pour l'expédier ("forwarder") vers gmail == dangereux.
Avant : c’était une fonctionnalité sympa de regrouper tes mails sur une boit "facile d'accès" (gmail) avec ton propre domaine (sur ton serveur) mais aujourd'hui, c'est négatif !
Aujourd'hui : le premier con qui spam ton boite avec des "pur spam" que ton serveur va bêtement transférer vers ton gmail va résulter à :
=> Gmail va blacklister ton IP / domaine / serveur.
=> KS (OVH) qui surveille tes connections vers TOUTES l'adresses IP, porte 25, va détecter qui tu balance des spams, et va bloquer ta porte "25" pour émission des mails.

Ce qu'il faut faire (et ce n'est pas une option, c'est obligatoire) :
Envoyer tes mails techniquement correctement, ce qui implique :
To serveur mail habite ici : mail.mrsmith.be (c'est le URL de ton "MX" qui tu expose au monde), fait en sorte que le reverse se son IP (== 91.121.76.131) est "mail.mrsmith.be" - ne garde surtout pas "ns3031939.ip-91-121-76.eu" comme reverse.
T'as un champs SPF qui me semble correct.
Ajoute aussi la gestion DKIM !!

Citation Envoyé par MrLLp
....
....
: host
gmail-smtp-in.l.google.com[2a00:1450:400c:c01::1b] said: 550-5.7.1
[2001:41d0:1:8183::1] Our system has detected that this message does
550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and
Ok, ton serveur mail "ose" communiquer avec gmail avec son IPv6 2001:41d0:1:8183::1. (ton serveur possède un IPv6 et un IPv6)
Pourquoi pas ... plus en plus de communication se fait par IPv6, le IPv4 en en voie de disparition.
Mais dans ce cas : gmail t’informe t'as fait n’importe quoi. Le paramétrage n'est pas fini.
PAS de DKIM - et pas (nouveau !!) de DMARC !!!! Une communication IPv6 exige un DMARC correct (et il n'y pas que gmail qui exige ça, presque toutes les free- et pourie-mails exige ça aujourd’hui).

Soit : et c'est encore possible aujourd’hui : interdit simplement ton serveur mail d'utiliser le IPv6 ....

L’utilisation de ton IPv6 nécessite la déclaration d'un champ AAAA dans ta zone DNS, genre
Code:
   IN AAAA  2001:41d0:1:8183::1
mail    IN AAAA  2001:41d0:1:8183::1
et bien sur le reverse de " 2001:41d0:1:8183::1" qui pointe vers mail."mrsmith.be".

Dès que tout ça est ok, et https://www.mail-tester.com/ te donne un 10/10 (c'est le minimum pour que ça risque de fonctionner) ça va durer encore quelques jours (voir semaines, vu que t'as mal mené gmail au début) et tes mails passeront correctement.

janus57
05/02/2016, 07h31
Bonjour,

Resolve Host ns3031939.ip-91-121-76.eu
IP Address 91.121.76.131
Et vu que cela doit être pareil en IPv6 il vous manque clairement un reverse "valide", je vous invite à envoyer un mail ici : web-WmMYei@mail-tester.com
Puis vérifier ici :https://www.mail-tester.com/web-WmMYei

Après pour la config de plesk je vous laisse voir avec leurs guides/forum/support.

Cordialement, janus57

MrLLp
05/02/2016, 00h57
Bonjour/Bonsoir,

J'ai pris récemment un serveur KS-4C que j'utilise pour héberger mes sites personnels et je rencontre des soucis de mail.
Avec 2 noms de domaine, un ancien et un récent mais le problème semble être le même...
J'utilise Plesk 12.5.30 sous CentOS Linux 7.2.1511.

Ip du serveur : 91.121.76.131
Noms de domaines concernés : mrsmith.be (nouveau) et finaltouch.brussels (ancien)

J'utilise Plesk pour le forward vers mon compte Gmail et un start10m pour l'envoi (histoire avec Google qui a besoin de vérifier un smtp afin de pouvoir envoyer via Gmail).

Et donc le cas bizarre c'est que :

- j'arrive à envoyer et recevoir des mails directement de hotmail ou yahoo mail
- venant d'autres domaines (un à moi chez OVH et venant d'un client, qui je pense est aussi chez ovh) je reçois une erreur
- mais bizarrement, ce problème arrive de temps en temps avec mes adresses hotmail et yahoo...

Code HTML:
This is the mail system at host ns3031939.ip-91-121-76.eu.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

: host
    gmail-smtp-in.l.google.com[2a00:1450:400c:c01::1b] said: 550-5.7.1
    [2001:41d0:1:8183::1] Our system has detected that this message does
    550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and
    550-5.7.1 authentication. Please review 550-5.7.1
    https://support.google.com/mail/?p=ipv6_authentication_error for more 550
    5.7.1 information. kz4si20698568wjc.203 - gsmtp (in reply to end of DATA
    command)
Reporting-MTA: dns; ns3031939.ip-91-121-76.eu
X-Postfix-Queue-ID: E8CE82E00054
X-Postfix-Sender: rfc822; webmaster@afenergy.be
Arrival-Date: Fri,  5 Feb 2016 00:45:38 +0100 (CET)

Final-Recipient: rfc822; laurent.dhoop@gmail.com
Action: failed
Status: 5.7.1
Remote-MTA: dns; gmail-smtp-in.l.google.com
Diagnostic-Code: smtp; 550-5.7.1 [2001:41d0:1:8183::1] Our system has detected
    that this message does 550-5.7.1 not meet IPv6 sending guidelines regarding
    PTR records and 550-5.7.1 authentication. Please review 550-5.7.1
    https://support.google.com/mail/?p=ipv6_authentication_error for more 550
    5.7.1 information. kz4si20698568wjc.203 - gsmtp
N'étant vraiment pas spécialiste avec ce sujet, je me demande ce qui pourrait causer ce problème...
Une idée de solution serait la bienvenue !

Merci d'avance,
Laurent