We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Serveur timeout aléatoire, une idée ?


janus57
29/05/2016, 19h04
Bonjour,

les traceroutes c'est pas pour "voir" le timeout mais bien pour que le support vois le chemin aller/retour utilisé pour constater le défaut.

De plus si il y a beaucoup d'infos c'est des infos que le support ne te demandera pas et donc tu gagneras tu temps après si tu as envie de perdre du temps libre à toi de donner le stricte minimum au support.

Cordialement, janus57

aktarus69
29/05/2016, 17h20
Pas de timeout depuis 11h ce matin en rescue après une semaine avec plusieurs timeout / heure , j'ai donc redémarré il y a une heure en normal et ca a l'air de tenir pour le moment.

une intervention divine le jour du Seigneur ?

aktarus69
29/05/2016, 14h22
Citation Envoyé par janus57
Bonjour,

En plus du MTR il faut un traceroute ip src vers serveur + serveur vers ip dst.

En gros de la ou tu lance le mtr il faut un traceroute vers le serveur puis du serveur vers la ou tu fait le MTR.

Cordialement, janus57
Ok mais le traceroute n'est pas dynamique. En gros j'ai les meme info sur le MTR et le traceroute, excepté que sur le traceroute je n'ai qu'une seule tentative de connection.

Je peux le faire sans soucis mais il faut que je le fasse dans une periode de timeout - ce qui m'oblige à rester devant la session SSH - ou à n'inporte quel moment sachant que le chemin emprunté reste le même ?

Ils ont deja l'ip src et l'ip dst - mon serveur - et les deux sont sur le réseau OVH ( j'ai lancé le MTR via SSH et la commande screen à partir d'un VPS OVH).

Merci

janus57
29/05/2016, 13h36
Bonjour,

En plus du MTR il faut un traceroute ip src vers serveur + serveur vers ip dst.

En gros de la ou tu lance le mtr il faut un traceroute vers le serveur puis du serveur vers la ou tu fait le MTR.

Cordialement, janus57

aktarus69
29/05/2016, 12h56
Ok, donc c'est bien ce que je pensais. Le problème ne vient pas de moi
J'en suis a une trentaine de timeout en rescue depuis 0h00. J'ai relancé un autre MTR de 24H en rescue pour renvoyer demain également.

Reste à ce que le support me réponde honnetement maintenant au lieu de me dire durant 48H qu'ils ont fait remonté l'info au service concerné sans aucune autre nouvelle

janus57
29/05/2016, 11h50
Bonjour,

visiblement cette IP est celle du serveur rescue d'OVH.

Le mieux est d'attendre un retour du support si vous avez transmis toute les infos (ip src/ip dst/traceroute/mtr).

Si cela timeout aussi en rescue c'est soit matériel côté serveur soit matériel/logiciel côté OVH vu que le rescue c'est normalement "clean" niveau config.

Cordialement, janus57

aktarus69
29/05/2016, 02h35
J'ai ce genre de ligne dans le syslog :

May 28 23:55:56 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 28 23:56:09 rescue kernel: nfs: server 178.33.124.49 not responding, still trying

plusieurs fois, concordant avec mes timeout, mais rien de plus

aktarus69
29/05/2016, 02h29
J'ai répondu en détail avec log et screen mais apparement ca a été modéré, je ne sais pas pourquoi.

Ce que je peux voir dans les logs a chaque timeout, ce sont des lignes de ce style dans le syslog:

May 28 23:55:56 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 28 23:56:09 rescue kernel: nfs: server 178.33.124.49 not responding, still trying

Edit : screen d'un MTR sur une heure, en rescue. Serveur injoignable durant plus de 3 minutes...


aktarus69
29/05/2016, 02h02
J'ai cela aussi qui est apparu :

May 29 00:52:29 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 29 00:52:52 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 29 00:52:53 rescue systemd[1]: systemd-networkd.service watchdog timeout (limit 1min)!
May 29 00:52:53 rescue systemd-networkd[331]: Received SIGTERM from PID 1 (systemd).
May 29 00:52:53 rescue kernel: nfs: server 178.33.124.49 OK
May 29 00:52:53 rescue kernel: nfs: server 178.33.124.49 OK
May 29 00:52:53 rescue systemd[1]: Unit systemd-networkd.service entered failed state.
May 29 00:52:53 rescue systemd[1]: systemd-networkd.service has no holdoff time, scheduling restart.
May 29 00:52:53 rescue systemd[1]: Stopping Network Service...
May 29 00:52:53 rescue systemd[1]: Starting Network Service...
May 29 00:52:53 rescue systemd-timesyncd[610]: No network connectivity, watching for changes.
May 29 00:52:53 rescue systemd-networkd[1634]: eth0 : gained carrier
May 29 00:52:53 rescue systemd-networkd[1634]: lo : gained carrier
May 29 00:52:53 rescue systemd[1]: Started Network Service.
May 29 00:52:53 rescue systemd-timesyncd[610]: Network configuration changed, trying to establish connection.
May 29 00:52:53 rescue systemd-timesyncd[610]: Using NTP server 217.114.59.3:123 (0.debian.pool.ntp.org).
May 29 00:52:53 rescue systemd-timesyncd[610]: interval/delta/delay/jitter/drift 2048s/+0.004s/0.011s/0.094s/+5ppm

aktarus69
29/05/2016, 01h58
Dispo ici le pastbin du test DD. Si quelqu'un peut me confirmer qu'a part son age, il n'y a rien d'arlarmant :

http://pastebin.com/7jHUdWn1

J'ai bien remarquer une ligne dans le syslog maintenant que t'en parle qui se répète :

May 28 23:55:56 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 28 23:56:09 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 28 23:56:09 rescue kernel: nfs: server 178.33.124.49 OK
May 28 23:56:09 rescue kernel: nfs: server 178.33.124.49 OK

May 29 00:18:46 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 29 00:18:51 rescue kernel: nfs: server 178.33.124.49 OK

May 29 00:40:07 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 29 00:40:29 rescue kernel: nfs: server 178.33.124.49 OK

Une idée ?

Comme vous pouvez le voir, sur un MTR de une heure, 5% de perte, soit environ 3 minutes sur une heure où le site était inaccessible. Et je suis en recue donc exit les problèmes logiciels.


aktarus69
29/05/2016, 00h48
Oui, rien d'étrange en normal ou en rescue. Ou peut-être n'ai je pas cherché au bon endroit.
J'ai fait un tour du coté de /var/log, trier par date et regarder tout ce qui semblait récent. Sans rien remarquer de suspect.

Merci d'avoir pris le temps de me répondre.
Cdlt.

EDIT : Dispo ici le pastbin du test DD. Si quelqu'un peut me confirmer qu'a part son age, il n'y a rien d'arlarmant :

http://pastebin.com/7jHUdWn1

J'ai bien remarquer une ligne dans le syslog maintenant que t'en parle qui se répète :

May 28 23:55:56 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 28 23:56:09 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 28 23:56:09 rescue kernel: nfs: server 178.33.124.49 OK
May 28 23:56:09 rescue kernel: nfs: server 178.33.124.49 OK

May 29 00:18:46 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 29 00:18:51 rescue kernel: nfs: server 178.33.124.49 OK

May 29 00:40:07 rescue kernel: nfs: server 178.33.124.49 not responding, still trying
May 29 00:40:29 rescue kernel: nfs: server 178.33.124.49 OK

Une idée ?

Comme vous pouvez le voir, sur un MTR de une heure, 5% de perte, soit environ 3 minutes sur une heure où le site était inaccessible. Et je suis en recue donc exit les problèmes logiciels.


sloomy
28/05/2016, 22h19
Bonjour,

Et tu as regardé du coté des logs serveurs ?

Cdlt
Bruno

aktarus69
28/05/2016, 15h11
J'ai fait un long test du DD, test without error sur toutes les lignes

aktarus69
28/05/2016, 10h34
Resultat du test du DD :



root@rescue:~# sudo smartctl -a /dev/sda
smartctl 6.4 2014-10-07 r4002 [x86_64-linux-3.14.32-xxxx-std-ipv6-64-rescue] (local build)
Copyright (C) 2002-14, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family: Toshiba 3.5" HDD DT01ACA...
Device Model: TOSHIBA DT01ACA200
Serial Number: 836VLXXVS
LU WWN Device Id: 5 000039 ff3da3039
Firmware Version: MX4OABB0
User Capacity: 2,000,398,934,016 bytes [2.00 TB]
Sector Sizes: 512 bytes logical, 4096 bytes physical
Rotation Rate: 7200 rpm
Form Factor: 3.5 inches
Device is: In smartctl database [for details use: -P show]
ATA Version is: ATA8-ACS T13/1699-D revision 4
SATA Version is: SATA 3.0, 6.0 Gb/s (current: 3.0 Gb/s)
Local Time is: Sat May 28 09:32:39 2016 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x85) Offline data collection activity
was aborted by an interrupting command from host.
Auto Offline Data Collection: Enabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: (15683) seconds.
Offline data collection
capabilities: (0x5b) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
command.
Offline surface scan supported.
Self-test supported.
No Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 1) minutes.
Extended self-test routine
recommended polling time: ( 262) minutes.
SCT capabilities: (0x003d) SCT Status supported.
SCT Error Recovery Control supported.
SCT Feature Control supported.
SCT Data Table supported.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x000b 100 100 016 Pre-fail Always - 0
2 Throughput_Performance 0x0005 138 138 054 Pre-fail Offline - 75
3 Spin_Up_Time 0x0007 127 127 024 Pre-fail Always - 295 (Average 300)
4 Start_Stop_Count 0x0012 100 100 000 Old_age Always - 65
5 Reallocated_Sector_Ct 0x0033 100 100 005 Pre-fail Always - 0
7 Seek_Error_Rate 0x000b 100 100 067 Pre-fail Always - 0
8 Seek_Time_Performance 0x0005 124 124 020 Pre-fail Offline - 33
9 Power_On_Hours 0x0012 098 098 000 Old_age Always - 20770
10 Spin_Retry_Count 0x0013 100 100 060 Pre-fail Always - 0
12 Power_Cycle_Count 0x0032 100 100 000 Old_age Always - 52
192 Power-Off_Retract_Count 0x0032 100 100 000 Old_age Always - 95
193 Load_Cycle_Count 0x0012 100 100 000 Old_age Always - 95
194 Temperature_Celsius 0x0002 193 193 000 Old_age Always - 31 (Min/Max 19/50)
196 Reallocated_Event_Count 0x0032 100 100 000 Old_age Always - 0
197 Current_Pending_Sector 0x0022 100 100 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0008 100 100 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x000a 200 200 000 Old_age Always - 0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Extended offline Completed without error 00% 20767 -
# 2 Short offline Completed without error 00% 14525 -
# 3 Short offline Completed without error 00% 14524 -
# 4 Short offline Completed without error 00% 14524 -
# 5 Short offline Completed without error 00% 12466 -
# 6 Short offline Completed without error 00% 12466 -
# 7 Short offline Completed without error 00% 12458 -
# 8 Short offline Completed without error 00% 12399 -
# 9 Short offline Completed without error 00% 12383 -

SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.

aktarus69
28/05/2016, 02h34
Salut,

Voila j'aimerai savoir si quelqu'un a une idée de ce qui pourrait causer ce problème.

Depuis la fin de la semaine dernière, mon serveur ne répond plus régulièrement, et ce de manière complètement random, pendant quelques dizaines de seconde à chaque fois.
Que ce soit en mode production ou sur le rescue, j'ai le même soucis.
Il y a deux jours, l'équipe d'intervention a changé les cables réseaux, sans succes selon le support. Et depuis, ils ont dit qu'ils ont fait remonter le problème mais je n'ai pas plus d'info et me retrouve avec un serveur bancale, qui a parfaitement bien fonctionné depuis presque un an.
J'ai tester le CPU et RAM via le rescue, RAS.

J'ai fait un test MTR, sur 24H, j'ai quasiment 4% de perte ! C'est à dire que sur les 24 dernières heures, mon serveur n'a pas été joignable pendant 1H au total avec tous ces timeouts cumulés. Précision : le MTR est effectué en remote à partir d'un VPS OVH pour rester sur le même réseau et éviter que d'éventuelles problèmes de ma connection personnel viennent altérer les résultats. Je les considère donc comme valide. 4% de perte en restant intégralement sur le même réseau - moyenne de ping de 0.5 ms - c'est énorme. On est loin du 99.9%...

Une idée ? J'ai fourni toutes les heures trois ou quatre screens avec le MTR au periode avec le soucis, ils me répondent toujours "Merci pour ce complément d'informations" mais au final il ne m'en donne aucune à moi des informations. J'ai bien du envoyer 50 screens aujourd'hui que sur la période 10h-18h... correspondant donc au moins à une cinquantaine de timeout différents...

Merci