We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

VPS Issue, possible attack


Netherblood
28/06/2016, 02h55
Citation Envoyé par nowwhat
Small detail : "KS" is NOT a VPS. This is especially true when your hard disk breaks down (they always do) - With a VPS you wouldn't notice this because you're using disk space that isn't 'yours' to maintain.
A KS : you'll have to re-install everything - OS - your data - your programs.

ALL IP's are known. Actually : all IPv4 were are used elsewhere before YOU get it on your server. It's like a phone number : you are probably using a number that was being used by some else.
So, yes, the spammer is spamming your IP because it's in its 'list'.
Some are spamming all 0.0.0.0 to 256.256.256.256 and yours IS in that range

Btw : Do not expect to be hidden on the net. That like thinking you'll be able to breath at the moon ...


Well, if your PC doesn't ping, then that is an issue not related to KS.


Resetting through the control panel is like ripping out the electric plug on your PC. Do this often enough and data structures on your hard disk will be damaged, and you will have boot issues. Data loss will happen often ....
When you restart, seeing from the outside, your IP will not reply anymore for a small moment. Then it gets back, and everything start over again.

I advice you to use a small script (thousand can be found on the net) that lists IP's that hammer your server, and that you start to blacklist them.
What services are running on your KS ?
Maybe fail2ban can help you ....
Thanks a lot for the advice, this will make me backup my data for sure.
As for the attacks, the problems I was experiencing may have been from insufficient RAM.

nowwhat
27/06/2016, 09h09
Citation Envoyé par Netherblood
A strange thing has been happening with my VPS. I have been getting e-mails about getting attacked days after I bought it. I signed them off as a mistake because nobody even knew the IP and nothing was set up on it yet.
Small detail : "KS" is NOT a VPS. This is especially true when your hard disk breaks down (they always do) - With a VPS you wouldn't notice this because you're using disk space that isn't 'yours' to maintain.
A KS : you'll have to re-install everything - OS - your data - your programs.

ALL IP's are known. Actually : all IPv4 were are used elsewhere before YOU get it on your server. It's like a phone number : you are probably using a number that was being used by some else.
So, yes, the spammer is spamming your IP because it's in its 'list'.
Some are spamming all 0.0.0.0 to 256.256.256.256 and yours IS in that range

Btw : Do not expect to be hidden on the net. That like thinking you'll be able to breath at the moon ...

Citation Envoyé par Netherblood
Later the service it hosts lags, does not respond and SSH disconnects too. While this is happening I tried pinging from my computer and it does ping!
Well, if your PC doesn't ping, then that is an issue not related to KS.

Citation Envoyé par Netherblood
What is even happening, how can I get to the bottom of this? Every time I restart it manually through the control panel and it fixes the problem.
Resetting through the control panel is like ripping out the electric plug on your PC. Do this often enough and data structures on your hard disk will be damaged, and you will have boot issues. Data loss will happen often ....
When you restart, seeing from the outside, your IP will not reply anymore for a small moment. Then it gets back, and everything start over again.

I advice you to use a small script (thousand can be found on the net) that lists IP's that hammer your server, and that you start to blacklist them.
What services are running on your KS ?
Maybe fail2ban can help you ....

Netherblood
26/06/2016, 16h22
A strange thing has been happening with my VPS. I have been getting e-mails about getting attacked days after I bought it. I signed them off as a mistake because nobody even knew the IP and nothing was set up on it yet.
Later the service it hosts lags, does not respond and SSH disconnects too. While this is happening I tried pinging from my computer and it does ping!
What is even happening, how can I get to the bottom of this? Every time I restart it manually through the control panel and it fixes the problem.