We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

acceder au site web de ma CT OpenVZ


patxmay
20/07/2016, 00h52
ok merci
cela semble fonctionner

BBR
19/07/2016, 22h07
10.0.0.0/8 c'est une plage d'IP
10.10.10.10 c'est l'ip attribuée au ct
et tu y accèdes en ssh avec l'ip du serveur 87.98.177.172 mais sur le port 1022

patxmay
19/07/2016, 20h10
ok merci bien
je vais essayer cela mais un coup du met 10.0.0.0 puis apres 10.10.10.10
ce doit etre la meme ip, non ?
et as tu une idee ensuite comment j'accede à mes sites web sur la ct101 ?

BBR
19/07/2016, 19h44
perso j'aurais fait comme ceci car il faut prendre une ip locale, pas une ip sortie de je ne sais où :
Code:
iptables -t nat -A POSTROUTING -s 10.0.0.0/8 -o vmbr0 -j SNAT --to 87.98.177.172
Code:
iptables -t nat -A PREROUTING -i vmbr0 -p tcp -m tcp -d 87.98.177.172 --dport 1022 -j DNAT --to-destination 10.10.10.10:22
et mettre ces lignes dans ton firewall afin que cela soit toujours opérationnel en cas de reboot
et pour voir si c'est ok
Code:
iptables -L -t nat
ce n'est pas une ip locale de ton serveur :

Geolocation Information


patxmay
19/07/2016, 19h15
oui je le pinge

patxmay
19/07/2016, 18h58
je sais pas si je m'exprime bien car j'ai pas trop de compétences dans ces virtualisations :

J'ai un Serveur kimsufi avec deux container OpenVZ :
CT100 : debian7 (IP Adress = 87.98.177.172 c'est mon ip failover)
CT101 : centos6+zimbra (IP Adress = 145.68.49.62) : je sais plus comment cette ip a été défini !!!
je sais que pour mettre al ct101 sur le reseau j'ai exécuté la commande suivante sur la CT de base :
iptables -t nat -A POSTROUTING -s 145.68.49.62/24 -o vmbr0 -j SNAT --to 87.98.177.172
j'ai ensuite redemarré la machine virtuelle 101
puis j'ai redirigé le port 1022 (par exemple) de l'hote 87.98.177.172 vers le port 22 ssh de ma CT101 avec la commande suivante
iptables -t nat -A PREROUTING -i vmbr0 -p tcp --dport 1022 -j DNAT --to 145.68.49.62:22

merci encore pour votre aide

BBR
19/07/2016, 16h32
l'ip 145.xxx est ton ip perso (surfnet) ?
Ton CT doit être sur l'ip FO ou alors en NAT (sur l'IP du serveur)

sloomy
19/07/2016, 15h31
Bonjour,

Tu arrives à la pinger depuis ton hote ?

Cdlt
Bruno

patxmay
19/07/2016, 13h18
bonjour à tous

j'ai cree un CT OpenVZ sur mon serveur dedie kimsufi avec proxmox
j'ai mis la CT sur le réseau avec une ip privé (145.68.49.62) et en Network Type “Virtual Network (venet)”
ma CT est bien sur le reseau mais j'aimerai acceder au site web defini sur l'apache de ma ct
comment faire ?
mon ip failover est 87.98.177.172

merci pour votre aide