We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Configuration DNS Primaire - Secondaire


BBR
21/07/2016, 16h08
et cette config tu l'as bien mise sur EuroDNS?

xVirusproj3ct
21/07/2016, 15h40
( au passage la config , avec des 'x' a la place de l'ip ;P )
Name servers
NameServer1:nsxxxxxx.ip-x-xxx-xx.eu
NameServer2:ns.kimsufi.com

xVirusproj3ct
21/07/2016, 15h33
Citation Envoyé par BBR
où as-tu acheté ton nom de domaine ? c'est chez ce registar que tu vas paramétrer tes DNS en mettant le nom de ton ks en primaire (ns123etc.eu) et en secondaire ns.kimsufi.com
Je l'ai pris chez EuroDNS je pense qu'il y a plus de temps d'attente que prévu pour propager le DNS, je vais être patient et attendre demain je pense que ça ira^^

merci de vos messages

BBR
21/07/2016, 14h00
où as-tu acheté ton nom de domaine ? c'est chez ce registar que tu vas paramétrer tes DNS en mettant le nom de ton ks en primaire (ns123etc.eu) et en secondaire ns.kimsufi.com

xVirusproj3ct
21/07/2016, 11h46
J'ai répondu, le message est en attente de validation
P.S : Je ne peux me connecter seulement au manager KS et non celui de OVH ( je ne sais aps si c'est normal )

xVirusproj3ct
21/07/2016, 11h39
Bonjour et merci pour ta réponse !
J'ai donc configurer mon serveur DNS primaire avec bind selon le modèle suivant :


-- db.webject.fr --
Code:
$TTL 86400
webject.fr.     IN    SOA    ns378141.ip-5-196-67.eu. hostmaster.webject.fr. (
                2016072102  ; serial à changer à chaque modification
                43200       ; refresh, 12h
                3600        ; retry, 1h
                1209600     ; expire
                86400 )     ; negative cache, 24h
webject.fr.    IN     NS   ns378141.ip-5-196-67.eu.
webject.fr.    IN     NS   ns.kimsufi.com.
webject.fr.    IN     A    5.196.67.136
www             IN     A    5.196.67.136
mail           IN     A    5.196.67.136
webject.fr.   IN     MX   10 webject.fr.
ownercheck      IN      TXT     "88c23464"
-- named.conf.options --
Code:
 dnssec-validation auto;

        auth-nxdomain no;    # conform to RFC1035

        listen-on-v6 { ::1; };
        listen-on { any; };
        allow-recursion { 127.0.0.1; ::1; };
-- named.conf.local --
Code:
zone "webject.fr" {
        type master;
        file "/etc/bind/db.webject.fr";
        allow-transfer {213.186.33.199;};
        allow-query{any;};
        notify yes;
};

Je me dis donc que je vais tester si ma conf est bonne, et voici le résultat :
-- Test dns --
Code:
root@ns378141:/etc/bind# named-checkzone webject.fr db.webject.fr
zone webject.fr/IN: loaded serial 2016072102
OK
root@ns378141:/etc/bind# nslookup webject.fr.
Server:         127.0.0.1
Address:        127.0.0.1#53

Name:   webject.fr
Address: 5.196.67.136

root@ns378141:/etc/bind# service bind9 status
● bind9.service - BIND Domain Name Server
   Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: enabled)
  Drop-In: /run/systemd/generator/bind9.service.d
           └─50-insserv.conf-$named.conf
   Active: active (running) since mer. 2016-07-20 11:41:39 CEST; 22h ago
     Docs: man:named(8)
  Process: 7058 ExecReload=/usr/sbin/rndc reload (code=exited, status=0/SUCCESS)
 Main PID: 2190 (named)
   CGroup: /system.slice/bind9.service
           └─2190 /usr/sbin/named -f -u bind

juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: automatic empty zone: 8.B.D.0.1.0.0.2.IP6.ARPA
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: automatic empty zone: EMPTY.AS112.ARPA
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: configuring command channel from '/etc/bind/rndc.key'
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: configuring command channel from '/etc/bind/rndc.key'
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: reloading configuration succeeded
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: reloading zones succeeded
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: zone webject.fr/IN: loaded serial 2016072102
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: zone webject.fr/IN: sending notifies (serial 2016072102)
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: all zones loaded
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: running
root@ns378141:/etc/bind#

Cependant, sur l'interface manager KS, impossible d'ajouter le dns secondaire car il ne valide pas mon ownercheck


Quand tu parles de manager qui n'est pas celui de KS, lequel parles-tu svp?

merci !!

xVirusproj3ct
21/07/2016, 11h38
Bonjour et merci pour ta réponse !
J'ai donc configurer mon serveur DNS primaire avec bind selon le modèle suivant :


-- db.webject.fr --
Code:
$TTL 86400
webject.fr.     IN    SOA    ns378141.ip-5-196-67.eu. hostmaster.webject.fr. (
                2016072102  ; serial à changer à chaque modification
                43200       ; refresh, 12h
                3600        ; retry, 1h
                1209600     ; expire
                86400 )     ; negative cache, 24h
webject.fr.    IN     NS   ns378141.ip-5-196-67.eu.
webject.fr.    IN     NS   ns.kimsufi.com.
webject.fr.    IN     A    5.196.67.136
www             IN     A    5.196.67.136
mail           IN     A    5.196.67.136
webject.fr.   IN     MX   10 webject.fr.
ownercheck      IN      TXT     "88c23464"
-- named.conf.options --
Code:
 dnssec-validation auto;

        auth-nxdomain no;    # conform to RFC1035

        listen-on-v6 { ::1; };
        listen-on { any; };
        allow-recursion { 127.0.0.1; ::1; };
-- named.conf.local --
Code:
zone "webject.fr" {
        type master;
        file "/etc/bind/db.webject.fr";
        allow-transfer {213.186.33.199;};
        allow-query{any;};
        notify yes;
};

Je me dis donc que je vais tester si ma conf est bonne, et voici le résultat :
-- Test dns --
Code:
root@ns378141:/etc/bind# named-checkzone webject.fr db.webject.fr
zone webject.fr/IN: loaded serial 2016072102
OK
root@ns378141:/etc/bind# nslookup webject.fr.
Server:         127.0.0.1
Address:        127.0.0.1#53

Name:   webject.fr
Address: 5.196.67.136

root@ns378141:/etc/bind# service bind9 status
● bind9.service - BIND Domain Name Server
   Loaded: loaded (/lib/systemd/system/bind9.service; enabled; vendor preset: enabled)
  Drop-In: /run/systemd/generator/bind9.service.d
           └─50-insserv.conf-$named.conf
   Active: active (running) since mer. 2016-07-20 11:41:39 CEST; 22h ago
     Docs: man:named(8)
  Process: 7058 ExecReload=/usr/sbin/rndc reload (code=exited, status=0/SUCCESS)
 Main PID: 2190 (named)
   CGroup: /system.slice/bind9.service
           └─2190 /usr/sbin/named -f -u bind

juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: automatic empty zone: 8.B.D.0.1.0.0.2.IP6.ARPA
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: automatic empty zone: EMPTY.AS112.ARPA
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: configuring command channel from '/etc/bind/rndc.key'
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: configuring command channel from '/etc/bind/rndc.key'
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: reloading configuration succeeded
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: reloading zones succeeded
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: zone webject.fr/IN: loaded serial 2016072102
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: zone webject.fr/IN: sending notifies (serial 2016072102)
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: all zones loaded
juil. 21 10:32:03 ns378141.ip-5-196-67.eu named[2190]: running
root@ns378141:/etc/bind#

Cependant, sur l'interface manager KS, impossible d'ajouter le dns secondaire car il ne valide pas mon ownercheck


Quand tu parles de manager qui n'est pas celui de KS, lequel parles-tu svp?

merci !!

nowwhat
21/07/2016, 11h12
Citation Envoyé par xVirusproj3ct
....je voulais demander si c'est normal de ne pas pouvoir gérer ses DNS primaires depuis l'interface du manager KS ?
Normalement, on garde dans le Manager de ton nom de domaine (ce Manager n'est PAS le Manager de ton KS) la gestion de tes DNS de ton nom de domaine.
Pour que le serveur web sur votre serveur KS va servir des pages web de ton http://www.ton-domaine.tld/.... il suffit de modifier le champ "A" dans ta zone pour qu'il pointe vers l'IPv4 (et champ AAAA pour ton IPv6) vers TON serveur KS.
Puis ça roule.

le jour que tu te decide de gérer aussi tes propres mails, genre
ton-domaine.tld
tu change dans ta zone DNS le MX:
1) enlève toutes les chaps MX
puis
2) ajoute un
Code:
  IN MX 10 ton-domaine.tld.
et hoppa, toutes les mails entrent (ceux pour ...@ton-domaine.tld) seront envoyé vers le serveur mail sur ton KS.

Le Manager KS, il faut l'utiliser ainsi :
Pour rien du tout sauf que - si nécessaire - redémarrer ton serveur - mode RESCUE, ou pas.
Quand ça foire un max, pour le ré-installer.
Les stats présent dans ce Manager seront d'une qualité très médiocre.
Ce Manager, pour mes serveur, je ne l'utilsie peu ou pas.
=> Ah si, je vérifie si que le coté facture / paiement tout va bien.

Citation Envoyé par xVirusproj3ct
....
De plus après avoir ajouté le ownercheck dans la config de ma zone cela ne fonctionne toujours pas :/
Rien ne marche si on met pas l'ownercheck. Et c'est normal.
Ça empêche les gens de déclarer un DNS secondaire pour p.e. microsoft.com

Vu que tu désire ajouter un des tes domaines sur le DNS secondaire de ton KS il faut d'abord que le DNS maître ne soit plus ceux d'OVH (ou ailluers sur la planete) : il faut que ça soit :
1) Ton serveur
2) Le DNS secondaire "offert par OVH".
Ce tuto est très vieux : http://guide.ovh.com/InstallDNSSecondaire mais indique la méthode à suivre.

La feuille de route est :
Active un serveur DNS "maître" sur ton serveur - avec l'aide de bind par exemple.
Le serveur maitre sera " ksxxxx.kimsufi.com" (ton serveur KS) et le DNS secondaire "ns.kimsufi.com"
Active le serveur DNS secondaire "ns.kimsufi.com" dans l'onglet DNS du manager de ton KS.
( pour que ça fonctionne, il faut déclarer un champ "ownercheck" dans la zone de ton DNS, cad dans le fichier de ta zone "ton-domaine.tld" - puis test à partir d'ailuers si tout est ok)
Maintenant, dans le Manager ton domaine (OVH, ou pas) vire les deux serveurs DNS en place, et ajoute
1) Ton serveur
2) Le DNS secondaire "offert par OVH" ("ns.kimsufi.com").
Après quelques heures, c'est ton serveur qui sera aussi serveur DNS de ton "ton-domaine.tld"

Autrement dit : te fait pas chier, choisi la méthode simple cité plus haut .... ,)

xVirusproj3ct
21/07/2016, 09h54
De plus, on ne peut pas se connecter sur téléphone portable au manager ( pas responsive )

xVirusproj3ct
21/07/2016, 09h53
Bonjour,
Étant actuellement en pleine configuration de dns apache etc... car je viens de prendre un dédié chez KS, je voulais demander si c'est normal de ne pas pouvoir gérer ses DNS primaires depuis l'interface du manager KS ?
De plus après avoir ajouté le ownercheck dans la config de ma zone cela ne fonctionne toujours pas :/

Merci