We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Soucis pour l'installation d'apache et de PHP et impossible de faire un update !


janus57
14/08/2016, 00h54
Bonjour,

eventuellement faire :
Code:
apt-get autoremove && dpkg --configure -a
Sinon perso j'utilise les dépôts officiel français de debian et non les miroir OVH.

Pour ma part je vois pas le problème (il faudrait check tous les logs).

Cordialement, janus57

interalex
13/08/2016, 19h42
Si seulement c'était aussi simple non cela fait la même chose

janus57
13/08/2016, 18h24
Bonjour,

comme dit le message un "apt-get -f install" ne corrige pas le problème ?

Cordialement, janus57

interalex
13/08/2016, 18h05
lorsque je fait un update avec aptitude le problème est le même, mais le upgrade, lui a fonctionner

interalex
13/08/2016, 17h54
Oui je vient de réessayer et c'est bien un update que je fait
Code:
root@XXXXXXX:~# apt-get update
Hit http://debian.mirrors.ovh.net wheezy Release.gpg
Hit http://debian.mirrors.ovh.net wheezy Release
Hit http://debian.mirrors.ovh.net wheezy/main Sources
Hit http://ftp.debian.org testing Release.gpg
Hit http://debian.mirrors.ovh.net wheezy/contrib Sources
Hit http://debian.mirrors.ovh.net wheezy/non-free Sources
Hit http://debian.mirrors.ovh.net wheezy/main amd64 Packages
Hit http://debian.mirrors.ovh.net wheezy/contrib amd64 Packages
Hit http://debian.mirrors.ovh.net wheezy/non-free amd64 Packages
Hit http://debian.mirrors.ovh.net wheezy/contrib Translation-en
Hit http://debian.mirrors.ovh.net wheezy/main Translation-en
Hit http://debian.mirrors.ovh.net wheezy/non-free Translation-en
Hit http://ftp.debian.org testing Release
Hit http://ftp.debian.org testing/main amd64 Packages/DiffIndex
Hit http://security.debian.org wheezy/updates Release.gpg
Hit http://security.debian.org wheezy/updates Release
Hit http://ftp.debian.org testing/main Translation-en/DiffIndex
Hit http://security.debian.org wheezy/updates/main Sources
Hit http://security.debian.org wheezy/updates/main amd64 Packages
Hit http://security.debian.org wheezy/updates/main Translation-en
Reading package lists... Done
W: Ignoring Provides line with DepCompareOp for package dh-systemd
W: Ignoring Provides line with DepCompareOp for package libjpeg62
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: You may want to run apt-get update to correct these problems
sinon voila ce qu'il se passe quand je fait un "apt-get upgrade"
Code:
root@XXXXXXX~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: apache2-mpm-prefork (> 2.0.52) but it is not installed or
                                apache2-mpm-itk but it is not installed
                       Depends: apache2.2-common but it is not installed
E: Unmet dependencies. Try using -f.

janus57
13/08/2016, 17h50
Bonjour,

pour le début vous êtes sûr que c'est "apt-get update" que vous avez fait ? car visiblement debian n'est pas d'accord et il a dit que c'était plus un upgrade.

Sinon essayer de passer par aptitude plutôt que apt-get car aptitude a un système d'auto-correction plus poussé que apt-get (parfois cela suffit à débloquer la situation).

Cordialement, janus57

interalex
13/08/2016, 17h28
Bonjour,

J'ai depuis quelques années un petit dédié chez kimsufi et il est tourne actuellement sous Debian 7.10 (Wheezy) (64bits) mais j'ai un gros soucis qui m’empêche de mettre a bien la mise en place d'un site.

Tout d'abord je suis dans l'impossibilité de mettre a jour le serveur car lorcque je fait "apt-get update" voila ce qu'il ce passe
Code:
Hit http://debian.mirrors.ovh.net wheezy Release.gpg
Hit http://debian.mirrors.ovh.net wheezy Release
Hit http://ftp.debian.org testing Release.gpg
Hit http://debian.mirrors.ovh.net wheezy/main Sources
Hit http://ftp.debian.org testing Release
Hit http://debian.mirrors.ovh.net wheezy/contrib Sources
Hit http://debian.mirrors.ovh.net wheezy/non-free Sources
Hit http://debian.mirrors.ovh.net wheezy/main amd64 Packages
Hit http://debian.mirrors.ovh.net wheezy/contrib amd64 Packages
Hit http://debian.mirrors.ovh.net wheezy/non-free amd64 Packages
Hit http://debian.mirrors.ovh.net wheezy/contrib Translation-en
Hit http://debian.mirrors.ovh.net wheezy/main Translation-en
Hit http://debian.mirrors.ovh.net wheezy/non-free Translation-en
Hit http://ftp.debian.org testing/main amd64 Packages/DiffIndex
Hit http://security.debian.org wheezy/updates Release.gpg
Hit http://security.debian.org wheezy/updates Release
Hit http://ftp.debian.org testing/main Translation-en/DiffIndex
Hit http://security.debian.org wheezy/updates/main Sources
Hit http://security.debian.org wheezy/updates/main amd64 Packages
Hit http://security.debian.org wheezy/updates/main Translation-en
Reading package lists... Done
W: Ignoring Provides line with DepCompareOp for package dh-systemd
W: Ignoring Provides line with DepCompareOp for package libjpeg62
W: Ignoring Provides line with DepCompareOp for package php-psr-log-implementation
W: Ignoring Provides line with DepCompareOp for package php-seclib
W: Ignoring Provides line with DepCompareOp for package php-sabre-http
W: Ignoring Provides line with DepCompareOp for package php-math-biginteger
W: Ignoring Provides line with DepCompareOp for package pypy-cffi
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package pypy-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python-cffi-backend-api-min
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-max
W: Ignoring Provides line with DepCompareOp for package python3-cffi-backend-api-min
W: You may want to run apt-get update to correct these problems
J'ai tout de meme réussi a installer apache mais impossible de le lancer depuis l'installation de PHP, voila l'érreur quand je fait "/etc/init.d/apache2 start" :

Code:
[FAIL] Starting Apache httpd web server: apache2 failed!
[warn] The apache2 configtest failed. ... (warning).
Output of config test was:
env: 'apache2ctl': No such file or directory
Je suis un peut perdu au beau milieu de tout ces problèmes et je ne sait pas trop quoi faire pour y remédier j'ai pas mal chercher sur le net mais j'ai rien trouver qui ai fonctionné pour ma part..

Merci d'avance pour tous ceux qui se risqueront a m'aider

Cordialement,