We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Serveur innaccessible suite à une commande


nowwhat
16/08/2016, 18h20
[QUOTE=admindunet;198336]j'ai un serveur avec mes sites, j'ai exécuté la commande "iptables -P INPUT DROP"
Sans définir des règles 'pas" adéquates avant ?
T'as raison.
C'est comme tirer la prise RJ45 de ton serveur.
Ça stoppe tout d'une façon très direct.

Citation Envoyé par admindunet
du coup le serveur est innaccessible et ...
Normal.
T'as demandé a été exécute.

Citation Envoyé par admindunet
j'ai reçu ce mail de la part d'OVH :
Vous avez fait la demande d'un reboot hardware à distance sur .......
Moins normal.
Le MTR (les paquetes UDP sortent uniquement) passent encore - et le "ping de vérification" ne sera plus répind par ton serveur.Un mail pour prevebir que ton seruer "à l'air down", ça c'est normal.
Sérieux : ils ont redémarré comme ça ?? (Youpi pour l'état de tes bases etc).

=> Pense à désactiver le MTR si tu persiste ) jouer l'apprentie iptables.

Citation Envoyé par admindunet
Une heure après le service technique a redémarré mon serveur en mode rescue, j'ai donc utilisé le nouvel accès SSH et exécuté "iptables -P INPUT DROP" la commande est passée, j'ai donc redémarré le serveur pour tester si ça marche mais malhereusement il bloque encore et j'ai reçu le même mail qu'avant :

Vous avez fait la demande d'un reboot hardware à distance sur .......
Ah , ceux qui persiste à cogner leur tête contre le m.....
D'ABORD, tu ajoute les règles 'pas' dans INPUT.
Aussi une pour garder les connections dèja 'construit'.
Puis tu bascule le "POLICY" sur DROP (à voir : les millions des tutos concernant ce sujet)

Mas t'as pas du tout a attendre que quelqu’un chez KS pousse sur la bouton reset.
Visite ton Manager de ton KS, et fait le reset toi même .... (comme ça, quand ça foire, t'as que toi même à blâmer)

Citation Envoyé par admindunet
et là il est encore en mode rescue, si je régle le problème normalement mes sites seront fonctionnel même en mode rescue ? je veux dire comment tester si le problème est résolu ou non sans redémarer le serveur en mode normal
T'as loupé un détail majeur.
Quand le mode rescue est démarré, RIEN est lu (donc utilisé) venant de ton disque dur.
Il n'est même "mounté".
Donc même si t'as un script, disons un fichier qui initialise tes règles parafeu au démarre, il ne sera pas exécuté .... donc en mode rescue tout fonctionne. Car .... ce n'est pas du tout TON OS et ton paramétrage qui est pris en compte

Comment accéder à TES données (tes fichiers) quand le mode rescue est acrtivé ? => Forum: How-To - Tutoriels

edit :
Citation Envoyé par admindunet
C'est bon problème résolu :

iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT
C'est la paramétrage par défaut.
Je l'utilise depuis des années (décennies).
Ça fonctionne bien.

nowwhat
16/08/2016, 18h19
[QUOTE=admindunet;198336]j'ai un serveur avec mes sites, j'ai exécuté la commande "iptables -P INPUT DROP"
Sans définir des règles 'pas" adéquates avant ?
T'as raison.
C'est comme tirer la prise RJ45 de ton serveur.
Ça stoppe tout d'une façon très direct.

Citation Envoyé par admindunet
du coup le serveur est innaccessible et ...
Normal.
T'as demandé a été exécute.

Citation Envoyé par admindunet
j'ai reçu ce mail de la part d'OVH :
Vous avez fait la demande d'un reboot hardware à distance sur .......
Moins normal.
Le MTR (les paquetes UDP sortent uniquement) passent encore - et le "ping de vérification" ne sera plus répind par ton serveur.Un mail pour prevebir que ton seruer "à l'air down", ça c'est normal.
Sérieux : ils ont redémarré comme ça ?? (Youpi pour l'état de tes bases etc).

=> Pense à désactiver le MTR si tu persiste ) jouer l'apprentie iptables.

Citation Envoyé par admindunet
Une heure après le service technique a redémarré mon serveur en mode rescue, j'ai donc utilisé le nouvel accès SSH et exécuté "iptables -P INPUT DROP" la commande est passée, j'ai donc redémarré le serveur pour tester si ça marche mais malhereusement il bloque encore et j'ai reçu le même mail qu'avant :

Vous avez fait la demande d'un reboot hardware à distance sur .......
Ah , ceux qui persiste à cogner leur tête contre le m.....
D'ABORD, tu ajoute les règles 'pas' dans INPUT.
Aussi une pour garder les connections dèja 'construit'.
Puis tu bascule le "POLICY" sur DROP (à voir : les millions des tutos concernant ce sujet)

Mas t'as pas du tout a attendre que quelqu’un chez KS pousse sur la bouton reset.
Visite ton Manager de ton KS, et fait le reset toi même .... (comme ça, quand ça foire, t'as que toi même à blâmer)

Citation Envoyé par admindunet
et là il est encore en mode rescue, si je régle le problème normalement mes sites seront fonctionnel même en mode rescue ? je veux dire comment tester si le problème est résolu ou non sans redémarer le serveur en mode normal
T'as loupé un détail majeur.
Quand le mode rescue est démarré, RIEN est lu (donc utilisé) venant de ton disque dur.
Il n'est même "mounté".
Donc même si t'as un script, disons un fichier qui initialise tes règles parafeu au démarre, il ne sera pas exécuté .... donc en mode rescue tout fonctionne. Car .... ce n'est pas du tout TON OS et ton paramétrage qui est pris en compte

Comment accéder à TES données (tes fichiers) quand le mode rescue est acrtivé ? => Forum: How-To - Tutoriels

admindunet
16/08/2016, 15h01
C'est bon problème résolu :

iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT

admindunet
16/08/2016, 14h37
en mode rescue le dossier /etc est le même que en mode ssh normal ? (je dis ça car /home n'est pas le même je ne trouve pas mes fichier

admindunet
16/08/2016, 14h25
salut Janus57, oui j'ai fait erreur dans ma question, la première commande c drop et non accept ^^ c'est à cause de ma nuit blanche.
j'attend que le service technique redémarre mon serveur en rescue pour exécuter un accept car je ne peux pas le redémarrer de mon interface.
Vous pensez que la commande accept s'exécute en ssh rescue comme si on la fait en sssh normal ? (car en mode ssh rescue je ne vois pas mes données du /home)

janus57
16/08/2016, 14h15
Bonjour,

si je régle le problème normalement mes sites seront fonctionnel même en mode rescue ?
non car le mode rescue c'est comme un liveCD, de plus à chaque reboot iptable est vidé sauf si vous avez un script/logiciel qui remet le tout en place.

Avez-vous fait les test hardware en rescue ?

je veux dire comment tester si le problème est résolu ou non sans redémarer le serveur en mode normal
on inspecte les logs, on trouve l'origine du problème, on corrige et en passe en normale.

j'ai un serveur avec mes sites, j'ai exécuté la commande "iptables -P INPUT ACCEPT" du coup le serveur est innaccessible et j'ai reçu ce mail de la part d'OVH :
j'y connais pas grande chose en IPTables (j'y touche jamais, pas besoin), mais cette commande accepte toute les connexion donc elle ne devrait en rien couper votre serveur.

"iptables -P INPUT DROP" la commande est passée
celle-ci par contre coupe tout les connexions entrante de votre serveur, donc super pour isoler votre serveur d'internet.

Aussi petit point finale, en rescue si on veux modifier quelque chose sur son serveur il fut monter voir chrooter les partition (selon le changement à faire).

Cordialement, janus57

admindunet
16/08/2016, 13h52
Bonjour,
j'ai un serveur avec mes sites, j'ai exécuté la commande "iptables -P INPUT DROP" du coup le serveur est innaccessible et j'ai reçu ce mail de la part d'OVH :

Vous avez fait la demande d'un reboot hardware à distance sur .......

Une heure après le service technique a redémarré mon serveur en mode rescue, j'ai donc utilisé le nouvel accès SSH et exécuté "iptables -P INPUT DROP" la commande est passée, j'ai donc redémarré le serveur pour tester si ça marche mais malhereusement il bloque encore et j'ai reçu le même mail qu'avant :

Vous avez fait la demande d'un reboot hardware à distance sur .......

et là il est encore en mode rescue, si je régle le problème normalement mes sites seront fonctionnel même en mode rescue ? je veux dire comment tester si le problème est résolu ou non sans redémarer le serveur en mode normal


Vous avez une idée ?