We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Google refuse des couriels


nowwhat
13/10/2016, 14h45
Citation Envoyé par nicobilaine
Juste un truc : attention avec le forward de mails, car si vous recevez du spam sur cette adresse vous allez le renvoyer vers Gmail qui vous considérera comme spammeur. L'idéal est de garder les mails sur le serveur et les relever automatiquement par la boite Gmail.
Et il y a pire.
Ce n'est pas hyper sorcier de découvrir que tu (Azahiel) gère ton propre serveur mail sur ton KS.
Dès que je recouvre un adresse mail géré par ton serveur, je pourrait lui envoyer des milliers des "vrais spams".
Bien sur, ton serveur va "forward" tout ce mails.
Comme c'est dit plus haut : Google ne sera pas contant du tout, et finalement refuser tout mail venant de ton serveur oendant un bon bout de temps. Car, Google ne pourrait pas savoir que c'est TES mails, venant d'un serveur que TU gère (que tu gère mal car il forward des spams ....).
Sache que OVH (KS) filtre TOUTES nos mails sortent (avec http://www.vadesecure.com/fr/desktop/ ), et quand ton serveur commence à envoyer trop de "pure spams" l'IP de ton serveur va être bloqué vers "toutes les les IP au monde, porte 25" : autrement dit: plus aucun mail sortira de ton serveur.
Quand ça arrive plusieurs fois, tu perdras le droit d'envoyer des mails et il t'auras qu'un choix : changer de serveur (== IP).

Ceci implique que tout 'forward' (et je pense qu'il en existe un paquet) d'un mail va petit à petit disparaitre.

cassiopee
13/10/2016, 03h26
Citation Envoyé par Azahiel
J'ai du abandonner u npeu cette histoire ... IRL d'abord
Pour relever les mail via Gmail sur le serveur.. il me faut dessus autre chose que postfix je suppose?
A partir du moment où il y a déjà un serveur IMAP ou POP3 installé dans le dédié (Dovecot assez souvent),
il n'y a rien de plus à installer dans le dédié.

C'est dans le compte Gmail que l'on va configurer la relève de la boîte aux lettres présente
dans le serveur dédié.

Azahiel
13/10/2016, 00h22
J'ai du abandonner u npeu cette histoire ... IRL d'abord
Pour relever les mail via Gmail sur le serveur.. il me faut dessus autre chose que postfix je suppose?

cassiopee
30/09/2016, 23h50
Citation Envoyé par nicobilaine
Juste un truc : attention avec le forward de mails, car si vous recevez du spam sur cette adresse vous allez le renvoyer vers Gmail qui vous considérera comme spammeur. L'idéal est de garder les mails sur le serveur et les relever automatiquement par la boite Gmail.
Très juste. Gmail est très chatouilleux sur les spams.

nicobilaine
30/09/2016, 12h30
Juste un truc : attention avec le forward de mails, car si vous recevez du spam sur cette adresse vous allez le renvoyer vers Gmail qui vous considérera comme spammeur. L'idéal est de garder les mails sur le serveur et les relever automatiquement par la boite Gmail.

cassiopee
29/09/2016, 13h44
Si la boîte "forum" est vide, c'est parce qu'il y a le .forward qui fait suivre
tout message rentrant vers Gmail. C'est normal.

Si ensuite tu supprimes le .forward, logiquement, les messages reçus restent
dans la boîte "forum" dans ton dédié.

Dans les logs que tu as montré plus haut, on voit un message en provenance de gmail,
à destination de forum. Bien. Ce message est reçu par ton serveur dédié et il est ensuite
forwardé à ton adresse Gmail (grâce au .forward) et Gmail accepte bien le message.

ça c'est ce qui est décrit dans les logs.

Donc si ensuite tu ne vois pas ce message dans Gmail, c'est qu'il doit être "planqué"
quelque part dans l'interface de Gmail. Je crois me souvenir que par défaut
le dossier des Indésirables/Spams n'est pas montré dans Gmail.
Il faudrait donc modifier les paramètres de ta boîte Gmail afin de les afficher.

Azahiel
29/09/2016, 12h55
ok j'ai supprimer le fichier .forward et maintenant forum@ recoit bien le courrier. le problème vient de là ou ce n'est pas suffisant comem manip ou il y a un bug

Azahiel
29/09/2016, 12h21
non non, c'est l'inverse qui ne fonctionne pas

du serveur vers google ca fonctionne...
mais de gmail vers Forum@mondomaine.com ca ne marche pas
pourtant si j'écris de google vers admin@mondomaine.com, là ca fonctionne

le log est le log directement après avoir envoyer le message a forum et admin
mais la boite de forum@ reste vide

et je n'ai pas recus de mail de google que l'adresse n'existe pas donc il est censé etre arrivé.

ou alors c'est le .forward qui débloque, je regarde cela

cassiopee
29/09/2016, 09h26
Non, dans ce contexte, mieux vaut ne pas installer Virtualmin qui rajouterait de la complexité pour rien.

Là d'après tes logs, le message reçu sur "forum@ton_domaine.com" a bien été forwardé à ton adresse Gmail
(et Gmail l'a accepté).

Tu ne l'aurais pas reçu dans les "Indésirables" ou autres "Spam" dans ta boîte Gmail ?

Azahiel
29/09/2016, 01h52
j'etais justement en train de regarder les log
si cela peut t'aider

non je n'ai pas virtualmin mais si il faut je peux cherchera l'installerdu momentqu'il n'entre pas en conflit avec webmin sur le même port
Sep 29 00:37:51 ns352726 postfix/smtpd[28269]: connect from mail-oi0-x22d.google.com[2607:f8b0:4003:c06::22d]
Sep 29 00:37:51 ns352726 postfix/local[28273]: 8358E60225: to=, relay=local, delay=2.2, delays=0.29/0.01/0/1.9, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Sep 29 00:37:51 ns352726 postfix/qmgr[25867]: 8358E60225: removed
Sep 29 00:37:51 ns352726 postfix/smtpd[28269]: C252E60225: client=mail-oi0-x22d.google.com[2607:f8b0:4003:c06::22d]
Sep 29 00:37:52 ns352726 postfix/cleanup[28272]: C252E60225: message-id=
Sep 29 00:37:52 ns352726 postfix/qmgr[25867]: C252E60225: from=<***@gmail.com>, size=2257, nrcpt=1 (queue active)
Sep 29 00:37:52 ns352726 postfix/cleanup[28272]: 14A7E60227: message-id=
Sep 29 00:37:52 ns352726 postfix/local[28273]: C252E60225: to=, relay=local, delay=0.31, delays=0.29/0/0/0.02, dsn=2.0.0, status=sent (forwarded as 14A7E60227)
Sep 29 00:37:52 ns352726 postfix/qmgr[25867]: 14A7E60227: from=<***@gmail.com>, size=2404, nrcpt=1 (queue active)
Sep 29 00:37:52 ns352726 postfix/qmgr[25867]: C252E60225: removed
Sep 29 00:37:52 ns352726 postfix/smtpd[28269]: disconnect from mail-oi0-x22d.google.com[2607:f8b0:4003:c06::22d]
Sep 29 00:37:52 ns352726 postfix/smtp[28277]: 14A7E60227: to=<***@gmail.com>, orig_to=, relay=gmail-smtp-in.l.google.com[2a00:1450:400c:c0b::1a]:25, delay=0.29, delays=0.02/0/0.07/0.19, dsn=2.0.0, status=sent (250 2.0.0 OK 1475102272 x64si22480850wmf.26 - gsmtp)
Sep 29 00:37:52 ns352726 postfix/qmgr[25867]: 14A7E60227: removed
Sep 29 00:41:12 ns352726 postfix/anvil[27980]: statistics: max connection rate 1/60s for (smtp:2607:f8b0:4003:c06::233) at Sep 29 00:34:40
Sep 29 00:41:12 ns352726 postfix/anvil[27980]: statistics: max connection count 1 for (smtp:2607:f8b0:4003:c06::233) at Sep 29 00:34:40
Sep 29 00:41:12 ns352726 postfix/anvil[27980]: statistics: max cache size 2 at Sep 29 00:37:51


Myhostname à bie nete changer postconf - n indique myhostname = mondomaine.com

mais

mydestination = ns352726., mondomaine.com, localhost.com, localhost

cassiopee
29/09/2016, 01h41
Commencer par regarder les fichiers de logs.

Pour la messagerie, ce sera principalement "/var/log/mail.log".

Je n'avais pas percuté que tu utilises webmin : utilises-tu aussi Virtualmin ?

Auquel cas, la plupart des manips sont à faire dans Virtualmin, pas "en direct" dans les fichiers de conf de Postfix
(comme modifier la ligne "myhostname")

Azahiel
29/09/2016, 00h27
Alors probleme

j'ai fait comme tu m'a dis et arreter/relancer postfix
j'ai ecris à forum@mondoamine .com rien n'arrive
par webmin, j'ai donc envoyer un émail du serveur vers ma boite gmail et je le recois mais pas a mon nomdedomaine et dns l'entête tout est bon sauf
Return-Path: pffffffffffffffff encore ce NS

j'ai fait repondre a ce mail mais je ne recois rien non plus ( regarder sur le serveur)... une idée ?

cassiopee
29/09/2016, 00h09
Citation Envoyé par Azahiel
il reste 2 choses
- savoir comment récupérer ou transférer les message qui arriverons a Forum@ sur le serveur
Ok, donc comme il s'agit d'un compte réel ( = compte Linux) et non virtuel, c'est à faire dans un fichier ".forward"
(attention au point en début de nom, c'est un fichier caché au sens Unix)

Ce fichier est à placer dans le répertoire "home" de l'utilisateur ("/home/forum" par exemple) et doit simplement
contenir l'adresse email vers laquelle faire suivre les messages.

Il faudra sans doute redémarrer Postfix ou au moins le relancer ("postfix reload")
afin qu'il prenne en compte.

- dois-faire aussi la validation DKIM ? je regarderais comment faire pour cela
Non, ce n'est pas indispensable.

Azahiel
28/09/2016, 22h06
c'est ce que je me suis dis aussi en prenant ma douche :-) pusique au debut je testait en m'envoyant un email de masse en utilisant que moi comme destinataire :-)

bon alors j'ai modifier aussi sur le forum Admin@.... par forum@..... et l'adresse du compte administrateur aussi car apaprement il figure dans l'entête.
donc maintenant c'est tout propre, dans l'entête des mail que des forum@.....

il reste 2 choses
- savoir comment récupérer ou transférer les message qui arriverons a Forum@ sur le serveur
- dois-faire aussi la validation DKIM ? je regarderais comment faire pour cela

cassiopee
28/09/2016, 21h49
Impeccable

Le fait d'utiliser tantôt l'IPv4 tantôt l'IPv6 dépend peut-être de la fonction utilisée dans le forum ?

Du genre

1) "envoyer un email" => passe en IPv4

2) "recevoir une notification" => passe en IPv6

?

Azahiel
28/09/2016, 21h13
Bon je viens de m'envoyer un mp sur le forum et j'ai recus la notification en ipV6
dans les infos du mail gamil >SPF :PASS avec l'adresse IP 2001:******
et je ne vois plus le NS c'est bien mondomaine.com partout dans l'entête

je finirais par devenir un pro

Azahiel
28/09/2016, 21h07
J'avance aussi de mon coté j'ai modifier le fichier mailname,remplacé NS**** par mondomaine.com et relire la config
maintenant postconf -n me donne bien

myhostname = mondomaine.com

je regarderais dans les prochain mail que je recois :-)

Azahiel
28/09/2016, 19h34
et pour "forum"
forum:x:1002:1000:,,,:/home/forum:/bin/bash

Azahiel
28/09/2016, 19h31
j'ai du mal a comprendre pq certain partent en ipv4 et d'autre ipv6 enfin passons//

cette commande me renvois
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/bin/sh
admin:x:1003:65534:MON NOM prenom:/nonexistent:/bin/false

c'est le bordel a mon avis la dedans, :-) a propos de "forum" webmin getion utilisateur >il me dit faire partie d'un groupe et dans le groupe il n'y est pas lol

cassiopee
28/09/2016, 18h56
Citation Envoyé par Azahiel
L'entete des derniers messages pourra peut être mieux te guider.
A noter que là le message est émis en IPv4

Mais on voit aussi qu'il n'est pas encore émis avec la bonne adresse email d'émission,
d'où le couïnement de Google à propos du SPF

cassiopee
28/09/2016, 18h53
Citation Envoyé par Azahiel
la commande ne donne rien
en utilisateur normale j'ai juste u-bash: postconf : commande introuvable
et en root juste un retour à la ligne invité mais la commande existe en root postconf seul me donne plein de truc
Ok, donc ça veut dire que vraisemblablement ton utilisateur "admin" existe en réel et non en virtuel.

Que donne la commande :

Code:
grep "admin" /etc/passwd
?

Azahiel
28/09/2016, 18h08
L'entete des derniers messages pourra peut être mieux te guider.

Code:
Delivered-To: Monadresse@gmail.com
Received: by 10.182.37.103 with SMTP id x7csp347472obj;
        Wed, 28 Sep 2016 05:19:55 -0700 (PDT)
X-Received: by 10.194.92.145 with SMTP id cm17mr7774135wjb.129.1475065195921;
        Wed, 28 Sep 2016 05:19:55 -0700 (PDT)
Return-Path: 
Received: from mondomaine.com (mail.mondomaine.com. [91.*****])
        by mx.google.com with ESMTP id gi8si8257179wjb.58.2016.09.28.05.19.55
        for ;
        Wed, 28 Sep 2016 05:19:55 -0700 (PDT)
Received-SPF: neutral (google.com: 91.****** is neither permitted nor denied by best guess record for domain of forum@ns******.eu) client-ip=91.******;
Authentication-Results: mx.google.com;
       spf=neutral (google.com: 91.******* is neither permitted nor denied by best guess record for domain of forum@ns*******.eu) smtp.mailfrom=forum@ns*******.eu
Received: by mondomaine.com (Postfix, from userid 1002) id CCEAF601A3; Wed, 28 Sep 2016 13:19:53 +0200 (CEST)
To: monadresse@gmail.com
Subject: Nouvelle réponse à Girafette
X-PHP-Originating-Script: 1002:classEmail.php
MIME-Version: 1.0
Date: Wed, 28 Sep 2016 11:19:53 +0000
X-Priority: 3
X-Mailer: IPS PHP Mailer
Message-ID: <079b7930d9666adac6ba58b350fd99c4@www.objectif-diaporama.com>
From: mondoamine.com 
Content-type: text/plain; charset="UTF-8"

Azahiel
28/09/2016, 17h33
la commande ne donne rien
en utilisateur normale j'ai juste u-bash: postconf : commande introuvable
et en root juste un retour à la ligne invité mais la commande existe en root postconf seul me donne plein de truc

cassiopee
28/09/2016, 14h12
Citation Envoyé par Azahiel
Je ne peux pas tester le mail, j'ai utiliser la limite des 3 mails par 24H..
je viens de regarder les émail utilisateur sur le serveur ( avec webmin) et le dernier message mailler demon était de hier 18h donc avant tout nos changements, j'ai recus dans ma boite G mail un paquet de notifications du forum, apparement cela fonctionne dirait on.
Il faudrait jsute s'assurer que les emails ne proviennent pas d'un auteur tel que "forum@nsXXX.ovh.net"
parce que tôt ou tard, ça finira par bloquer.

Si c'est "forum@ton_domaine.com" (ou autre adresse "...@ton_domaine.com"), alors c'est tout bon à ce niveau.

Bon alors il reste un probléme si un membre écris a admin@mondomaine.com je ne recoit pas le courrier, avant j'avais sendmail et il y avait une option qui renvoyait les message pour admin sur le serveur sur ma boite gmail persso, je ne vois pas cela dans postfix.

je suppose que je vais devoir installer un truc pour gérer les acces pop3 et smtp pour admin ???
Bah non, il suffit de configurer le forwarding que tu veux pour admin@ton_domaine.com.

Il y a différente manière de faire ça, selon la façon dont le compte "admin" existe dans ton serveur dédié.

Que donne comme résultat la commande :
Code:
# postconf -n | grep "virtual"
?

en masquant ton nom de domaine dans les résultats.

Azahiel
28/09/2016, 13h59
Je ne peux pas tester le mail, j'ai utiliser la limite des 3 mails par 24H..
je viens de regarder les émail utilisateur sur le serveur ( avec webmin) et le dernier message mailler demon était de hier 18h donc avant tout nos changements, j'ai recus dans ma boite G mail un paquet de notifications du forum, apparement cela fonctionne dirait on.

Bon alors il reste un probléme si un membre écris a admin@mondomaine.com je ne recoit pas le courrier, avant j'avais sendmail et il y avait une option qui renvoyait les message pour admin sur le serveur sur ma boite gmail persso, je ne vois pas cela dans postfix.

je suppose que je vais devoir installer un truc pour gérer les acces pop3 et smtp pour admin ???

cassiopee
28/09/2016, 13h08
Ok, c'est bon pour le reverse de l'IPv4 maintenant de mon côté également

Azahiel
28/09/2016, 12h45
bug surement ou un truc dans le message qui n'est pas bon

quand je recherche les dns inverse sur mon ipV4 j'ai bien
Résultats de la résolution DNS
IP :91.*****
Nom d'hôte :mail.mondomaine.com
Localisation :France
la propagation dns n'était peut etre pas encore total

Azahiel
28/09/2016, 12h42
?????? j'ai un message ici qu'un modérateur doit valider ma réponse ??? pq ??? pas hier ??? ni le premier message ce matin ?????

Azahiel
28/09/2016, 12h40
sur http://www.dnsfrog.com/fr

j'ai le resultat ipV4
Résultats de la résolution DNS
IP :
91.XXX
Nom d'hôte :
mail.mondoamine.com
Localisation :
France

Azahiel
28/09/2016, 12h39
Je viens de regarder le reverse sur http://www.dnsfrog.com/fr

j'ai
Résultats de la résolution DNS
IP :
91.XXXX
Nom d'hôte :
mail.mondomaine.com
Localisation :
France

Azahiel
28/09/2016, 12h09
Bonjour cassiopee

je viens d'enlever les " pour le dns

et sur le manager ovh j'ai ceci

GERER LES IP
SERVICE NS352 .XXXXX ( mail.mondomaine.com)


2001:XXXXX - mail.mondomaine.com.

91.XXXX - mail.mondomaine .com.

cassiopee
28/09/2016, 10h18
Pour le reverse de l'IPv6, c'est bon.

En revanche le reverse de l'IPv4 est toujours "ns352xxx.ip-91-121-xx.eu".

(à faire/vérifier dans le backoffice d'OVH)

cassiopee
28/09/2016, 10h16
Ok, on avance. Il y a un petit truc qui ne va pas avec les guillemets :

Voici ce que l'on voit actuellement :

Code:
IN TXT "\"v=spf1 +ip4:91.121.xx.xx +ip6:2001:41d:xxxx: +mx ~all\""
ça dépend de l'interface d'o2switch. Peut-être qu'ils en rajoutent automatiquement donc inutile
de les mettre en plus explicitement lors de la saisie (?)

Azahiel
28/09/2016, 02h51
tu n'es pas au lit toi ?

ok changé domaine et les "

Code:
mondomaine.com.    3600    IN    TXT    "v=spf1 +ip4:91.xxxx +ip6:2001:xxx +mx ~all"

bonne nuit.

cassiopee
28/09/2016, 02h39
Citation Envoyé par Azahiel
Bonne nuit Cassiopée merci pour ce soir..... ca m'aide déja pas mal...
...
...
Bonjour Cassiopée
Punaise, courte la nuit

Bon pour cela je ne sais pas si je dois le mettre dans le MX ou dans la zone dns ( c'est séparé chez o2switch)
je l'ai donc placer en mail.mondomaine .com en txt mais pas dans la zone mx.
mail.mondomaine.com. 3600 IN TXT v=spf1 +ip4:91.121.72.5 +ip6:2001:41d0:1:7d05::1 +mx ~all
Non, ça n'a pas de rapport avec l'enregistrement MX. L'enregistrement SPF est un enregistrement
DNS de type texte ( IN TXT) à ajouter au même endroit que les "IN A" et autre "IN AAAA".

Avant le (à gauche du) "IN TXT", il ne doit rien y avoir ou alors le nom de domaine car c'est à lui
que s'applique ce réglage (donc pas à "mail.ton_domaine.com").

Attention à ne pas oublier lesguillemets qui encadrent le SPF.

Le forum est configurer pour écrire avec admin@mondomaine.com
Je peux le changer ( je suppose) mais le pseudo "forum" n'existe pas sur le forum, ce n'est qu'une ID sur le serveur.
Manifestement (cf le premier message d'erreur de Google), les messages ne partent pas avec "admin@ton_domaine.com"
comme émetteur. Après, peu importe que ça soit "admin@...." ou "forum@...", ça c'est plus un détail de confort
pour toi.

On verra ça demain car de toute façon il faudra attendre la propagation DNS de tous les enregistrements DNS
ajoutés/modifiés.

Bonne nuit

Azahiel
28/09/2016, 02h28
Bonne nuit Cassiopée merci pour ce soir..... ca m'aide déja pas mal...
...
...
Bonjour Cassiopée

Citation Envoyé par cassiopee

1) Modifier ton enregistrement SPF au niveau DNS

Pour le point 1 :

Au niveau du SPF, il faut que tu indiques explicitement que ton adresse IPv4 et ton adresse IPv6 sont autorisées
à émettre des messages au nom de ton nom de domaine :

Code:
IN TXT "v=spf1 +ip4:91.121.XXX.XX +ip6:2001:41d0:XXX:XXX:: +mx ~all"
en remplacant bien sûr les "XXX" par les vraies valeurs.
Bon pour cela je ne sais pas si je dois le mettre dans le MX ou dans la zone dns ( c'est séparé chez o2switch)
je l'ai donc placer en mail.mondomaine .com en txt mais pas dans la zone mx.
Code:
mail.mondomaine.com.    3600    IN    TXT    v=spf1 +ip4:91.XXX +ip6:2001.XXXX +mx ~all
Pour le point 2 :
[/B]
Configurer ton logiciel de forum et Postfix
Actuellement les messages sont émis par l'adresse email "forum@ns352xxx.xxxxxx.eu"
ce qui bien sûr ne va pas.

Soit tu peux te contenter de configurer ton logiciel de forum afin qu'il utilise la bonne
adresse email (sans doute quelque chose comme "forum@ton_domaine.com"),
soit il faudra configurer Postfix dans ce sens.

Afin de configurer le forum, il faudra sans doute aller par là :
pour le forum je le connais par cœur ou presque
bon là je t'explique.
Le forum est configurer pour écrire avec "admin@mondomaine.com"
Techniquement Je peux le changer pas de probléme ( je suppose) mais le pseudo "forum" n'existe pas sur le forum, ce n'est qu'une ID sur le serveur.
celui qui m'a mis en place la configurations as fait cet id sur le serveur je ne sais pas pourquoi il y avait deja admin et mon pseudo alors "Forum@"pour tout ce qui est droit du forum sur le serveur je suppose donc c'est lui qui envois les mail par defaut je supose

mais il m'a laché il y a plus 1 ans. depuis je tatonne pour me dépatouiller comme je peux.
pour la petite histoire mon serveur à la base ne me servait que pour seconde life et aussi mes stream dj et radio. donc très peux de trucs installer juste le minimum pour ce que j'en avais besoin. quand O2switch a fini par m’énervé, j'ai tout transférer sur mon serveur c'est là que le membres en qui j'avais confiance m'a aider pour le transfert mais il m'a lacher avant d'avoir mis en place les mail... et les sauvegarde se font a moitier( ce sera un autre sujet) cela a fonctionner pendant plus d'un an mais depuis un moment Google a mit ses barrières. et paf je suis dans la mouise avec mes membres sur le forum



Si ça ne suffit pas à faire en sorte que les emails sortent avec la bonne adresse email,
on verra alors la configuration de Postfix.

PS : Bonne nuit, la suite demain pour moi
Merci et Bonne nuit

cassiopee
28/09/2016, 01h49
Alors oui, une partie des tests sera à faire uniquement demain matin pour cause de propagation DNS.

Mais d'ici là, exercices de nuit :

1) Modifier ton enregistrement SPF au niveau DNS

2) Configurer ton logiciel de forum et Postfix


Pour le point 1 :

Au niveau du SPF, il faut que tu indiques explicitement que ton adresse IPv4 et ton adresse IPv6 sont autorisées
à émettre des messages au nom de ton nom de domaine :

Code:
IN TXT "v=spf1 +ip4:91.121.XXX.XX +ip6:2001:41d0:XXX:XXX:: +mx ~all"
en remplacant bien sûr les "XXX" par les vraies valeurs.

Pour le point 2 :

Actuellement les messages sont émis par l'adresse email "forum@ns352xxx.xxxxxx.eu"
ce qui bien sûr ne va pas.

Soit tu peux te contenter de configurer ton logiciel de forum afin qu'il utilise la bonne
adresse email (sans doute quelque chose comme "forum@ton_domaine.com"),
soit il faudra configurer Postfix dans ce sens.

Afin de configurer le forum, il faudra sans doute aller par là :

https://invisionpower.com/4guides/ho...-settings-r24/

Si ça ne suffit pas à faire en sorte que les emails sortent avec la bonne adresse email,
on verra alors la configuration de Postfix.

PS : Bonne nuit, la suite demain pour moi

Azahiel
28/09/2016, 01h36
ok c'est fait sur les deux ip v4 et V6
mais je pense que je devrais attendre demain que les dns se mettent bien en place car je viens de tester le mail
et j'ai encore ce ns ..... dans le chemin

Nous vérifions si vous avez un serveur email (MX Record) derrière votre nom de domaine ns352726.xxxxxx.eu

Vous devriez publier une entrée DNS (de type MX) sur votre nom de domaine ns352726.xxxxxx.eu ou utiliser une adresse de rebond différente.

Votre adresse IP 91.xxxx est associée au nom de domaine ns352726xxxxxxxeu.
Néanmoins votre message semble être envoyé de mondomaine.com.

Vous devriez modifier le nom d'hôte de votre serveur en ns352726.xxxxxx.eu.

Voici les valeurs testées pour cette vérification:

  • IP: 91.xxxxxxx
  • HELO: mondomaine.com
  • rDNS: ns352726.xxxxxx.eu


cassiopee
28/09/2016, 01h12
Citation Envoyé par Azahiel
Ok mais je dois mettre quoi dans les reverses ?
Cf le message #4 plus haut :

Pour le point n°2 :

a) pour l'adresse IPv4, il faudra indiquer le nom utilisé au point n°1 comme reverse
b) pour l'adresse IPv6, il faudra indiquer le nom utilisé au point n°1 comme reverse

Là également, c'est un nom unique que l'on donnera en reverse aux deux adresses IP
afin que cela corresponde aux manips faites au point n°1.
Le "nom utilisé au point n°1" étant "mail.ton_domaine.com".

Azahiel
28/09/2016, 01h06
Citation Envoyé par cassiopee
J'ai vérifié, c'est impec

La suite, ce sont les deux reverses dans le back-office d'OVH.
Ok mais je dois mettre quoi dans les reverses ?
PS : inutile de cacher tes adresses IP, ce sont des infos publiques (ou alors cache aussi ton nom de domaine)
changer lol merci

cassiopee
28/09/2016, 00h55
J'ai vérifié, c'est impec

La suite, ce sont les deux reverses dans le back-office d'OVH.

PS : inutile de cacher tes adresses IP, ce sont des infos publiques (ou alors cache aussi ton nom de domaine)

Azahiel
28/09/2016, 00h51
pour le mx ok c'est changer aussi
mail.mondomaine.com

Azahiel
28/09/2016, 00h46
Citation Envoyé par cassiopee
Alors, comme entre-temps j'avais trouvé ton nom de domaine , j'ai déjà pu voir pas mal de choses :


2) le nom "mail.ton_domaine.com" existe déjà et est associé à l'adresse IP 109.234.xxx.37, laquelle appartient
à o2switch. Il te suffit de la remplacer par l'IPv4 de ton Kimsufi.

3) reste ensuite à ajouter (dans le backoffice d'o2switch) l'adresse IPv6 correspondant à "mail.ton_domaine.com",
ce que j'indiquais précédemment par :
je viens de le faire justement

Code:
Mondomaine.com.        14400    IN    A    91.xxx.   
www.Mondomaine.com  14400    IN    A    91.xxxx.   
mail.Mondomaine.com.   14400    IN    A    91.xxxx.    
   
Mondomaine.com.        14400    IN    AAAA    2001:xxxxxxx   
www.Mondomaine.com  14400    IN    AAAA    2001:xxxxxx    
mail.Mondomaine.com.  14400    IN    AAAA    2001:xxxxxx


jusque là ok ca devrait etre bon ?

cassiopee
28/09/2016, 00h19
Alors, comme entre-temps j'avais trouvé ton nom de domaine , j'ai déjà pu voir pas mal de choses :

1) au niveau MX, pour le moment, il y a directement ton nom de domaine. ça peut fonctionner ainsi mais bon,
ce n'est pas top, mets plutôt "mail.ton_domaine.com" à la place.

2) le nom "mail.ton_domaine.com" existe déjà et est associé à l'adresse IP 109.234.xxx.37, laquelle appartient
à o2switch. Il te suffit de la remplacer par l'IPv4 de ton Kimsufi.

3) reste ensuite à ajouter (dans le backoffice d'o2switch) l'adresse IPv6 correspondant à "mail.ton_domaine.com",
ce que j'indiquais précédemment par :

Code:
mail.ton_domaine.com. IN AAAA 
Restera ensuite à s'occuper des reverses des deux IP (dans le backoffice d'OVH/Kimsufi cette fois).

Une fois que ça sera fait, on se penchera sur le l'enregistrement SPF (ce qui permet de déclarer au monde entier
quelle(s) adresse(s) IP peuvent émettre des messages au nom de ton nom de domaine).

Azahiel
28/09/2016, 00h07
bon on va commencer par le début en essayant d'aller vite.
j'ai creer mon forum , nom de domaine etc etc chez O2SWITCH. mais c'etait la cata, le site était inacessible trop souvent quelques minutes et ils n' on jamais trouver le pourquoi, au bout d'un an j'ai fini par transférer tout le forum sur mon serveur kimsuffi.
le nom de domaine et les dns sont donc gerer chez eux je vais tenter de trouver ou faire ce MX je suppose que je dois le faire sur l'adresse ip v4 de mon kimsuffi


voici le résultat du test mail




cassiopee
27/09/2016, 23h57
Citation Envoyé par Azahiel
pour le mx... rien de configurer juste installer postfix sans rien y toucher.
Le "MX", c'est l'enregistrement DNS qui déclare quel est le serveur de messagerie en charge
des messages de ton nom de domaine (ce n'est pas directement lié à la configuration de Postfix).

Même si tu ne veux pas gérer de messages en réception, il faudra en déclarer un
(sinon tu ne passeras pas la plupart des barrages anti-spam des gros fournisseurs d'email type
Gmail, Yahoo, Hotmail, etc.)

La déclaration du MX est à faire là où est géré au niveau DNS ton nom de domaine
(si c'est "dnsXX.ovh.net" et "nsXX.ovh.net" qui gèrent ton nom de domaine,
ce sera à faire dans le backoffice du site web d'OVH, dans la partie "Nom de domaine")

Généralement ce sera quelque chose dans le genre :

Code:
ton_domaine.com IN MX 10 mail.ton_domaine.com.
et un peu plus loin dans la zone DNS :

Code:
mail.ton_domaine.com. IN A ww.xx.yy.zz
où "ww.xx.yy.zz" est l'adresse IP de ton dédié.

Ce que je comprends moins c'est que certain mail de notification du forum passent et d'autres pas...
au cas où le forum envois les mail via php et pas via smtp...
Il y a fort à parier que lorsque ça passe, c'est parce que l'émission du message partant de ton serveur dédié
se fait via son adresse IPv4 (laquelle a sans doute déjà un reverse correcte) et qu'inversement, lorsque
ça ne passe pas, c'est parce que le message est émis via son adresse IPv6 (laquelle n'a pas encore
de reverse correct).

Pour chaque adresse IP, il faut que :

1) l'adresse IP corresponde au nom (= déclaration à faire dans la zone DNS)
2) que le nom corresponde à l'adresse IP (= le reverse de l'adresse IP)

sinon Gmail et consorts ne seront pas contents

Donc puisqu'il y a deux adresses IP en jeu, une en IPv4 et une en IPv6,
ces deux points doivent être vérifiés pour les deux adresses IP.

Pour le point n°1 :

a) pour l'adresse IPv4, ce sera un enregistrement DNS de type "IN A" qu'il faudra utiliser
b) pour l'adresse IPv6, ce sera un enregistrement DNS de type "IN AAAA" qu'il faudra utiliser

A noter que pour ces deux enregistrements, il faudra utiliser le même nom, du genre "mail.ton_domaine.com"
(le nom déclaré au niveau de l'enregistrement "IN MX" vu plus haut)

Code:
mail.ton_domaine.com. IN A 
mail.ton_domaine.com. IN AAAA 
Pour le point n°2 :

a) pour l'adresse IPv4, il faudra indiquer le nom utilisé au point n°1 comme reverse
b) pour l'adresse IPv6, il faudra indiquer le nom utilisé au point n°1 comme reverse

Là également, c'est un nom unique que l'on donnera en reverse aux deux adresses IP
afin que cela corresponde aux manips faites au point n°1.

Afin de modifier le reverse dans la copie d'écran que tu montres, il faut cliquer sur la roue crantée
tout à fait à droite de l'écran.

Azahiel
27/09/2016, 23h27
MErci, mais on va commencer par le fin ip v6 et le reverse.

voici ce que j'ai


pour le mx... rien de configurer juste installer postfix sans rien y toucher.

Ce que je comprends moins c'est que certain mail de notification du forum passent et d'autres pas...
au cas où le forum envois les mail via php et pas via smtp...

pour les clients et la lecture mail, non je n'utilise rien je n'utilise pas d'adresse mail de mon domaine, sauf poru envoyer les notifications des membres des sujet qu'ils surveillent, pour le reste je passe par d'autre adresse mail..

nowwhat
27/09/2016, 22h52
Citation Envoyé par Azahiel
Bonjour à tous
pour infos
j'ai juste installer postfix comme serveur mail.
C'est un bon début.
Faut maintenant savoir ce que c'est un mail ..... et là, ça déconne plus : t'as pas le choix. Tu va découvrir que c'est tout un tas de "truc à savoir" (oui, beaucoup de truc !!)
Sinon : les types en face - les serveurs mails de Google, tout la clique de Microsoft, Yahoo, et aussi les FAI locales et nationales n'allons pas aimer tes mails (pour être plus précis : ton serveur mail !) et c'est poubelle direct.

Commence par visiter https://www.mail-tester.com/ - choppe toi le mail 'test' et envoi un mail à partir de ton serveur.
Paramètre ton serveur jusqu'à t'as un 10 sur 10.

Sinon ...... tu gagnera rapidment des mauvias point auprès les serveurs mail dans le monde, et ça, ça pardonne pas ....
Citation Envoyé par Azahiel
je n'ai pas besoin de lire mon courrier sur mon serveur.
postfix ne sert qu'a envoyer les notifications aux utilisateurs de mon forum, rien d'autre
je lit mes émail via le serveur directement, juste aux cas où et pour nettoyer les spam.
Faut être plus précis la.
Tu utilise un client mail (genre Thunderbird ou Outlook), c'est ça ?

Citation Envoyé par Azahiel
voici mon probléme
certain courrier passent sans problème et d'autre sont refusés. tous les refus viennent de Google,enfin je ne recois pas d'autre message de refus d'ailleur en tout cas.
Le message est très clair.
Google te fille même le lien dans l'erreur pour que tu constate toi-même le problème.
Ce n'est pas très compliqué en fait.
Ton serveur utilise le IPv6 pour déliver un mail chez Google => TOI == 2001:41d0:1:7d05::1 vers un serveur de GMail == 2a00:1450:400c:c0c::1a
Donc : le reverse de ton IPV6 ( le 2001:41d0:1:7d05::1 ) doit correspondre à ton MX. Comme le IPv4. Sinon, on te crache dessus. Maintenant, c'est Google et Yahoo qui réagisse comme ça. Bientôt Crosoft aussi ....

Le reverse de ton IPv6, ça se paramètre dans le Manager de ton serveur.

Azahiel
27/09/2016, 22h37
Bonjour à tous
pour infos
j'ai juste installer postfix comme serveur mail.
je n'ai pas besoin de lire mon courrier sur mon serveur.
postfix ne sert qu'a envoyer les notifications aux utilisateurs de mon forum, rien d'autre
je lit mes émail via le serveur directement, juste aux cas où et pour nettoyer les spam.
voici mon probléme
certain courrier passent sans problème et d'autre sont refusés. tous les refus viennent de Google,enfin je ne recois pas d'autre message de refus d'ailleur en tout cas.

This is the mail system at host monsite*****.com.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<*******@gmail.com>: host gmail-smtp-in.l.google.com[2a00:1450:400c:c0c::1a]
said: 550-5.7.1 [2001:41d0:1:7d05::1] Our system has detected that this
message does 550-5.7.1 not meet IPv6 sending guidelines regarding PTR
records and 550-5.7.1 authentication. Please review 550-5.7.1
https://support.google.com/mail/?p=IPv6AuthError for more information 550
5.7.1 . o76si14719277wmg.82 - gsmtp (in reply to end of DATA command)
qui pourrait me guider svp ?