We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

plus de ssh après un hard reboot


nowwhat
27/12/2016, 10h09
Si t'es le seul utilisateur sur le serveur, fait sauter ce protocole de m*rd* qui s’appelle FTP. Ils ont trouvé mieux depuis 1998 : le SFTP. FileZilla saura le faire. Le serveur SSH s'occupe de tout. Zéro paramétrage - Une service en moins. Essayer, c'est adopter.

Le serveur SSH logge toujousr vers UN fichier log : auth.log. Si t'as un OS 'normal' (Debian) il est ici, où sont toutes les fichiers log : /var/log/
De toute façon, avec un service comme FTP à bord t'es déjà obligé d'avoir "fail2ban" ...... donc bizarre que tu poses cette question.

namidaka
27/12/2016, 04h19
Citation Envoyé par nowwhat
Même si 'rien' a changé coté config, une explication (voir des centaines d'autres) pourrions expliquer ce qui ce passé :
La partition, là ou les fichiers log sont déposes, est plein.
Du coup, dès login réussi, la service SSH commence à logger et là, c'est la catastrophe : c'est le déco assuré. Ceci arrive très souvent.

Et t'inquiète, vérifier ce qui se passe dans les divers (4 ou 5) fichiers log de tes principales services n'est pas un acte de "débug" mais une obligation journalière.
Ce comme ça tu découvre ce qui est 'normal', et ce qui n'est pas normal.

Le mode "rescue" te permet aussi de sauvegarder le répertoire /etc/ qui contient env. 99 % de tout la configuration de ton serveur. Ce qui te permet, pendant la réinstallation, de vérifier la nouvelle configuration.
Pas de souci de partition pleine , j'ai qu'une seule partition , la root. (et 1.5 tera d'espace libre)
Par contre quel fichier log tu me conseilles de vérifier?
J'ai seulement ftp , vnc et 2 serveur ark qui tourne sur ce serveur.
De toute façon le souci est réglé j'ai réinstaller le serveur en me levant ^^

nowwhat
26/12/2016, 17h15
Même si 'rien' a changé coté config, une explication (voir des centaines d'autres) pourrions expliquer ce qui ce passé :
La partition, là ou les fichiers log sont déposes, est plein.
Du coup, dès login réussi, la service SSH commence à logger et là, c'est la catastrophe : c'est le déco assuré. Ceci arrive très souvent.

Et t'inquiète, vérifier ce qui se passe dans les divers (4 ou 5) fichiers log de tes principales services n'est pas un acte de "débug" mais une obligation journalière.
Ce comme ça tu découvre ce qui est 'normal', et ce qui n'est pas normal.

Le mode "rescue" te permet aussi de sauvegarder le répertoire /etc/ qui contient env. 99 % de tout la configuration de ton serveur. Ce qui te permet, pendant la réinstallation, de vérifier la nouvelle configuration.

namidaka
26/12/2016, 16h42
Citation Envoyé par nowwhat
Salut,

Pour autant, faut passer par ici : https://forum.kimsufi.com/forumdispl...w-To-Tutoriels
Le hard reboot ou reset n'a jamais réparé des choses, au contraire.

Dès que t'as accès à la mode rescue et que t'as "mount" tes partitions, tu pourrait voir les logs de SSH (dans /mnt/var/log/auth.log ** probablement - mais sachant que t'as pas donné le type de ton OS, ça reste à vérifier).
C'est là ou tu donne des détails pourquoi le log est refusé.
Inspecte aussi les autres logs, d’activités récentes.
Tant que t'as le mode rescue activé, démarre aussi un vérification de ton matériel.

Je te conseille aussi de vérifier ce fichier /mnt/etc/ssh/sshd_config *** (date dernier modif).
Liste-le ici en cas de doute.


Ceci n'est pas un forum support SAV de KS : aucun membre travaille chez KS, nous sommes tous des clients, comme toi, on nous n'avons pas accès à ton serveur.

** ou /var/log/auth.log après avoir "chroot".
*** ou /etc/ssh/sshd_config après avoir "chroot"
Je sais très bien que c'est pas un forum de support SAV , je suis pas venu ici raler , je suis venu ici demander si quelqu'un avez déja eu la même situation .
J'ai peut etre mal formuler ma question:
Je trouve cela etonnant que SSH me réponde pendant une verif fichier. Sur windows pendant une verification des fichiers les services ne se pas démarrés. La SSH il réponds a ma demande de connexion, demande nom d'utilisateur et mdp et m'envoie chier en plus que quand je donne le bon mot de passe.
En attendant toujours rien maintenant et ça fait plus de 12h du coup je reinstall l'os. Etant donné ce que j'avais sur le serveur, c'est plus rapide pour moi de tout reinstaller que d'essayer de debugger le tout.
Merci quant même d'avoir pris soin de me répondre et j'aurais appris ma leçon. Le hard reboot c'est maaaaal!

nowwhat
26/12/2016, 09h32
Salut,

Pour autant, faut passer par ici : https://forum.kimsufi.com/forumdispl...w-To-Tutoriels
Le hard reboot ou reset n'a jamais réparé des choses, au contraire.

Dès que t'as accès à la mode rescue et que t'as "mount" tes partitions, tu pourrait voir les logs de SSH (dans /mnt/var/log/auth.log ** probablement - mais sachant que t'as pas donné le type de ton OS, ça reste à vérifier).
C'est là ou tu donne des détails pourquoi le log est refusé.
Inspecte aussi les autres logs, d’activités récentes.
Tant que t'as le mode rescue activé, démarre aussi un vérification de ton matériel.

Je te conseille aussi de vérifier ce fichier /mnt/etc/ssh/sshd_config *** (date dernier modif).
Liste-le ici en cas de doute.

Pouvez vous me confirmer que le serveur se comport
Ceci n'est pas un forum support SAV de KS : aucun membre travaille chez KS, nous sommes tous des clients, comme toi, on nous n'avons pas accès à ton serveur.

** ou /var/log/auth.log après avoir "chroot".
*** ou /etc/ssh/sshd_config après avoir "chroot"

namidaka
26/12/2016, 04h09
Bonsoir,
Cela fait 25 minutes que j'ai hard reboot mon serveur et impossible de me logguer en ssh
Si je rentre root et un mauvais mot de passe , ca me le redemande
si je rentre root et le bon mot de passe , putty se ferme tout seul.
J'ai demandé a putty de ne plus se fermer sans mon accord et il m'affiche desormais ce message : Connection close by remote host et j'ai en plus la confirmation que le serveur comprends ce que je lui demande car j'ai le message
Last Login : Mon DEC 26 2:58:42 2016 from *monip*
J'ai lu sur un tuto kimsufi que le hard reboot n'etait pas la bonne maniere de reboot et que probablement mon serveur etait entrain de verifier les fichiers.
Pouvez vous me confirmer que le serveur se comporte bien comme ça quand il verifie les fichiers? (je trouve ca etonnant que ssh soit allumés mes refuses mes connexions...)
Combien cela risque-t-il de prendre a votre avis?
Merci de votre Aide,
Namidaka
[EDIT] toujours rien au bout de deux heures
je sais qu'il y a le mode rescue , mais j'ai aucune idée de ce qui pourrait foirer. J'ai touché a rien de sensible avant le reboot , pas touché a iptables , pas touché aux configs de ssh ...
[/EDIT]