We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

ISPConfig ownercheck sur VM


ilou
18/02/2017, 01h51
navré pour le temps de réponse, je n'avais pas vu que quelqu'un avait répondu à mon post.

Depuis j'ai changé un peu mon fusil d'épaule et je ne compte plus utiliser ispconfig, ce pendant je me servirais de tes remarques pour la config de bind sur ma nouvelle solution.

Pour ce qui est de l'utilité des VM avec une seule ip, mon cas est simple : je suis un particulier, je tente de m'auto-former (sans aucun but professionnel), je fais donc beaucoup de tests qui peuvent, parfois, se terminer par une réinstallation du serveur. Les VM me permettent donc d'avoir un serveur "prod" sur lequel j'installe ce qui ne bougera pas et des serveurs test, le tout à moindre coût. Je l'aurais bien fait sur mon serveur maison mais le vieux processeur n'est pas compatible virtualisation, J'ai regardé les serveurs avec plusieurs ip publiques mais on saute nettement une tranche en terme de tarif qui n'est pas compatible avec mon activité réseau "loisir". (je viens déjà de remplacer un KS-2 par un KS-5 et l'écart n'est pas négligeable).

nowwhat
05/02/2017, 01h13
Citation Envoyé par ilou
.....
La ou je sèche c'est sur le ownercheck :
J'ai essayé de le mettre en passant par ISPConfig :
nom d'hote : ownercheck
text : le code fourni
==> ne fonctionne pas

J'ai essayé de le mettre en fin de mon pri.mondomaine.net :
ownercheck IN TXT "lecodefourni"
==> ne fonctionne pas
J'ai bien évidemment reload bind après chaque test.

Quand je dis que ça ne fonctionne pas : sur le panel kimsufi il me remet le message rouge m'indiquant que je dois mettre le ownercheck.

Quelqu'un à une idée/un indice ?
Une.
Le domaine concernant, qui le gère ? Ton serveur - ou plus précisément, bind qui s'exécute dans ton VM ?

Le panel Kimsufu, avant de dire "non, va lancer une requête. Ce requête, va t'il aboutir sut ton serveur DNS (bind) ?
Faut vérifier ^^

Ajoute ceci dans /etc/bindnamed.conf.options :

Code:
logging {
	channel "debug" {
		file "/var/log/bind9/debug.log" versions 10 size 5m;
		print-time yes;
		print-category yes;
		severity dynamic;
	};
	category "default" { "debug"; };
	category "database" { "debug"; };
	category "security" { "debug"; };
	category "config" { "debug"; };
	category "resolver" { "debug"; };
	category "client" { "debug"; };
	category "unmatched" { "debug"; };
	category "network" { "debug"; };
	category "update" { "debug"; };
	category "dispatch" { "debug"; };
	category "dnssec" { "debug"; };
	category "lame-servers" { null; };

	channel "xfer" {
		file "/var/log/bind9/xfer.log" versions 10 size 5m;
		print-time yes;
		print-category yes;
		severity dynamic;
	};
	category "xfer-in" { "xfer"; };
	category "xfer-out" { "xfer"; };
	category "notify" { "xfer"; };


	channel "general" {
		file "/var/log/bind9/general.log" versions 10 size 5m;
		print-time yes;
		print-category yes;
		severity dynamic;
	};
	category "general" { "general"; };
		
	channel b_query {
		file "/var/log/bind9/query.log" versions 10 size 5m;
		print-time yes;
		print-category yes;
		severity dynamic;
	};
	category "queries" { "b_query"; };
};

Tu trouvas ces logs :
/var/log/bind9/debug.log
/var/log/bind9/query.log
/var/log/bind9/xfer.log
/var/log/bind9/general.log

/var/log/bind9/query.log pour les requetes, comme KS(OVH) qui effectue le "ownercheck".
Lance un
Code:
tail -f /var/log/bind9/query.log
avant que tu fasse le check dans le Manager et tu vas bien voir.

/var/log/bind9/xfer.log qui te montre que ns.kimsufi.com procède effectivement au transfert de ta zone.
Etc.

Plein de truc très intéressant.

Citation Envoyé par ilou
.....
Précision sur la règle iptable pour que la partie DNS soit affectée à ma VM :
iptables -t nat -A PREROUTING -p tcp -d MON.IP.PUBLIQUE --dport 53 -i vmbr0 -j DNAT --to-destination IP.DE.LA.VM:53
iptables -t nat -A PREROUTING -p udp -d MON.IP.PUBLIQUE --dport 53 -i vmbr0 -j DNAT --to-destination IP.DE.LA.VM:53
Là, je passe le main.
Avec un KS qui possède qu'UN IPv4 (et IPv6) je n'ai pas compris l'utilité d'un VM.

ilou
05/02/2017, 00h36
Bonjour,

Résolu, mon problème ne venait pas du coté du kimsufi mais du côté OVH qui gardait une partie des enregistrements dns de mon ancien serveur.

Ma conf : un KS-5 avec proxmox et une VM sur debian 8 avec ISPConfig 3.1 installé dessus (via l'autoinstall).
Sur le proxmox j'ai mis les règles iptable qui vont bien pour que les ports utilisés par ISPConfig soient affectés à ma VM.

La ou je sèche c'est sur le ownercheck :
J'ai essayé de le mettre en passant par ISPConfig :
nom d'hote : ownercheck
text : le code fourni
==> ne fonctionne pas

J'ai essayé de le mettre en fin de mon pri.mondomaine.net :
ownercheck IN TXT "lecodefourni"
==> ne fonctionne pas

J'ai bien évidemment reload bind après chaque test.
Quand je dis que ça ne fonctionne pas : sur le panel kimsufi il me remet le message rouge m'indiquant que je dois mettre le ownercheck.

Quelqu'un à une idée/un indice ?

Précision sur la règle iptable pour que la partie DNS soit affectée à ma VM :
iptables -t nat -A PREROUTING -p tcp -d MON.IP.PUBLIQUE --dport 53 -i vmbr0 -j DNAT --to-destination IP.DE.LA.VM:53
iptables -t nat -A PREROUTING -p udp -d MON.IP.PUBLIQUE --dport 53 -i vmbr0 -j DNAT --to-destination IP.DE.LA.VM:53